SPICE doesn't change resolution anymore

MisterY

Well-Known Member
Oct 10, 2016
136
4
58
36
Hi,

My somewhat older Mint VM still works, but if I install a new Linux-VM and set the screen to spice, I got at least a screen but it doesn't resize the resolution anymore if I set the virt-viewer to fullscreen.
As I said my old Mint VM works with fullscreen but other guests not anymore.
What's the problem? How can I solve it? I updated virt-viewer to v7.0 but didn't change anything.

Edit: AND I can't set more than one screen anymore to the Linux-VMs. Except my old Mint VM, here it is still working..
It is not a problem of the client, since my notebook reveals the same problem...

A fresh installed Win 10 Guest works as it should. But Linux not.
 
Last edited:
did you install the spice vdagent inside the vm (the name varies by linux distribution)
 
Hi,
yes, this solved the problem. But I never had to install this before? And in the Proxmox Wiki under Linux is written "All linux distributions released after 2011 have the necessary qxl driver included as a part of the Xorg package."

Now I'm facing this problem: Linux Mint works, but if I use something else for example Linux MX, then changing of the resolution only works AFTER hitting the "shutdown button" inside the VM. Beforehands it doesn't change the resolution. But I can see the commands for shutting down in FHD now...

Edit: I tried Kubuntu and Xubuntu and here its the same problem: If the VM is going down I can have FHD, but not with the VM running...
 
Last edited:
All linux distributions released after 2011 have the necessary qxl driver included as a part of the Xorg package."
yes that is the driver for the display, but has nothing to do with resizing, for this, the vdagent needs to be installed

But I never had to install this before?
some distributions/desktop environments install them by default, maybe some of them dropped the dependency


Now I'm facing this problem: Linux Mint works, but if I use something else for example Linux MX, then changing of the resolution only works AFTER hitting the "shutdown button" inside the VM. Beforehands it doesn't change the resolution. But I can see the commands for shutting down in FHD now...

Edit: I tried Kubuntu and Xubuntu and here its the same problem: If the VM is going down I can have FHD, but not with the VM running...
did you install the vdagent there also ?
 
Yes I did and the service is running. And as I said it works as it should right AFTER I hit the shutdown button inside the VM or in the proxmox GUI over qemu. I can see the shutdown screen in FHD until the windows closes because of the turned off VM.
 
ok after testing this, it seems the window manager/desktop environment has to support the resolution change (see also https://bugzilla.redhat.com/show_bug.cgi?id=1290586 )
with ubuntu 18.10 (gnome3) it worked out of the box
with xubuntu 18.04 i had to execute 'xrandr --output Virtual-0 --auto' after resizing the window to correctly choose the resolution
i do not believe there is anything we can do from the proxmox side here, maybe you want to file a bug against the relevant desktop environments/window managers ?
 
With Kubuntu 18.04 I'm sure it worked fine (up to resolution 1920x1200 or something like that), but after upgrading Proxmox some time ago, it does not work anymore even in VM I don't upgrade at all.
I don't mean "dynamic resolution", but simply changing resolution with the screen setup panel briefly blinks to the desired resolution and then goes back to 1024x768.
BUT I've noticed that:
If I enlarge the screen (dragging one corner) then the resolution is still the same, just "scaled".
THEN if I change resolution through the KDE config panel, it works! Forth and back, I mean after that I can set to 1920x1080 and works, then to 1024x768 and works, then back to 1920x1080 and works again (of course, after power off/on I've the problem again, the resolution is not "persistent").
Seems that at startup the window that pops up in my PC (and that shows guest desktop) has a sort of "lock" that breaks after I resize.
Could also be an update on my PC side (debian sid, now virt-viewer 7.0-2, libspice-client-gtk-3.0-5:amd64 0.37-1)
Hope it helps, thanks a lot
Code:
# qm config 611
agent: 1
boot: cd
bootdisk: scsi0
cores: 4
description: Kubuntu 18.04 with Lazarus
ide2: none,media=cdrom
memory: 4096
name: kub1804Lazarus
net0: virtio=82:B8:93:13:1C:06,bridge=vmbr0
numa: 0
ostype: l26
scsi0: local:611/vm-611-disk-0.qcow2,discard=on,size=32G
scsihw: virtio-scsi-pci
smbios1: uuid=049dbf7d-b2ab-4730-85fd-a0b20bd10977
sockets: 1
vga: qxl,memory=32
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!