spf softfail for ip sender in header


Jul 17, 2014
hi! I use proxmox mail gateway 7. When i send email the header fail for ip local header apper in header.

Received-SPF: softfail (fcen.uba.ar: Sender is not authorized by default to use '*****@fcen.uba.ar' in 'mfrom' identity, however domain is not currently prepared for false failures (mechanism '~all' matched)) receiver=mailgateway0.fcen.uba.ar; identity=mailfrom; envelope-from="******@fcen.uba.ar"; helo="[]"; client-ip=*******
Received: from [] (*****************)
by mailgateway0.fcen.uba.ar (Proxmox) with ESMTP id D0321809B7
for <ccc@fcen.uba.ar>; Sun, 26 Sep 2021 02:29:35 -0300 (-03)

if posible delete helo="[]" and Received: from []?

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
Not sure if I read the limited logs right (from which system are the logs?)

but - the sending server has the ip -(and no reverse DNS-entry) - you cannot delete the lines that are logged.

If there's a SPF failure on PMG - this is likely a misconfiguration - you need to send mails coming from your internal systems to the internal port (26) on PMG

If you really mean that the IP is in the header when you send mail through PMG - check the option 'Hide Internal Hosts' under GUI->Configuration->Mail Proxy -> Options

If this is not your questions -please provide more details and logs showing what is not working as you expect it and what you would like to have

I hope this helps!


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!