[SOLVED] Some VM migrations fail, but only between certain nodes


New Member
Jun 2, 2014
Hi there,

As intro: I've recently changed a bunch of node names / hostnames.

Things mostly work, except for one particular oddity.

In my 6-node cluster, using Ceph as shared storage, with HA configured, fencing working, etc. I can live-migrate my VMs from anywhere to anywhere else, EXCEPT for one particular node.

Let's say I have nodes A, B, C, and X. Migrations A<=>B, A<=>C, A=>X, B<=>C, B=>X and C=>X work just fine BUT X=>B and X=>C fail, only X=>A works.

In other words, everyone can "send" VMs to X, but once on X, they can only be migrated to, A, but none of the other nodes. All other pairwise migrations (not involving X) work.

Any idea what might cause this? Any suggestions how to better debug this?

Here's the syslog:

[COLOR=#000000][FONT=tahoma]Nov  7 17:07:14 ve44-b1 rgmanager[3467]: Migrating pvevm:10071 to ve23-b1[/FONT][/COLOR]
[COLOR=#000000][FONT=tahoma]Nov  7 17:07:15 ve44-b1 pvevm: <root@pam> starting task UPID:ve44-b1:0000B0A8:021FC6B2:545CEE33:qmigrate:10071:root@pam:[/FONT][/COLOR]
[COLOR=#000000][FONT=tahoma]Nov  7 17:07:15 ve44-b1 task UPID:ve44-b1:0000B0A8:021FC6B2:545CEE33:qmigrate:10071:root@pam:: migration aborted[/FONT][/COLOR]
[COLOR=#000000][FONT=tahoma]Nov  7 17:07:15 ve44-b1 pvevm: <root@pam> end task UPID:ve44-b1:0000B0A8:021FC6B2:545CEE33:qmigrate:10071:root@pam: migration aborted[/FONT][/COLOR]
[COLOR=#000000][FONT=tahoma]Nov  7 17:07:15 ve44-b1 rgmanager[3467]: migrate on pvevm "10071" returned 150 (unspecified)[/FONT][/COLOR]
[COLOR=#000000][FONT=tahoma]Nov  7 17:07:15 ve44-b1 rgmanager[3467]: Migration of pvevm:10071 to ve23-b1 failed; return code 150[/FONT][/COLOR]
[COLOR=#000000][FONT=tahoma]Nov  7 17:07:15 ve44-b1 corosync[3107]:   [CMAN  ] daemon: read 0 bytes from fd 35[/FONT][/COLOR]
[COLOR=#000000][FONT=tahoma]Nov  7 17:07:15 ve44-b1 corosync[3107]:   [CMAN  ] daemon: Freed 0 queued messages[/FONT][/COLOR]
[COLOR=#000000][FONT=tahoma]Nov  7 17:07:15 ve44-b1 pvedaemon[45220]: command 'clusvcadm -M pvevm:10071 -m ve23-b1' failed: exit code 239[/FONT][/COLOR]
[COLOR=#000000][FONT=tahoma]Nov  7 17:07:15 ve44-b1 pvedaemon[3751]: <root@pam> end task UPID:ve44-b1:0000B0A4:021FC679:545CEE32:hamigrate:10071:root@pam: command 'clusvcadm -M pvevm:10071 -m ve23-b1' failed: exit code 239[/FONT][/COLOR]

Thanks for your help !!
Last edited:
Yes, they are.

But I solved the issue. It had to do with SSH authentication I believe.

I manually tried to SSH from every node to every other node, and I noticed that in some cases I got the usual first-time-SSH-question (The authenticity of host ......... can't be established). Upon answering all those with "yes", all migrations now work.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!