[SOLVED] Senden über Mailgateway schlägt fehl: Relay access denied

Discussion in 'Proxmox Mail Gateway (Deutsch)' started by Thomas Stofer, Jul 28, 2018.

  1. Thomas Stofer

    Thomas Stofer Member
    Proxmox VE Subscriber

    Joined:
    Oct 29, 2017
    Messages:
    58
    Likes Received:
    0
    Hallo,

    ich versuche gerade zum Testen des Mailgateways über SMTPTool eine Nachricht über das Mailgateway los zu werden. Was immer ich konfiguriere, es klappt nicht.
    Zuerst mal meine Einstellungen:

    upload_2018-7-28_13-51-39.png
    Wenn ich das richtig verstanden habe ist das die Einstellung für das Versenden vom internen Mailserver, oder? Dann muss ich hier den Port 26 eintragen, oderverstehe ich das falsch?

    Bei Relay Domänen habe ich die IP Des Rechners über den ich die Mail senden will, also den internen Mailserver.

    Ports:
    upload_2018-7-28_13-54-9.png
    Unter Netzwerke hab ich mal nichts und mal das Netzwerk in dem sich der Client befindet eingetragen, war aber wurscht...

    So nun das Problem:
    Wenn ich über Port 36 verbinde:
    upload_2018-7-28_13-56-46.png

    Bleibt das ganze so stehen und bricht mit timeout irgendwann ab. Im Mailgateway taucht dann gar nichts auf.
    Wenn ich das gleiche auf Port 26 mache, dann wird das im SMTPTool mit folgender Fehlermeldung quittiert:
    Code:
    220 pmg01.ifsb.local mail.seite-zum-testen.de
    250-pmg01.ifsb.local
    250-PIPELINING
    250-SIZE 10485760
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 SMTPUTF8
    250 2.1.0 Ok
    454 4.7.1 <empfänger@domain.com>: Relay access denied
    554 5.5.1 Error: no valid recipients
    Im Mailgateway wird folgendes gezeigt:
    Code:
    Jul 28 13:59:27 pmg01 postfix/smtpd[18323]: connect from unknown[10.241.102.103]
    Jul 28 13:59:29 pmg01 postfix/smtpd[18323]: NOQUEUE: reject: RCPT from unknown[10.241.102.103]: 454 4.7.1 <empfänger@mail.com>: Relay access denied; from=<absender@seite-zum-testen.de> to=<info@ts-cs.com> proto=ESMTP helo=<seite-zum-testen.de>
    Das mit den Ports ist in der Doku wohl etwas unklücklich gemacht. Man erkennt so schlecht welche Einstellungen für den internen Mailverkehr gelten und welche für den Mailverkehr ins Internet...

    Danke für die Hilfe hier!
     
  2. Thomas Stofer

    Thomas Stofer Member
    Proxmox VE Subscriber

    Joined:
    Oct 29, 2017
    Messages:
    58
    Likes Received:
    0
    Hallo,
    ich habe es selber hinbekommen. Damit das aber hier auch für finder des Treads passt, hier die Lösung:
    Einstellungen Mailgateway:
    upload_2018-7-28_17-21-28.png
    upload_2018-7-28_17-22-1.png

    upload_2018-7-28_17-22-40.png

    upload_2018-7-28_17-23-10.png

    Bei Netzwerken hab ich nichts eingetragen, die Domain steht ja in Relay Domänen.
    Ein Fehler war dann noch im SMTP Tool, da muss unter den Mailtest mit einer Leerzeile noch der "." Punkt...
    Jetzt läuft es durch:
    upload_2018-7-28_17-33-44.png

    Die Mail wurde auch nach aussen zugestellt! :)

    Schönes Wochenende an alle die das lesen...!!!!
    Thomas
     
  3. achim22

    achim22 Member

    Joined:
    May 21, 2015
    Messages:
    166
    Likes Received:
    0
    Hallo Thomas,
    ich bin gerade dabei das Mailgateway zu testen. Vielleicht kannst Du mir die ein oder andere Frage beantworten, da diese Thematik nicht so ganz klar ist für mich.
    Da ich den Mailserver von einem Hoster nutze muss ich doch bei Ihm, im MX record, die IP von dem Mailgateway eintragen. So werden die Mails erst einmal den Filter durchlaufen, richtig?

    Behält das Mailgateway dann die Mails die jetzt von einem Client abgeholt werden oder muss ich die Mails erst wieder zu dem Mailserver des Hosters schicken und die Clients holen die "sauberen" Mails dann dort ab?

    Vorab danke für die Antwort
    Gruß
     
  4. Thomas Stofer

    Thomas Stofer Member
    Proxmox VE Subscriber

    Joined:
    Oct 29, 2017
    Messages:
    58
    Likes Received:
    0
    Hallo Achim,
    also:
    Du trägst (wie Du oben schreibst) den Proxmox beim Hoster ein. Wichtig ist hierbei auch die Subdomain für mail.deinedomain.de anzulegen und auf die IP des Mailservers die Du für Deinen Mailserver angelegt hast zu hinterlegen.

    Sollte dann so aussehen:
    upload_2018-8-4_15-11-22.png
    Das Gateway speichert dann die Mails (genügend Speicher muss natürlich da sein) bis Du die Mails mit einem Client beim Mailgatway abholst. Ich habe zum Testen auf einem Windows Rechner hmailserver installiert, der das dann abgeholt hat. Dort kannst Du imap oder pop einstellen und es z.B mit Thunderbird abholen. Einfach zum Testen.
    Normalerweise hast Du ja auf dem Server dann ein Exchange der das vom Mailgateway annimmt. Dem (oder dem Hmail Server) sagtst Du dann das auf der internen IP des Gateway lauscht. Im Gateway trägst Du unter Transports die relaydomaine und die IP des Rechners mit dem Mailserver ein. Dann schickt der das auf port25 dorthin.

    Ich hoffe da kannst Du was anfangen damit...
    LG
    Thomas
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice