[solved] restarting resulted in "timed out for waiting the udev queue being empty"


New Member
Jul 28, 2023
I'm still kind of new to proxmox. I paused and shut down my VMs, click "shut down node" and then moved my hardware. When I turned it back on, I got the above error, as well as

[ TIME ] Timed out waiting for device dev-sdb.device - /dev/sdb
[DEPEND] Dependency failed for mnt-vmstorage.mount - /mnt/vmstorage
[DEPEND] Dependency failed for local-fs.target - Local File Systems

It then asks for my root password in recovery mode. I'm not sure what to do here. The only storage I had on this device was a brand-new HDD (which I've removed for testing) and an NVME SSD.

I've tried a few things I found on google, like https://forum.proxmox.com/threads/timed-out-for-waiting-for-udev-queue-being-empty.129481/

but it didn't work. I'm not sure what could have happened, it and all the VMs were working just fine before the restart.
I fixed it; something in my fstab file was preventing boot. Unfortunately, I think it was working since now I'm unable to mount one of my HDDs, so I'll have to figure out what's going on with that


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!