Slow ethernet cable connection

carlolito

New Member
Apr 8, 2022
4
0
1
My ethernet connection seems to be capped at 100MB/s which I would like to change to 1000MB/s.

I'm with Proxmox 7.2-11
The command

ethtool enp0s31f6

give me :

Code:
Settings for enp0s31f6:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Speed: 100Mb/s
    Duplex: Full
    Auto-negotiation: on
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    MDI-X: on (auto)
    Supports Wake-on: pumbg
    Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
    Link detected: yes

and the command

mii-tool -v enp0s31f6

Code:
enp0s31f6: negotiated 1000baseT-FD flow-control, link ok
  product info: vendor 00:aa:00 or 00:55:00, model 10 rev 0
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
  link partner: 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control

I tried multiple cable, (other devices with these cable are capable of 1Gbit/s), noting is changing. If try to force with

ethtool -s enp0s31f6 speed 1000 duplex full autoneg on

But this just crash my connection. What can I do ? Thanks a lot !
 
How do you benchmark your network speed?
Do you mean MB/s (MegaBYTES/Second) or Mb/s (MegaBITS/Second)? If the former, then you won't be able to get more than ~100MB/s from your Gigabit NIC.
 
I have around 10.4MB/s (MegaBYTES/Second) on this device and 100 MB/s on other device on the same network.
Speed is "Speed: 100Mb/s" display with command "ethtool enp0s31f6"
 
Can you provide the model of the NIC? Which firmware version is it running?
 
Some informations :


ethtool -i enp0s31f6

Code:
driver: e1000e


version: 5.15.64-1-pve


firmware-version: 0.13-4


expansion-rom-version:


bus-info: 0000:00:1f.6


supports-statistics: yes


supports-test: yes


supports-eeprom-access: yes


supports-register-dump: yes


supports-priv-flags: yes



sudo lshw -class network



Code:
*-network


       description: Ethernet interface


       product: Ethernet Connection I219-LM


       vendor: Intel Corporation


       physical id: 1f.6


       bus info: pci@0000:00:1f.6


       logical name: enp0s31f6


       version: 21


       serial: 30:e1:71:85:e9:b2


       size: 100Mbit/s


       capacity: 1Gbit/s


       width: 32 bits


       clock: 33MHz


       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation


       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=5.15.64-1-pve duplex=full firmware=0.13-4 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s


       resources: irq:124 memory:e1200000-e121ffff



Thanks !
 
Check the switch side. Maybe it is set to 100Mbps or may is unable to negotiate 1Gbps correctly.

BTW, your ethtool ouput shows MDI-X: on (auto) which makes me think that either you are using a crossover cable or the switch has MDI-X forced to on.
 
Yes I used a crossover cable for this. I tried with regular cable. Same result. I checked the switch side, I have three other device on the switch they are all on 1Gbps. I try different cable same result, different plug on the switch same result.
 
Hi,

I'm having the same issue on one of my PCs with a Realtek NIC and an Intel NIC installed.
(Lenovo m920q Tiny)

The Realtek NIC only gets an offer from the link partner with 100Mb - no matter if connected to a Fritzbox, Gigabit Switch and which Cable I use.
But the fun fact - also on the second NIC (an Intel NIC that is onboard on that PC) is falling down to 100Mb. And that happens on a Gigabit Switch with a cable from which I know that it worked before on the same machine (before the second NIC was installed).

But the parallel running system with two Intel NICs doesn't have such issues...
(Dell Optiplex Micro 5090)

Did you solve your issue in the meantime?

Settings for eno1:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Speed: 100Mb/s
Duplex: Full
Auto-negotiation: on
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
MDI-X: off (auto)
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000007 (7)
drv probe link
Link detected: yes



driver: e1000e
version: 5.15.85-1-pve
firmware-version: 0.5-4
expansion-rom-version:
bus-info: 0000:00:1f.6
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: yes




Settings for enp2s0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full

Link partner advertised pause frame use: Symmetric
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 100Mb/s
Duplex: Full
Auto-negotiation: on
master-slave cfg: preferred slave
master-slave status: slave
Port: Twisted Pair
PHYAD: 0
Transceiver: external
MDI-X: Unknown
Supports Wake-on: pumbg
Wake-on: d
Link detected: yes


driver: r8169
version: 5.15.85-1-pve
firmware-version: rtl8168e-3_0.0.4 03/27/12
expansion-rom-version:
bus-info: 0000:02:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: yes
supports-priv-flags: no
 
Hi,

You could try disable autonegotiation speed , and setup 1000 base full duplex on Intel interface . And if it do not work, try to setup the same speed on the switch port. Some ethernet combination does not work with autonegotiation.

Good luck/Bafta!
 
Meanwhile I solved my problems.
I set the speed manually and switched to another port of the switch. The onboard Intel chip was working afterwards with 1 GBit.

The other side I only solved by changing the Realtek RTL8111F against a Realtek RTL8125B
Seems like the RTL8111F causes a lot more issues with the drivers than the RTL8125B (as far as I saw when I searched for possible solutions).
(Biggest problem here for me was, that it needs to be a m.2 interface card with only a 2230 size so that it fits into the socket for the WLAN card of the Lenovo SFF Tiny PC).


So for the thread opener: I would also suggest to try to set the speed manually.


Some more findings from my side:
For Realtek I would suggest to avoid the RTL8111x chipsets due to bad driver support (btw. it also didn't work as expected with the 6.1.10 opt-in kernel)

Another funny issue I realized when I tried to solve these issues:
I use 2,5 Gbit USB 3.0 Ethernet NICs for a direct connection between the Cluster nodes. On the Dell Optiplex, the adapter was only recognized as USB2.0 (but all ports of the Optiplex are at least USB3.0 Gen1). It turned out that it depends on the direction of the USB-C to USB-A Adapter. As far as I knew before, it should not matter for a USB-C connector in which direction it is plugged in. But when I turned it 180 degrees, it was working as USB 3.0. I repeated this three times - always the same (really, really strange... also with a different USB C to A adapter).
 
Last edited:
I'm not the original guy who opened the topic. Just another one with the same or similar problem.
Just wanted to share my findings / solution.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!