[SOLVED] RRD: Illegal attempt to update

bootsie123

Well-Known Member
Dec 29, 2018
53
12
48
Hi. When looking into my Syslog I keep seeing an error message related to rrdcached and the system time.

Aug 07 18:38:30 vmworld rrdcached[3793]: queue_thread_main: rrd_update_r (/var/lib/rrdcached/db/pve2-vm/105) failed with status -1. (/var/lib/rrdcached/db/pve2-vm/105: illegal attempt to update using time 1565217220 when last update time is 1565225776 (minimum one second step))

This message repeats for all files in the /var/lib/rrdcached/db directory.

I've tried clearing out the rrdcached directory, resetting the system time in my systems BIOS and also installing ntp and using that instead of systemd-timesyncd. Currently ntp is uninstalled and I am using systemd-timesyncd.

If you need anything else let me know! Thanks!

timedatectl output:
Code:
root@vmworld:~# timedatectl
      Local time: Wed 2019-08-07 18:43:47 EDT
  Universal time: Wed 2019-08-07 22:43:47 UTC
        RTC time: n/a
       Time zone: America/New_York (EDT, -0400)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no


Package Versions:
Code:
proxmox-ve: 5.4-1 (running kernel: 4.15.18-17-pve)
pve-manager: 5.4-13 (running version: 5.4-13/aee6f0ec)
pve-kernel-4.15: 5.4-5
pve-kernel-4.15.18-19-pve: 4.15.18-45
pve-kernel-4.15.18-18-pve: 4.15.18-44
pve-kernel-4.15.18-17-pve: 4.15.18-43
pve-kernel-4.15.18-16-pve: 4.15.18-41
pve-kernel-4.15.18-13-pve: 4.15.18-37
pve-kernel-4.15.18-11-pve: 4.15.18-34
pve-kernel-4.15.18-10-pve: 4.15.18-32
pve-kernel-4.15.18-9-pve: 4.15.18-30
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-12
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-54
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-14
libpve-storage-perl: 5.0-44
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-3
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-28
pve-cluster: 5.0-37
pve-container: 2.0-40
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-22
pve-firmware: 2.0-7
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 3.0.1-4
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-54
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2
 
your system probably made a time jump, the problem will correct itself since it's just 2.5 hours we are talking about it should already be gone ;)
 
your system probably made a time jump, the problem will correct itself since it's just 2.5 hours we are talking about it should already be gone ;)

You’re right. Looks like it has sorted itself out. Thanks!
 
Hi, I have the same problem
Sep 20 16:01:26 proxmox-ext pmxcfs[1340]: [status] notice: RRD update error /var/lib/rrdcached/db/pve2-storage/proxmox/local-zfs: /var/lib/rrdcached/db/pve2-storage/proxmox/local-zfs: illegal attempt to update using time 1663682486 when last update time is 1670599081 (minimum one second step)
It messed up when i replaced the motherboard battery and after that the clock was wrong. I think this also break graphs in the node webpage (only the "year" works correctly, other won't load) and i can't stay logged in more than a couple of minutes.
The wrong last update time is "Fri Dec 09 2022 16:18:01 UTC+0100", is there a way to fix it?
Thank you
 
the RRD thing is cosmetic (IIRC removing the RRD files - losing all data - or waiting for the time to catch up - not storing any data until then - both work). the login issue can be fixed by touch /etc/pve/authkey*.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!