restore bug in vzdump 1.2.3?

proxymoxy

New Member
Jun 9, 2011
28
0
1
Is this is potential bug in vzdump/vzrestore?

Here is what I did:

Install sl6 precreated template from openvz.org

vzctl enter 101
- yum update
- yum install iotop
- exit
vzctl enter 101
- iotop [works fine]
- exit

vzdump --stop --dumpdir /root 101

vzctl destroy 101

vzrestore /root/vzdump-openvz-101-2011_08_25-05_03_20.tar 101
INFO: restore openvz backup '/root/vzdump-openvz-101-2011_08_25-05_03_20.tar' using ID 101
INFO: extracting archive '/root/vzdump-openvz-101-2011_08_25-05_03_20.tar'
INFO: Total bytes read: 621721600 (593MiB, 17MiB/s)
INFO: extracting configuration to '/etc/vz/conf/101.conf'
INFO: restore openvz backup '/root/vzdump-openvz-101-2011_08_25-05_03_20.tar' successful

vzctl start 101
vzctl enter 101
- ping google.com [works fine]
- vim [works fine]
- yum update [works fine]
- top [works fine]
- iotop

[root@mycontainer /]# iotop
Traceback (most recent call last):
File "/usr/bin/iotop", line 16, in <module>
main()
File "/usr/lib/python2.6/site-packages/iotop/ui.py", line 541, in main
main_loop()
File "/usr/lib/python2.6/site-packages/iotop/ui.py", line 531, in <lambda>
main_loop = lambda: run_iotop(options)
File "/usr/lib/python2.6/site-packages/iotop/ui.py", line 446, in run_iotop
return curses.wrapper(run_iotop_window, options)
File "/usr/lib/python2.6/curses/wrapper.py", line 43, in wrapper
return func(stdscr, *args, **kwds)
File "/usr/lib/python2.6/site-packages/iotop/ui.py", line 437, in run_iotop_window
taskstats_connection = TaskStatsNetlink(options)
File "/usr/lib/python2.6/site-packages/iotop/data.py", line 113, in __init__
self.family_id = controller.get_family_id('TASKSTATS')
File "/usr/lib/python2.6/site-packages/iotop/genetlink.py", line 54, in get_family_id
m = self.conn.recv()
File "/usr/lib/python2.6/site-packages/iotop/netlink.py", line 190, in recv
raise err
OSError: Netlink error: No such file or directory (2)
[root@mycontainer /]# exit

Not sure why iotop doesn't work in a container restored with vzrestore. I tried also a lot of other commands, but so far only iotop showed a problem.

I also tried to restore with a different VMID, but same problem.

Any idea what the problem could be?
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,337
829
163
latest version is vzdump: 1.2-14, pls use this one and report any issues.
 

proxymoxy

New Member
Jun 9, 2011
28
0
1
Yes, that is the version I tried. No, idea why I wrote 1.2.3 :)

Latest entry in the change log was:

2011-05-24 Proxmox Support Team <support@proxmox.com>
* OpenVZ.pm (resume_vm): remove --skiplock flag
 

proxymoxy

New Member
Jun 9, 2011
28
0
1
Well, I reinstalled everything, and now iotop doesn't work in any container (even one that was not restored). I am not able anymore to run iotop successfully in any container with sl6 (but it works fine on the host).

In other words vzdump/vzrestore work fine and there is no bug at all.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!