pvesm share name with a space


Dec 27, 2021
So, I've got a space in my share name. Ya. I know. Not good ;(
I can't change it now as their are over 50 computers connected to the server all mapped and probably hundreds of lines of code in various programs/settings/environments with that share name.

How do I add this SMB share with the space [NWIC Drive]

pvesm add cifs NWICDrive --server --share NWIC Drive --username xxx --password xxx
create storage failed: storage 'NWICDrive' is not online

Doing a scan shows the share name as [Drive] witch I have tried adding. I have also tried [NWIC\040Drive] witch works in fstab, nether of witch works.
Thanks, the quotes worked. Although I used single quotes 'NWIC Drive'
This was to accomplish adding the share to the Datacenter>Storage.
It is showing on the list of drives in the left panel and passing through to the LXC as a mount point so I'm happy but the icon shows a grey question mark and on clicking on the drive I get no status updates on storage space.
running [pvesm status] shows as "inactive'
I don't really need it but it would be nice to fix it.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!