Pveproxy throws errors on one of the nodes in Proxmox 4.3 cluster

Discussion in 'Proxmox VE: Installation and configuration' started by fcukinyahoo, Nov 30, 2016.

  1. fcukinyahoo

    fcukinyahoo New Member

    Joined:
    Nov 29, 2012
    Messages:
    27
    Likes Received:
    0
    Only when I open clustered Proxmox GUI on web browser, https://IP:8006 I see errors on only 1 of the servers below.

    Code:
    Nov 30 11:18:09 pmox03 pveproxy[16239]: problem with client 192.168.1.10; ssl3_read_bytes: tlsv1 alert unknown ca
    Nov 30 11:18:09 pmox03 pveproxy[16239]: Can't call method "timeout_reset" on an undefined value at /usr/share/perl5/PVE/HTTPServer.pm line 315.
    Nov 30 11:18:12 pmox03 pveproxy[16239]: problem with client 192.168.1.10; ssl3_read_bytes: ssl handshake failure
    Nov 30 11:18:12 pmox03 pveproxy[16239]: Can't call method "timeout_reset" on an undefined value at /usr/share/perl5/PVE/HTTPServer.pm line 315.
    Nov 30 11:18:16 pmox03 pveproxy[16239]: problem with client 192.168.1.10; ssl3_read_bytes: tlsv1 alert unknown ca
    Nov 30 11:18:16 pmox03 pveproxy[16239]: Can't call method "timeout_reset" on an undefined value at /usr/share/perl5/PVE/HTTPServer.pm line 315.
    Nov 30 11:18:24 pmox03 pveproxy[16239]: problem with client 192.168.1.10; ssl3_read_bytes: ssl handshake failure
    Nov 30 11:39:09 pmox03 pveproxy[22547]: Can't call method "on_read" on an undefined value at /usr/share/perl5/PVE/HTTPServer.pm line 298.
    Nov 30 11:43:05 pmox03 pveproxy[22547]: problem with client 192.168.1.10; ssl3_read_bytes: ssl handshake failure
    Nov 30 11:43:05 pmox03 pveproxy[22547]: Can't call method "on_read" on an undefined value at /usr/share/perl5/PVE/HTTPServer.pm line 298.
    Nov 30 11:43:07 pmox03 pveproxy[22547]: problem with client 192.168.1.10; ssl3_read_bytes: tlsv1 alert unknown ca
    Nov 30 11:43:07 pmox03 pveproxy[22547]: Can't call method "on_read" on an undefined value at /usr/share/perl5/PVE/HTTPServer.pm line 298.
    
    IP address above is the other node that I am viewing the cluster from. So
    https://192.168.1.10:8006 is pmox01
    192.168.1.12 is pmox03 where the problem occurs.

    I have tried below solution but no luck
    Code:
    pvecm updatecerts --force
    reboot
    
    I also see "Too many redirects (599)" every couple seconds on the browser when looking at that node's summary. It only exist on that node, and all 3 nodes are setup exactly the same way and same time. What could be the issue? Thanks in advance.

    Code:
    root@pmox03:~# pveversion --verbose
    proxmox-ve: 4.3-72 (running kernel: 4.4.24-1-pve)
    pve-manager: 4.3-12 (running version: 4.3-12/6894c9d9)
    pve-kernel-4.4.24-1-pve: 4.4.24-72
    pve-kernel-4.4.19-1-pve: 4.4.19-66
    lvm2: 2.02.116-pve3
    corosync-pve: 2.4.0-1
    libqb0: 1.0-1
    pve-cluster: 4.0-47
    qemu-server: 4.0-96
    pve-firmware: 1.1-10
    libpve-common-perl: 4.0-83
    libpve-access-control: 4.0-19
    libpve-storage-perl: 4.0-68
    pve-libspice-server1: 0.12.8-1
    vncterm: 1.2-1
    pve-docs: 4.3-17
    pve-qemu-kvm: 2.7.0-8
    pve-container: 1.0-85
    pve-firewall: 2.0-31
    pve-ha-manager: 1.0-38
    ksm-control-daemon: 1.2-1
    glusterfs-client: 3.5.2-2+deb8u2
    lxc-pve: 2.0.6-1
    lxcfs: 2.0.5-pve1
    criu: 1.6.0-1
    novnc-pve: 0.5-8
    smartmontools: 6.5+svn4324-1~pve80
    zfsutils: 0.6.5.8-pve13~bpo80
    
     
    #1 fcukinyahoo, Nov 30, 2016
    Last edited: Nov 30, 2016
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice