PVE8: /var/lib/vz mounten

frantek

Renowned Member
May 30, 2009
170
7
83
Hallo,

ich habe mein ersten PVE8 System installiert und scheitere mit etwas, was mit allen Vorgängerversionen immer funktioniert hat. Folgender fstab Eintrag führt dazu, dass das System nicht bootet:

/dev/pve/data /var/lib/vz xfs defaults 0 0

Ich bekomme dann:

Found volume group “pve" using metadata type lvm2
3 logical volume(s) in volume group “pue" now

[ TIME ] Timed out waiting for device dev-pve-data
[ DEPEND ] Dependency failed for var-lib-vz.mount - /var/lib/vz.
[ DEPEND ] Dependency failed for local-fs.target - Local File Sytems.

und hänge im Emergency-Modus. Mache ich dann "mount -a" funktioniert alles wie es soll.

Wie immer habe ich das LVM-Thin entfernt, ein XFS angelegt und gemountet.

Wie bekomme ich das dazu, dass es das macht was es soll?

TIA
Matthias
 
bitte

- pveversion -v
- /etc/fstab
- ausgabe von "lvs"
- ausgabe von "journalctl -b" bis zum erreichen des multi-user.target
 
pveversion -v
Code:
proxmox-ve: 8.0.1 (running kernel: 6.2.16-3-pve)
pve-manager: 8.0.3 (running version: 8.0.3/bbf3993334bfa916)
pve-kernel-6.2: 8.0.2
pve-kernel-6.2.16-3-pve: 6.2.16-3
ceph-fuse: 17.2.6-pve1+3
corosync: 3.1.7-pve3
criu: 3.17.1-2
glusterfs-client: 10.3-5
ifupdown2: 3.2.0-1+pmx2
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-3
libknet1: 1.25-pve1
libproxmox-acme-perl: 1.4.6
libproxmox-backup-qemu0: 1.4.0
libproxmox-rs-perl: 0.3.0
libpve-access-control: 8.0.3
libpve-apiclient-perl: 3.3.1
libpve-common-perl: 8.0.5
libpve-guest-common-perl: 5.0.3
libpve-http-server-perl: 5.0.3
libpve-rs-perl: 0.8.3
libpve-storage-perl: 8.0.1
libspice-server1: 0.15.1-1
lvm2: 2.03.16-2
lxc-pve: 5.0.2-4
lxcfs: 5.0.3-pve3
novnc-pve: 1.4.0-2
proxmox-backup-client: 2.99.0-1
proxmox-backup-file-restore: 2.99.0-1
proxmox-kernel-helper: 8.0.2
proxmox-mail-forward: 0.1.1-1
proxmox-mini-journalreader: 1.4.0
proxmox-widget-toolkit: 4.0.5
pve-cluster: 8.0.1
pve-container: 5.0.3
pve-docs: 8.0.3
pve-edk2-firmware: 3.20230228-4
pve-firewall: 5.0.2
pve-firmware: 3.7-1
pve-ha-manager: 4.0.2
pve-i18n: 3.0.4
pve-qemu-kvm: 8.0.2-3
pve-xtermjs: 4.16.0-3
qemu-server: 8.0.6
smartmontools: 7.3-pve1
spiceterm: 3.3.0
swtpm: 0.8.0+pve1
vncterm: 1.8.0
zfsutils-linux: 2.1.12-pve1

/etc/fstab

Code:
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/pve/root / ext4 errors=remount-ro 0 1
/dev/pve/swap none swap sw 0 0
proc /proc proc defaults 0 0

/dev/pve/data /var/lib/vz xfs defaults 0 0

ausgabe von "lvs"

LV VG Attr LSize Pool Origin Data% Meta% Move Log Cpy%Sync Convert data pve twi-a-tz-- <2.47t 0.00 0.17 root pve -wi-ao---- 96.00g swap pve -wi-ao---- 8.00g

"journalctl -b" im Anhang. (Es war ein Kampf ... Datei zu gross, bz2 nicht erlaubt ... :))

Manuell geht es dann:

Code:
Filesystem            Size  Used Avail Use% Mounted on
udev                   32G     0   32G   0% /dev
tmpfs                 6.3G  1.8M  6.3G   1% /run
/dev/mapper/pve-root   94G  2.9G   87G   4% /
tmpfs                  32G   34M   32G   1% /dev/shm
tmpfs                 5.0M     0  5.0M   0% /run/lock
/dev/fuse             128M   16K  128M   1% /etc/pve
/dev/mapper/pve-data  2.5T   18G  2.5T   1% /var/lib/vz
tmpfs                 6.3G     0  6.3G   0% /run/user/0

Der Mount-Point ist übrigens egal. Der Fehler kommt immer.
 

Attachments

  • j.txt.gz
    38.5 KB · Views: 1
Last edited:
laut "lvs" und journal ist pve/data ein thin pool, kein normales volume.. ist da vielleicht was beim loeschen und neuerstellen schief gegangen? ;)
 
Danke, ich erinnere mich nicht das Volume je gelöscht zu haben. Egal, dann versuche ich das mal so.

Gibt es eigentlich einen guten Grund warum per Default der thin pool angelegt wird? Kann man das beim Setup beeinflussen?

Edit: besser, funktioniert jetzt.
 
Last edited:
Danke, ich erinnere mich nicht das Volume je gelöscht zu haben. Egal, dann versuche ich das mal so.

Gibt es eigentlich einen guten Grund warum per Default der thin pool angelegt wird? Kann man das beim Setup beeinflussen?

ja - LVM thin hat features (snapshots, linked clones, thin provisioning) die viele user haben wollen - daher ist es der default.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!