pve-firmware package incompatible with firmware-realtek

Lope

New Member
Jun 28, 2019
7
0
1
111
My system has Realtek RTL8111/8168/8411 PCI-E GbE rev6

Within the server running for it's first 24 hours, the link went down without good reason.

Upon researching the issue I discovered people saying that r8169 (open source, default module) is not as stable etc as r8168, they recommended r8168.
I tried to install the Debian non-free package r8168-dkms. Apparently it automagically blacklists the r8169 module and compiles itself etc. But it did not compile a module for the 5.x kernel. Only the previous 4.x kernel that was sitting unused on my system.

Then I tried to install firmware-realtek, but it's incompatible with pve-firmware and tries to remove proxmox and about 100 other packages, which is obviously not an option.

So I just wanted to bring it to the Proxmox team's attention that firmware-realtek is not compatible with pve-firmware (is that intentional?)

I also want to document my workaround experience.
The only workaround I could find online that's suitable is adding this to /etc/network/interfaces under the physical NIC bridge:
pre-up /sbin/ethtool -s enpAsB speed 1000 duplex full autoneg off

Let's see how well it works.
 
pve-firmware ships the realtek 8168 firmware files, which is why the packages conflict.
 
Thank you so much for your quick reply Fabian
I want to mention firstly that my ethernet connection has been stable so far for > 48 hours (which is a big improvement) with the above ethtool workaround.

Secondly, Fabian, it's interesting that you say pve-firmware has 8168 firmware files, because I have pve-firmware and the Realtek 8168 adapter, yet I've got r8169 kernel module loaded.
After rebooting I've not done anything related to modules. No modprobe etc. I've not specially loaded or blacklisted any modules.

Code:
root@node:/# lspci | grep Ethernet
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

root@node:/# lsmod | grep r81
r8169                  81920  0

root@node:/# uname -a
Linux node 5.0.15-1-pve #1 SMP PVE 5.0.15-1 (Wed, 03 Jul 2019 10:51:57 +0200) x86_64 GNU/Linux

root@node:/# dpkg -l | grep firmware
ii  intel-microcode                      3.20190618.1                    amd64        Processor microcode firmware for Intel CPUs
ii  pve-edk2-firmware                    2.20190614-1                    all          edk2 based firmware modules for virtual machines
ii  pve-firmware                         3.0-2                           all          Binary firmware code for the pve-kernel

root@node:/# dpkg -l | grep proxmox
ii  proxmox-mini-journalreader           1.1-1                           amd64        Minimal systemd Journal Reader
ii  proxmox-ve                           6.0-2                           all          The Proxmox Virtual Environment
ii  proxmox-widget-toolkit               2.0-5                           all          ExtJS Helper Classes for Proxmox

root@node:/# dpkg -l | grep realtek
root@node:/# dpkg -l | grep dkms
rc  dkms                                 2.6.1-4                         all          Dynamic Kernel Module Support Framework
rc  zfs-dkms                             0.6.5.9-5                       all          OpenZFS filesystem kernel modules for Linux
 
Last edited:
yes, but the r8169 module uses the same firmware files
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!