PVE 5.4 spice disable-ticketing

ricardoj

Member
Oct 16, 2018
101
8
23
65
Sao Paulo - Brazil
Hi,

I just installed version 5.4 in my lab and restored one Linux VM ( Ubuntu 18.04 Desktop ) to test.

I usually put "args" in VM conf file like this, to have direct access to spice :

args: -device AC97,addr=0x18 -spice port=3200,addr=0.0.0.0,disable-ticketing

I use Remmina to connect to the VM.

I noticed there is no bind to port 3200 in my case and there is no error message in LOGs.

Is there any change in version 5.4 in order to disable spice ticketing ?

Regards,

Ricardo Jorge
 
the order of the args changed (they are now at the very end of the qemu commandline)
sadly qemu only parses the first '-spice' it encounters so in order to do what you want, you have to disable spice from the gui and make all those changes it does manually via args
(look at the output of 'qm showcmd ID --pretty' with and without spice and the difference is what you need)
 
Dear Dominik,

I'm so sorry but I'm stuck

When you say with and without spice you mean using GUI configure video as "default" save the configuration then configure video as "spice" save the configuration then "diff" those 2 configuration files ?

After that may I let video configuration ( using GUI ) as "spice" and just put the differences in the VM.conf file ?

I still sen no bind to the port I assigned in the VM conf file.

Regards,

Ricardo Jorge
 
no you have to set the display to something other than 'spice'
only them qemu will recognize the port you give it via args
 
Hi,

It does not work here.

It works with version 5.2 and 5.3 but not with 5.4

Do you have an example of such VM.conf file ?

Just the spice portion as well as what video option you choose in the GUI ?

Regards,

Ricardo Jorge
 
Hello,

this is the same issue as discussed already here:
https://forum.proxmox.com/threads/proxmox-5-3-spice-port-ignored.51388/

Until now there is no "real" solution other than start the vm from command line as shown in my posts of the thread linked.

And the hint form the Proxmox Staff Member above to remove spice as graphic device in the conf file will cause several other issues, as example no automatical screen resultion change when you are connect with remote-viewer and resize the window beside many other's...
 
And the hint form the Proxmox Staff Member above to remove spice as graphic device in the conf file will cause several other issues, as example no automatical screen resultion change when you are connect with remote-viewer and resize the window beside many other's...
please do not post things that are not true

the hints i gave you work well and normally users do not need this (especially disabling ticketing is a bad idea)
but here is a config that works :

Code:
agent: 1
args: -device 'qxl-vga,id=vga,bus=pci.0,addr=0x2' -device 'virtio-serial,id=spice,bus=pci.0,addr=0x9' -chardev 'spicevmc,id=vdagent,name=vdagent' -device 'virtserialport,chardev=vdagent,name=com.redhat.spice.0' -spice port=3200,addr=0.0.0.0,disable-ticketing
bootdisk: scsi0
cores: 4
ide2: none,media=cdrom
memory: 4096
name: guest
numa: 0
ostype: win10
scsi0: nvme:ID/vm-ID-disk-0.qcow2,discard=on,size=32G
scsihw: virtio-scsi-pci
sockets: 1
vga: none
 
Hi,

There is a "script" that works for me.

I took it from here : https://forum.proxmox.com/threads/remote-spice-access-without-using-web-manager.16561/page-3

Please, see the second one in bash.

The issue in my environment is that in order to work this script needs virt-viewer that is not available in Raspberry Pi in the current version ( stretch - Debian 9 )

There is a bug in RPI virt-viewer package : https://bugs.launchpad.net/raspbian/+bug/1753068

In the next release of raspbian ( Debian 10 - buster ) looks like this package will be fixed.

I'm going to make more tests.

Regards,

Ricardo Jorge
 
Hi Dominik,

I tested the example code you sent and it works fine and now I can use my Raspberry Pi ( with Remmina ) to connect to PVE VMs.

Thank you so much for your time and attenttion.

Regards,

Ricardo Jorge
 
Hi,

I was talking to Antenore Gatta remmina's ( https://remmina.org/ ) developer and he told me he is evaluating some modifications that in future let remmina be used the same way we do for remote-viewer ( using a script to pass authentication ) to connect to Proxmox.

This way we're going to have an alternative client to be used for spice protocol.

Today this is only possible if ticketing is disabled.

Stay tuned for news in gitlab ( https://gitlab.com/Remmina/Remmina/issues/1882 ).

Regards,

Ricardo Jorge
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!