ProxMox won't boot on AsRock Industrial 1220P


New Member
Dec 31, 2022
When attempting to initial boot ProxMox from USB to an AsRock Industrial 1220P (Intel I3-220 CPU, 32GB G.Skills (tested) memory 500GB Samsung 980Pro SSD), the system display shuts down after about a second of attempting to boot. This same system will boot to Windows 10, but won't boot to ProxMox, Debian or Ubuntu. I suspect that there's a driver issue, but have been unable to discover the problem, since there are no logs or error messages. I have created USB sticks with Ventoy, Etcher, and Rufus. I have a tech support call into ASRock Industrial, but there has been no response in a couple of weeks. I can still return this box, but I really like the specifications. Any thoughts?
Agreed, sounds very familiar. I will apply the suggestions in that thread and let everyone know. Thanks for the quick response.
None of these solutions help. I have tried various permutations of Linux and ProxMox to no avail. I have reached out to AsRock Industrial for help, but no response in over two weeks. I will continue to attempt to make this work, since the hardware is a perfect match for my use case.
Has anyone successfully installed ProxMox on an ASRock Industrial 1220P? I've tried all of the suggestions provided, and still no luck. I'm guessing that it's related to the 2.5 G network adapters or the video drivers. I'm getting no response from the ASRock Industrial tech support. I've had this box for about 2 months, and I'm about ready to pitch it (and the concept of ProxMox).
Attempting to install Proxmox 7.4 ISO on the ASRock Industrial 1220P was impossible using HDMI until I switched to USBC DisplayPort connection.

For those who can't use a different display output I'd like point out that the boot config can be edited by pressing the e key while highlighting the install option or dropping to a shell by using the debug mode, methods I attempted to use to set a different resolution but after some time of trial & error I just decided to move on with the DisplayPort USB. If anyone finds a way to make it install using the HDMI connection I'd be interested to hear about the workaround.
Thanks for your response on this topic. Your message is consistent with the one I received from ASRock Industrial tech support, in the sense that they said " works with a DP monitor". There was no mention in their response about a solution using HDMI. My approach was to install Debian, and then ProxMox on top of that. It worked, mostly. Even after updating the Debian firmware to the not-yet-stable version, I could not recover the HDMI monitor once it goes to sleep. So even though this device will work as a server with a SSH interface to the outside world, I decided to purchase a DP monitor.
I haven't tried a USB-C to HDMI cable, but I'm guessing that it won't work. The problem appears to be in the HDMI drivers. I would be really interested to know if this cable works. It would allow me to assign an old HDMI monitor to my server which would be most convenient.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!