[SOLVED] Proxmox Webinterface Unterschiede zwischen Firefox und Chrome

monokuai

Member
Feb 20, 2019
4
0
21
38
Hallo,

ich habe ein Problem mit der Console Anzeige bei Firefox.

Wenn im Webinterface bei einer (linux)VM die Console ausgewählt wird,
erscheint bekanntermaßen die Shell.
Bei Firefox funktioniert die Tasteneingabe schlecht, - wird zu ß,
_ wird zu ß, ö ist auf der Punkttaste.

Selber Server, selbe (linux)VM, aber mit Chrome funktionieren die Tasten.

Was muss getan werden, damit Firefox die Tasten exakt so erkennt wie
bei Chrome?


MfG
 
bitte auch um die ausgabe von:

> pveversion -v

und die VM settings.

> qm config VMID
 
# pveversion -v

proxmox-ve: 5.3-1 (running kernel: 4.15.18-11-pve)
pve-manager: 5.3-9 (running version: 5.3-9/ba817b29)
pve-kernel-4.15: 5.3-2
pve-kernel-4.15.18-11-pve: 4.15.18-33
pve-kernel-4.15.18-9-pve: 4.15.18-30
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-3
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-46
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-11
libpve-storage-perl: 5.0-38
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-3
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-2
proxmox-widget-toolkit: 1.0-22
pve-cluster: 5.0-33
pve-container: 2.0-34
pve-docs: 5.3-2
pve-edk2-firmware: 1.20181023-1
pve-firewall: 3.0-17
pve-firmware: 2.0-6
pve-ha-manager: 2.0-6
pve-i18n: 1.0-9
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 2.12.1-1
pve-xtermjs: 3.10.1-1
qemu-server: 5.0-46
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.12-pve1~bpo1

# qm config 100

agent: 1
bootdisk: virtio0
cores: 1
cpu: host
ide2: none,media=cdrom
keyboard: de
memory: 512
name: example
net0: virtio=11:22:33:44:55:66,bridge=vmbr0
numa: 0
onboot: 1
ostype: l26
scsihw: virtio-scsi-pci
smbios1: uuid=79212048-f5df-4b05-b9f9-0143101fdef2
sockets: 1
vga: virtio
virtio0: virtpool:vm-100-disk-0,size=30G
vmgenid: 254b918b-a3d4-4186-994d-00617a1ff978
 
sollte gehen. welche "console" wird denn verwendet (noVNC, SPICE, xterm.js)?

keyboard innerhalb der VM auch richtig gesetzt?
 
Hallo Tom,

noVNC wird verwendet.
Keyboard innerhalb der VM ist de

Diese VM ist eine Migration vom KVM/Qemu-Server. Da gab es keine Schwierigkeit wenn über die integrierte Anzeige gearbeitet wird.
Eingaben in einer SSH-Konsole funktionieren ebenfalls tadellos, es betrifft nur das Webinterface mit Firefox.

Neben der Migration wurden selbstverständlich zu Testzwecken neue VMs über das Webinterface erstellt, mit dem selben Resultat dass die Eingabe über Chrome ohne Schwierigkeiten stattfinden
 
am besten die sprach/keyboard einstellung in der vm config (hardware->keyboard) auf default lassen
dann funktioniert es hier auch
 
Hallo,

das Problem lag an Firefox selbst.
Da ich Firefox auf mehreren Geräten verwende mit der Firefox synchronisierung, ist auf jedem Endgerät dasselbe Profil vorhanden.
Und selbstverständlich hatte ich proxmox von den verschiedenen Endgeräten getestet, überall mit dem selben voreiligen Resultat,
dass das Problem nicht von meiner Seite aus kommen kann. Denn alles andere funktioniert ja.

Es konnte einfach nicht sein, dass eine Software wie Proxmox Probleme mit Firerfox hat, wenn es selbst unser Uni-Rechenzentrum das verwendet. Und die sind sehr pingelig.

TL;DR:
FF-Profil gelöscht = Proxmox funktioniert einwandfrei
FF-Sync gestartet = Probleme wie oben
vimdiff non_sync_pref.js sync_pref.js gemacht und die Optionen durchgegangen und folgenden modifizierten Eintrag auf Default gesetzt:
privacy.resistFingerprinting

Jetzt funktioniert es. Danke an Proxmox für die Hilfeleistung.


Mit freundlichen Grüßen
Monokuai
 
macht sinn wenn man folgendes bedenkt:

  • privacy.resistFingerprinting = true – This will hide a number of unique settings when you browse websites, such as language preferences, timezones, dates, and more

wenn keyboard: de eingestellt ist, erwartet qemu die korrekten scancodes/keysymbols für das deutsche layout, novnc kann in dem fall aber nicht mehr wissen das die sprache deutsch ist
mein tipp: 'keyboard: de' aus der config löschen, vm runterfahren, vm hochfahren, und nun sollte immer das korrekte (im gast eingestelle) layout funktionieren
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!