[SOLVED] proxmox-ve trying to be removed updating 6.4.x

sg90

Active Member
Sep 21, 2018
268
39
33
31
I have a server running 6.4.x

When I run apt update && apt-dist upgrade it trys to remove promox-ve along with some other packages

Code:
apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  bridge-utils ceph-common ceph-fuse cifs-utils corosync criu cstream dtach ebtables faketime fontconfig fontconfig-config fonts-dejavu-core fonts-font-awesome fonts-glyphicons-halflings genisoimage
  glusterfs-client glusterfs-common hdparm ifenslave ipset iso-codes libacl1-dev libanyevent-http-perl libanyevent-perl libappconfig-perl libapt-pkg-perl libarchive13 libasound2 libasound2-data
  libasyncns0 libattr1-dev libauthen-pam-perl libavahi-client3 libavahi-common-data libavahi-common3 libbabeltrace1 libboost-atomic1.67.0 libboost-program-options1.67.0 libboost-regex1.67.0
  libboost-thread1.67.0 libc-dev-bin libc6-dev libcaca0 libcairo2 libcephfs2 libcfg7 libclone-perl libcmap4 libcorosync-common4 libcpg4 libcrypt-openssl-bignum-perl libcrypt-openssl-random-perl
  libcrypt-openssl-rsa-perl libcups2 libcurl3-gnutls libdatrie1 libdbi1 libdevel-cycle-perl libdw1 libfaketime libfile-chdir-perl libfile-readbackwards-perl libfilesys-df-perl libflac8 libfontconfig1
  libfuse3-3 libgfapi0 libgfchangelog0 libgfdb0 libgfrpc0 libgfxdr0 libglusterfs-dev libglusterfs0 libgnutlsxx28 libgoogle-perftools4 libgraphite2-3 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0
  libharfbuzz0b libibverbs1 libice6 libio-multiplex-perl libio-stringy-perl libipset11 libiscsi7 libjansson4 libjemalloc2 libjpeg62-turbo libjs-bootstrap libjs-extjs libjs-jquery libjs-sphinxdoc
  libjs-underscore libknet1 libldb1 libleveldb1d liblinux-inotify2-perl liblttng-ust-ctl4 liblttng-ust0 libmime-base32-perl libnet-dbus-perl libnet-dns-perl libnet-ip-perl libnet1 libnetfilter-log1
  libnl-3-200 libnl-route-3-200 libnspr4 libnss3 liboath0 libogg0 libopus0 liborc-0.4-0 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpixman-1-0 libprotobuf17 libproxmox-acme-perl
  libproxmox-backup-qemu0 libpulse0 libpve-access-control libpve-apiclient-perl libpve-cluster-api-perl libpve-cluster-perl libpve-common-perl libpve-guest-common-perl libpve-http-server-perl
  libpve-storage-perl libpve-u2f-server-perl libpython2.7 libpython3.7 libqb0 libqrencode4 libquorum5 librabbitmq4 librados2 librados2-perl libradosstriper1 librbd1 librdkafka1 librdmacm1 librgw2
  librrd8 librrds-perl libsdl1.2debian libsm6 libsmbclient libsnappy1v5 libsndfile1 libspice-server1 libstatgrab10 libstring-shellquote-perl libtalloc2 libtcmalloc-minimal4 libtdb1 libtemplate-perl
  libtevent0 libthai-data libthai0 libu2f-server0 libunwind8 liburcu6 libusbredirparser1 libuuid-perl libvorbis0a libvorbisenc2 libvotequorum8 libwbclient0 libx11-6 libx11-data libx11-xcb1 libxau6
  libxcb-render0 libxcb-shm0 libxcb1 libxdmcp6 libxext6 libxi6 libxml-libxml-perl libxml-twig-perl libxrender1 libxslt1.1 libxtst6 libyaml-0-2 libyaml-libyaml-perl linux-image-4.19.0-10-amd64
  linux-libc-dev lxc-pve lxcfs lzop novnc-pve numactl proxmox-archive-keyring proxmox-backup-client proxmox-backup-file-restore proxmox-backup-restore-image proxmox-mini-journalreader
  proxmox-widget-toolkit pve-cluster pve-container pve-docs pve-edk2-firmware pve-firewall pve-ha-manager pve-i18n pve-kernel-helper pve-lxc-syscalld pve-manager pve-qemu-kvm pve-xtermjs
  python-cephfs python-certifi python-chardet python-configparser python-future python-idna python-ipaddr python-pkg-resources python-prettytable python-protobuf python-rados python-rbd
  python-requests python-six python-talloc python-urllib3 python3-ceph-argparse python3-ceph-common python3-cephfs python3-certifi python3-chardet python3-idna python3-jwt python3-pkg-resources
  python3-prettytable python3-rados python3-rbd python3-requests python3-rgw python3-six python3-urllib3 python3-yaml qemu-server qrencode rrdcached samba-common samba-libs smartmontools smbclient
  socat spiceterm sqlite3 uidmap vncterm x11-common xsltproc zstd
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  proxmox-ve pve-firmware pve-kernel-5.4
The following NEW packages will be installed:
  firmware-linux-free libleveldb1d liblttng-ust-ctl4 liblttng-ust0 liboath0 librabbitmq4 librdkafka1 librgw2 linux-image-4.19.0-16-amd64 proxmox-backup-file-restore proxmox-backup-restore-image
  python3-ceph-argparse python3-ceph-common python3-cephfs python3-rados python3-rbd python3-rgw python3-yaml
The following packages will be upgraded:
  apt apt-utils base-files bind9-host ceph-common ceph-fuse corosync curl debian-archive-keyring groff-base intel-microcode iputils-clockdiff iputils-ping iputils-tracepath libapt-inst2.0
  libapt-pkg5.0 libavahi-client3 libavahi-common-data libavahi-common3 libbind9-161 libbsd0 libcephfs2 libcfg7 libcmap4 libcorosync-common4 libcpg4 libcurl3-gnutls libcurl4 libdns-export1104
  libdns1104 libgstreamer-plugins-base1.0-0 libirs-export161 libisc-export1100 libisc1100 libisccc161 libisccfg-export163 libisccfg163 libjs-jquery libjs-underscore libldap-2.4-2 libldap-common
  libldb1 liblwres161 libpam-systemd libproxmox-acme-perl libproxmox-backup-qemu0 libpve-access-control libpve-cluster-api-perl libpve-cluster-perl libpve-common-perl libpve-guest-common-perl
  libpve-http-server-perl libpve-storage-perl libpython3.7 libpython3.7-minimal libpython3.7-stdlib libquorum5 librados2 libradosstriper1 librbd1 libssl1.1 libsystemd0 libudev1 libvotequorum8
  libzstd1 linux-image-amd64 linux-libc-dev openssl proxmox-backup-client proxmox-widget-toolkit pve-cluster pve-container pve-docs pve-i18n pve-kernel-helper pve-manager pve-qemu-kvm python3.7
  python3.7-minimal qemu-server smartmontools systemd systemd-sysv udev zstd
85 upgraded, 18 newly installed, 3 to remove and 0 not upgraded.
Need to get 29.9 MB/168 MB of archives.

Repo's setup

Code:
deb http://download.proxmox.com/debian/pve buster pve-no-subscription
deb http://download.proxmox.com/debian/ceph-octopus buster main

Code:
pveversion -v
proxmox-ve: 6.4-1 (running kernel: 5.4.78-2-pve)
pve-manager: 6.3-3 (running version: 6.3-3/eee5f901)
pve-kernel-5.4: 6.3-3
pve-kernel-helper: 6.3-3
pve-kernel-5.4.78-2-pve: 5.4.78-2
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.1.0-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksmtuned: 4.20150325+b1
libjs-extjs: 6.0.1-10
libknet1: 1.20-pve1
libproxmox-acme-perl: 1.0.7
libproxmox-backup-qemu0: 1.0.2-1
libpve-access-control: 6.1-3
libpve-apiclient-perl: 3.1-3
libpve-common-perl: 6.3-2
libpve-guest-common-perl: 3.1-4
libpve-http-server-perl: 3.1-1
libpve-storage-perl: 6.3-5
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.6-2
lxcfs: 4.0.6-pve1
novnc-pve: 1.1.0-1
proxmox-backup-client: 1.0.8-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.4-4
pve-cluster: 6.2-1
pve-container: 3.3-3
pve-docs: 6.3-1
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-3
pve-firmware: 3.1-3
pve-ha-manager: 3.1-1
pve-i18n: 2.2-2
pve-qemu-kvm: 5.1.0-8
pve-xtermjs: 4.7.0-3
qemu-server: 6.3-4
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
 

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
2,056
269
83
Can you post the output of apt update? Somewhere there must be a problem with the repositories, causing the dependencies to get messed up.
 

sg90

Active Member
Sep 21, 2018
268
39
33
31
Code:
apt update
Hit:1 http://deb.debian.org/debian buster InRelease
Hit:2 http://deb.debian.org/debian buster-updates InRelease
Hit:3 http://security.debian.org/debian-security buster/updates InRelease
Hit:4 http://mirror.hetzner.de/debian/packages buster InRelease
Hit:5 http://mirror.hetzner.de/debian/security buster/updates InRelease
Hit:6 http://mirror.hetzner.de/debian/packages buster-updates InRelease
Hit:7 http://download.proxmox.com/debian/pve buster InRelease
Hit:8 http://download.proxmox.com/debian/ceph-octopus buster InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
87 packages can be upgraded. Run 'apt list --upgradable' to see them.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!