Proxmox VE GUI won't load after upgrade

scottk8

New Member
Oct 1, 2026
6
0
1
Hello all. I ran a kernel upgrade today from within the GUI and it all seemed to go through fine but after rebooting the GUI no longer loads. The server is running and my containers are running but when I run 'systemctl status pveproxy.service' I get the following error;

× pveproxy.service - PVE API Proxy Server
Loaded: loaded (/usr/lib/systemd/system/pveproxy.service; enabled; preset: enabled)
Active: failed (Result: exit-code) since Thu 2026-10-01 16:00:41 BST; 8min ago
Invocation: 34ee16c7b8fe4ff985eade06aa498e62
Process: 10116 ExecStartPre=/usr/bin/pvecm updatecerts --silent (code=exited, status=0/SUCCESS)
Process: 10119 ExecStart=/usr/bin/pveproxy start (code=exited, status=255/EXCEPTION)

Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Scheduled restart job, restart counter is at 5.
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Start request repeated too quickly.
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Failed with result 'exit-code'.
Oct 01 16:00:41 pve systemd[1]: Failed to start pveproxy.service - PVE API Proxy Server.

I've tried a bunch of things from previous forum posts to try and fix this but nothing seems to work. I've tried to downgrade the release from apt cache but no go. Any ideas I can try to get the GUI back or am I looking at a reinstall and then recovering my containers from a snapshot?

Thanks.
 
please post journalctl -b -u pveproxyp and pveversion -v using the code formatting option of the forum.
 
Output of pveversion -v follows. The jounalctl command gave me a No entries response.

Code:
proxmox-ve: 9.2.0 (running kernel: 7.0.14-20-pve)
pve-manager: 9.2.21 (running version: 9.2.21/4f6e0ac86f9e8c7f)
proxmox-kernel-helper: 9.2.0
proxmox-kernel-7.0: 7.0.14-20
proxmox-kernel-7.0.14-20-pve-signed: 7.0.14-20
proxmox-kernel-7.0.14-19-pve-signed: 7.0.14-19
proxmox-kernel-libc-dev: 7.0.14-2
proxmox-kernel-7.0.6-2-pve: 7.0.6-2
proxmox-kernel-7.0.6-1-pve: 7.0.6-1
proxmox-kernel-7.0.2-6-pve-signed: 7.0.2-6
ceph-fuse: 19.2.6-pve4
corosync: 3.1.10-pve3
criu: 4.1.1-1
frr-pythontools: 10.6.1-1+pve3
ifupdown2: 3.3.0-1+pmx12
intel-microcode: 3.20251111.1~deb13u1
ksm-control-daemon: 1.5-1
libjs-extjs: 7.0.0-7
libproxmox-acme-perl: 1.7.2
libproxmox-backup-qemu0: 2.0.3
libproxmox-rs-perl: 0.4.1
libpve-access-control: 9.1.2
libpve-apiclient-perl: 3.4.3
libpve-cluster-api-perl: 9.1.6
libpve-cluster-perl: 9.1.6
libpve-common-perl: 9.2.2
libpve-guest-common-perl: 6.0.5
libpve-http-server-perl: 6.0.5
libpve-network-perl: 1.6.7
libpve-notify-perl: 9.1.6
libpve-rs-perl: 0.15.3
libpve-storage-perl: 9.1.11
libspice-server1: 0.15.2-1+b1
lvm2: 2.03.31-2+pmx1
lxc-pve: 7.0.0-2
lxcfs: 7.0.0-pve1
novnc-pve: 1.7.0-2
proxmox-backup-client: 4.2.7-1
proxmox-backup-file-restore: 4.2.7-1
proxmox-backup-restore-image: 1.0.0
proxmox-enterprise-support-keyring: 1.1
proxmox-firewall: 1.2.3
proxmox-kernel-helper: 9.2.0
proxmox-mail-forward: 1.0.3
proxmox-mini-journalreader: 1.7
proxmox-offline-mirror-helper: 0.7.4
proxmox-widget-toolkit: 5.2.10
pve-cluster: 9.1.6
pve-container: 6.1.14
pve-docs: 9.2.13
pve-edk2-firmware: 4.2026.08-1
pve-esxi-import-tools: 1.0.1
pve-firewall: 6.0.6
pve-firmware: 3.18-6
pve-ha-manager: 5.2.5
pve-i18n: 3.10.0
pve-qemu-kvm: 11.0.3-4
pve-xtermjs: 6.0.0-2
qemu-server: 9.2.10
smartmontools: 7.5-pve2
spiceterm: 3.4.2
swtpm: 0.8.0+pve3
vncterm: 1.9.2
zfsutils-linux: 2.4.4-pve1
 
Last edited:
Output of journalctl -xeu pveproxy.service:-

Code:
░░ The job identifier is 5708 and the job result is failed.
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Consumed 1.261s CPU time, 149.8M memory peak.
░░ Subject: Resources consumed by unit runtime
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░
░░ The unit pveproxy.service completed and consumed the indicated resources.
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Scheduled restart job, restart counter is at 5.
░░ Subject: Automatic restarting of a unit has been scheduled
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░
░░ Automatic restarting of the unit pveproxy.service has been scheduled, as the result for
░░ the configured Restart= setting for the unit.
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Start request repeated too quickly.
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░
░░ The unit pveproxy.service has entered the 'failed' state with result 'exit-code'.
Oct 01 16:00:41 pve systemd[1]: Failed to start pveproxy.service - PVE API Proxy Server.
░░ Subject: A start job for unit pveproxy.service has failed
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░
░░ A start job for unit pveproxy.service has finished with a failure.
░░
░░ The job identifier is 5853 and the job result is failed.
 
Last edited:
sorry, please post "journalctl -b -u pveproxy" (and please use code blocks!)
 
There was a typo in the journal command - extra p at the end, did you fix it by chance in your run?


Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox
Doh, missed it. Output follows:-

...
Code:
Oct 01 16:00:40 pve systemd[1]: Starting pveproxy.service - PVE API Proxy Server...
Oct 01 16:00:41 pve pveproxy[10119]: start failed - unable to create socket - Address already in use
Oct 01 16:00:41 pve pveproxy[10119]: start failed - unable to create socket - Address already in use
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Control process exited, code=exited, status=255/EXCEPTION
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Failed with result 'exit-code'.
Oct 01 16:00:41 pve systemd[1]: Failed to start pveproxy.service - PVE API Proxy Server.
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Consumed 1.261s CPU time, 149.8M memory peak.
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Scheduled restart job, restart counter is at 5.
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Start request repeated too quickly.
Oct 01 16:00:41 pve systemd[1]: pveproxy.service: Failed with result 'exit-code'.
Oct 01 16:00:41 pve systemd[1]: Failed to start pveproxy.service - PVE API Proxy Server.
 
Last edited:
is something else binding to port 8006 already? or did you manually start pveproxy outside of the service?
 
is something else binding to port 8006 already? or did you manually start pveproxy outside of the service?
Yes, there's a Beszel agent running on it. I used it for a while but recently removed it and could have sworn I ran the agent remove command on the pve host.
 
Last edited:
could you post "ss -ltpn | grep 8006" (as root)?
 
could you post "ss -ltpn | grep 8006" (as root)?
Actually already did that, found the Beszel service was there, killed it then tried to restart the pvedaemon and pveproxy services and voila, I have a GUI back! Thaks for your help guys, my brain had totally frozen in panic...