Proxmox super langsamer Upload

Feb 3, 2022
62
4
13
28
Hallo zusammen,

ich habe mir heute meinen alten Nuc (7. Generation) als Proxmox Server installiert.
Der erste Linux Server funktioniert auch schon und alles ist super.
Ich hab noch 2 Windows Server 2016 Standard Lizenzen und dachte mir ich installiere mir diese.
Doch leider dauert der Upload per SFTP oder HTTPs ewig.
Der Upload wird auch immer langsamer gefühlt, ein Neustart bringt da nichts. Maximal erreiche ich 300 Kbit, eher so 160 KBit durchschnittlich.

Kurz ein paar nützliche Infos zum Nuc:

lspci | grep Ethernet
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-LM (rev 21)

ethtool eno1
driver: e1000e
version: 5.13.19-3-pve
firmware-version: 0.2-4
expansion-rom-version:
bus-info: 0000:00:1f.6
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: yes

pveversion
pve-manager/7.1-10/6ddebafe (running kernel: 5.13.19-3-pve)

smartctl -a /dev/nvme0n1
Model Number: Samsung SSD 970 EVO Plus 250GB
Firmware Version: 2B2QEXM7
Total NVM Capacity: 250,059,350,016 [250 GB]
[...]
=== START OF SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED
 
Last edited:
Du solltest die Virtio Treiber in Windows installieren und dann für HDDs "virtio SCSI" und für die NIC "virtio" benutzen. Deutlich schneller als Intel E1000 oder IDE da paravirtualisiert. CPU type von "kvm64" auf "host" stellen bringt auch noch einmal ordentlich mehr CPU performance, sofern du die VMs nicht zwischen mehreren unhomogenen Nodes migirieren willst:
https://pve.proxmox.com/wiki/Windows_VirtIO_Drivers
 
Last edited:
Du solltest die Virtio Treiber in Windows installieren und dann für HDDs "virtio SCSI" und für die NIC "virtio" benutzen. Deutlich schneller als Intel E1000 oder IDE da paravirtualisiert. CPU type von "kvm64" auf "host" stellen bringt auch noch einmal ordentlich mehr CPU performance, sofern du die VMs nicht zwischen mehreren unhomogenen Nodes migirieren willst:
https://pve.proxmox.com/wiki/Windows_VirtIO_Drivers
Das Problem ist nicht das die VM nicht startet sondern das ISO Kopieren ist so langsam das dass nach 2 Stunden immer noch nicht fertig ist. (6GB)
Ich hab eine 1G Connection zum Host.
 
Siehst du irgendwo etwas Auslastung beim kopieren? I/O delay oder so?
 
Siehst du irgendwo etwas Auslastung beim kopieren? I/O delay oder so?
Nein nichts, hab auch mal im englischen Forum gepostet, da hab ich den Tipp her Kernel 5.15 auszuprobieren. Jetzt kommen am Gerät selbst 0,58 Gbit an aber keine 1G (getestet mit iPerf):

iperf3 -c 172.16.24.1 -fg Connecting to host 172.16.24.1, port 5201 [ 5] local 172.16.24.100 port 44920 connected to 172.16.24.1 port 5201 [ ID] Interval Transfer Bitrate Retr Cwnd [ 5] 0.00-1.00 sec 70.1 MBytes 0.59 Gbits/sec 0 110 KBytes [ 5] 1.00-2.00 sec 69.3 MBytes 0.58 Gbits/sec 0 110 KBytes [ 5] 2.00-3.00 sec 68.8 MBytes 0.58 Gbits/sec 0 110 KBytes [ 5] 3.00-4.00 sec 69.5 MBytes 0.58 Gbits/sec 0 110 KBytes [ 5] 4.00-5.00 sec 68.5 MBytes 0.58 Gbits/sec 0 110 KBytes [ 5] 5.00-6.00 sec 69.5 MBytes 0.58 Gbits/sec 0 110 KBytes [ 5] 6.00-7.00 sec 69.5 MBytes 0.58 Gbits/sec 0 110 KBytes [ 5] 7.00-8.00 sec 69.0 MBytes 0.58 Gbits/sec 0 110 KBytes [ 5] 8.00-9.00 sec 69.0 MBytes 0.58 Gbits/sec 0 110 KBytes [ 5] 9.00-10.00 sec 68.8 MBytes 0.58 Gbits/sec 0 110 KBytes - - - - - - - - - - - - - - - - - - - - - - - - - [ ID] Interval Transfer Bitrate Retr [ 5] 0.00-10.00 sec 692 MBytes 0.58 Gbits/sec 0 sender [ 5] 0.00-10.00 sec 692 MBytes 0.58 Gbits/sec receiver

Speedtest by Ookla Server: Contabo - Dusseldorf (id = 35154) ISP: Deutsche Telekom AG Latency: 5.42 ms (0.16 ms jitter) Download: 94.35 Mbps (data used: 47.1 MB ) Upload: 33.58 Mbps (data used: 16.0 MB ) Packet Loss: Not available.

WGET lässt mich auch mit 100MBit aus dem Internet ne ISO laden:
View attachment 33896

Aber intern erhalte ich halt nur:
View attachment 33895
Hab jetzt per Wget die ISO auf Proxmox bekommen, allerdings denke ich, dass das keine Dauerlösung sein kein.
 
Aber 0,6 GBit mit iperf ist wenig. Da sollte schon GBit ankommen. Routest du zwischen Netzen?
 
Aber 0,6 GBit mit iperf ist wenig. Da sollte schon GBit ankommen. Routest du zwischen Netzen?
Hi, ja, allerdings ist der iperf test zwischen Host und pfsense Firewall. Ich teste heute den Durchsatz von Windows PC zur Firewall. Ggf. Ist die Firewall das bottleneck aber nichts desto trotz müsste mehr als 300kbit/s am Host ankommen weil 0,6Gbit sollten trotzdem etwa 75 MB/s ergeben.

IPerf Test Netzwerk:
Proxmox Host -> Switch -> pfsense firewall
 
Last edited:
Wird in der pfsense auch gefiltert oder gescannt? Könntest du temporär ein anderes Gerät/VM Routen lassen?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!