[SOLVED] Proxmox nested on vCenter - VLANs not working

nicedevil

Member
Aug 5, 2021
104
10
23
Heya, I'm trying to get a nested Proxmox working inside vCenter.

I have a trunk Port with all VLANs assigned to it so I can assign the tags inside Proxmox for each LXC/VM.
Unfortunately the LXCs won't get an IP adress, doesn't matter which VLAN tag I assign to them.

I'm using the default stock installation with the default Linux bridge (vmbr0). On a not nested installation it is working like this.

Maybe there is something special that I missed for achieving this?

Ty in advance for any helpful response.
 
verify the "promiscous" mode of the vswtich and uplink.
by default vswitch only allow the vm mac address on each virtual port
you are the man :)

For anyone else that is looking for this setting:
1. open vCenter
2. select the ESXi Host that you want to configure
3. Networking > Virtual Switches
4. Click the small "Arrow" at the left of the vSwitch you want to edit to unfold the VLANs
1688407078077.png
5. click "edit" at the center
6. Security > Promiscuous mode > Accept
1688407165380.png
 
This is from memory ( I've no access to ESXI anymore).... and my memory is slow ( saw your post yesterday and trying since then to remember the word "promiscous"..)

Glad you could solve your issue !
EC
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!