Proxmox-Mailversand mit dynamischer IP / Testmail?

Discussion in 'Proxmox VE (Deutsch)' started by r4dh4l, Jun 5, 2018.

Tags:
  1. r4dh4l

    r4dh4l New Member
    Proxmox VE Subscriber

    Joined:
    Feb 5, 2018
    Messages:
    19
    Likes Received:
    1
    Hallo,

    mein Heim-Server läuft mit Proxmox jetzt seit einigen Monaten wunderbar. Allerdings frage ich mich, warum ich noch nie irgendeine System-Benachrichtigung per Mail erhalten habe (dafür gibt man die Adresse doch beim Installieren an, oder?). Das kann nun schlicht daran liegen, dass es nichts zu melden gibt, aber verlassen möchte ich mich darauf nicht, daher:

    1. Soweit ich verstanden habe wird der Mailversand über Postfix geregelt. Ich vermute, dass ein Postfix-Server mit einer IP aus einem variablen IP-Adressbereich Probleme hat, an reguläre Mailprovider Mails zu verschicken. Falls dem so ist: Ist es ohne größere Probleme möglich, Postfix entsprechend umzukonfigurieren, bspw. als Satellite-System oder durch zu Nullmailer ersetzen, um die System-Mails über einen privaten Mail-Account zu verschicken?

    2. Kann man irgendwo einstellen, dass Proxmox an einem bestimmten Tag eine Mail verschickt, die lediglich dazu dient, zu bestätigen, dass der Mailversand funktioniert (um einer "verdächtigen Ruhe" vorzubeugen)?

    Danke im Voraus!

    Edit: Als Domain habe ich in Proxmox eine DynDNS angegeben (also "MeineAdresse.ddns.net" in "/etc/hosts" und "/etc/postfix/main.cf"), die ich auch benutze, um Dienste auf den VMs von außen anzusprechen.
     
  2. fireon

    fireon Well-Known Member
    Proxmox VE Subscriber

    Joined:
    Oct 25, 2010
    Messages:
    2,419
    Likes Received:
    121
  3. r4dh4l

    r4dh4l New Member
    Proxmox VE Subscriber

    Joined:
    Feb 5, 2018
    Messages:
    19
    Likes Received:
    1
    Danke für die Rückmeldung. Google ist für mich außen vor (wenn ich mit Google kein Problem hätte, würde ich mir den Stress eines eigenen Servers nicht geben und denen einfach alles in den Rachen werfen - nichts ist bequemer als das Google-Universum).

    Zum Problem:

    Bevor ich Nullmailer kannte hatte ich mir Postfix als Satellite-System eingerichtet und das funktionierte soweit, war nur aufwendiger einzurichten. Ist es nicht möglich, Postfix zum Satellite-System umzukonfigurieren, sodass es wie Nullmailer System-Mails über ein vorhandenes Postfach verschickt? (Ich habe Nullmailer auf einer VM zu laufen und die verschickt bspw. tadellos Logwatch-Mails.)

    Edit: Ich sehe gerade, dass die Gmail-Geschichte in https://forum.proxmox.com/threads/how-to-use-google-apps-smtp-to-email-warnings.38236/#post-188938 auf ein Relay hinausläuft... ich teste das erstmal und melde mich, danke!
     
    #3 r4dh4l, Jun 6, 2018
    Last edited: Jun 6, 2018
    fireon likes this.
  4. r4dh4l

    r4dh4l New Member
    Proxmox VE Subscriber

    Joined:
    Feb 5, 2018
    Messages:
    19
    Likes Received:
    1
    Ich habe mich jetzt so weit "durchgebissen", dass ich die meisten Fehlermeldungen beim Postfix-Testversand an eine Posteo-Adresse beseitigen konnte. Allerdings komme ich bei folgendem Fehler in /var/log/mail.log nicht weiter:

    Code:
    warning: TLS library problem: error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../ssl/record/ssl3_record.c:252:
    Ich nutze Posteo als relayhost, da ich dort auch den Account habe, an den ich später Logwatch&Co senden lassen möchte. Meine aktuelle /etc/postfix/main.cf:

    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    myhostname=MeinHostname.MeineSubdomain.ddns.net
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    mydestination = $myhostname, localhost.$mydomain, localhost
    mydomain = posteo.de
    #relayhost =
    # sets Posteo as relay, has to be STARTTLS via 587
    relayhost = [posteo.de]:587
    mynetworks = 127.0.0.0/8
    inet_interfaces = loopback-only
    recipient_delimiter = +
    # use tls
    smtp_use_tls=yes
    # use sasl when authenticating to foreign SMTP servers
    smtp_sasl_auth_enable = yes
    # path to password map file
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    # list of CAs to trust when verifying server certificate
    smtp_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
    # additional settings mandatory for Posteo
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
    smtp_sasl_security_options = noanonymous
    smtp_tls_security_level = encrypt
    smtp_tls_wrappermode = yes
    
    Ich vermute mal es läuft darauf hinaus, dass ich dem Postfix noch sagen muss, bestimmte SSL-Verbindungsvarianten nicht zu nutzen - hat jemand eine Idee, wie ich das anstelle?
     
    #4 r4dh4l, Jun 8, 2018
    Last edited: Jun 9, 2018
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice