Proxmox fails to boot when an empty NVME drive is removed


New Member
Jul 16, 2023

I am having an issue with proxmox failing to boot properly when I remove an empty M.2 NVME drive. For context, I have the proxmox host OS and its associated boot partitions on a different SSD, with my VMs being stored on another M.2 NVME. I had been running Ubuntu and virtualizing machines by KVM, so I wanted to move those from that drive to the new M.2 (hence having two M.2 drives). I moved everything without issues and so I wanted to remove the no longer needed drive - however, this is the one that seems to be necessary.

Here is the output of lsblk, I have a few spinning drives that I don't think are relevant. nvme1n1 is the drive I cannot seem to remove.

sda 8:0 0 7.3T 0 disk
├─sda1 8:1 0 16M 0 part /mnt/pve/test
└─sda2 8:2 0 7.3T 0 part /mnt/HDD
sdb 8:16 0 1.8T 0 disk /mnt/tempHDD
sdc 8:32 0 223.6G 0 disk
├─sdc1 8:33 0 1007K 0 part
├─sdc2 8:34 0 1G 0 part /boot/efi
└─sdc3 8:35 0 222.6G 0 part
├─pve-swap 253:0 0 8G 0 lvm [SWAP]
└─pve-root 253:1 0 214.6G 0 lvm /
sr0 11:0 1 1024M 0 rom
nvme0n1 259:0 0 931.5G 0 disk
├─VMs-VMs_tmeta 253:2 0 9.3G 0 lvm
│ └─VMs-VMs-tpool 253:4 0 912.8G 0 lvm
│ ├─VMs-VMs 253:5 0 912.8G 1 lvm
│ ├─VMs-vm--100--disk--0 253:6 0 256G 0 lvm
│ ├─VMs-vm--101--disk--0 253:7 0 4M 0 lvm
│ ├─VMs-vm--101--disk--1 253:8 0 256G 0 lvm
│ └─VMs-vm--102--disk--0 253:9 0 8G 0 lvm
└─VMs-VMs_tdata 253:3 0 912.8G 0 lvm
└─VMs-VMs-tpool 253:4 0 912.8G 0 lvm
├─VMs-VMs 253:5 0 912.8G 1 lvm
├─VMs-vm--100--disk--0 253:6 0 256G 0 lvm
├─VMs-vm--101--disk--0 253:7 0 4M 0 lvm
├─VMs-vm--101--disk--1 253:8 0 256G 0 lvm
└─VMs-vm--102--disk--0 253:9 0 8G 0 lvm
nvme1n1 259:1 0 931.5G 0 disk

I have seen this reddit thread which seems to indicate that maybe the EFI partition is set up incorrectly, but I don't think so. lsblk indicates that the EFI partition is where it should be. I can get into grub just fine, and have tried booting in both normal and recovery mode. Neither work, but recovery mode seems to get slightly further, I could transcribe the TTY text as it boot if that would help. TTY stops updating after a few lines even in a normal boot for me, I think this is because I have disabled the GPU drivers for PCI passthrough?

I have tried wipefs to make sure nothing is on the drive, although I don't think it did anything. I tried putting another M.2 in the same slot as the misbehaving drive, also no luck. I have tried swapping disks around a few times, played around with the bios boot settings as well as CPU virtualization settings. I don't know why, but I know for sure that the system boots properly with the nvme1n1 M.2 in place, and doesn't when its removed.

At this point I don't know what to try! I'd appreciate any suggestions, I certainly am not an expert with linux or proxmox, and this is the first issue I couldn't solve by googling or that wasn't already documented on this forum (that I could find).



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!