Proxmox CIFS angeschaltet >>> Openmediavault CPU bis zu 50% CPU smbd

crmspezi

Member
Sep 5, 2019
180
7
18
41
Hallo,
auf NAS Systemen OpenMediaVault 5 (Debian 10), die kleinere CPU's drin haben (AMD A8-xxxx) habe ich den Effekt (bei 3 gleichen NAS getestet) , das das blanke Zuschalten des CIFS Storage (10 PVE's im Cluster) eine Grundlast auf der NAS mit 30-50% CPU erzeugt. Dabei gibt's es in der angelegten Freigabe max. 50 Dateien. Mir ist klar, das hier jeder PVE das Verzeichnis der NAS ständig abscannen tut. Auf NAS Systemen mit besseren CPU's wirkt sich das nicht so aus.

Welche Parameter könnte ich hier setzen, um dies zu mildern. Ein blankes periodischen Aufrufen per Windows Explorer der CIFS Freigaben erzeugt keine messbare Last.

Vielen Dank
crmspezi
 
Last edited:

crmspezi

Member
Sep 5, 2019
180
7
18
41
Ich habe eben nochmal Tests gemacht. Den Storage nicht für alle Knoten freizugeben, wäre die Umgehung aber nicht Lösung hier.

Bei einem Knoten: 3-5% CPU
bei 2 Knoten = Faktor 2
bei 3 Knoten = Faktor 3

Vielleicht kann man ja die CIFS Abfrage im Proxmox etwas beeinflussen?
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
5,446
559
133
32
Vienna
Vielleicht kann man ja die CIFS Abfrage im Proxmox etwas beeinflussen?
außer die nodes zu limitieren leider nicht.

da gibt es aber noch ein anderes problem, wenn schon nur die abfage der shares 50% cpu braucht, wird die performance bei 'normalen' zugriffen wohl sehr zu wünschen übrig lassen
 

crmspezi

Member
Sep 5, 2019
180
7
18
41
Hallo Dominik,
nein die Performance der VM's mit qcow2 und raw ist ziemlich gut (Windows Server). Auf der NAS liegt außer CIFS auch ZFS over iSCSI. Da kommt NULL Last zu Stande. Und von Windows aus als Share gibt es auch keine Lastprobleme. Es müsste also was mit dem CIPS Client Abfragen zu tun haben.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
5,446
559
133
32
Vienna
Es müsste also was mit dem CIPS Client Abfragen zu tun haben.
das hört sich auf jeden fall seltsam an und ist eig. nicht erwartetes verhalten. die abfrage verbindet sich eig. nur kurz mit dem server, obs ihn eh noch gibt und er erreichbar ist und sonst nix...
ist irgendwas im smbd log zu sehen ?
 

crmspezi

Member
Sep 5, 2019
180
7
18
41
Nur viele Abfragen

Mar 5 15:40:31 nasomv3 smbd[28096]: [2021/03/05 15:40:31.310545, 2] ../source3/smbd/dosmode.c:136(unix_mode)
Mar 5 15:40:31 nasomv3 smbd[28096]: unix_mode(.) inheriting from .
Mar 5 15:40:31 nasomv3 smbd[28096]: [2021/03/05 15:40:31.310646, 2] ../source3/smbd/dosmode.c:161(unix_mode)
Mar 5 15:40:31 nasomv3 smbd[28096]: unix_mode(.) inherit mode 42770
Mar 5 15:40:31 nasomv3 smbd[28096]: [2021/03/05 15:40:31.314121, 2] ../source3/smbd/dosmode.c:136(unix_mode)
Mar 5 15:40:31 nasomv3 smbd[28096]: unix_mode(images) inheriting from .
Mar 5 15:40:31 nasomv3 smbd[28096]: [2021/03/05 15:40:31.314217, 2] ../source3/smbd/dosmode.c:161(unix_mode)
Mar 5 15:40:31 nasomv3 smbd[28096]: unix_mode(images) inherit mode 42770
Mar 5 15:40:31 nasomv3 smbd[28096]: [2021/03/05 15:40:31.316773, 2] ../source3/smbd/dosmode.c:136(unix_mode)
Mar 5 15:40:31 nasomv3 smbd[28096]: unix_mode(.) inheriting from .
Mar 5 15:40:31 nasomv3 smbd[28096]: [2021/03/05 15:40:31.316868, 2] ../source3/smbd/dosmode.c:161(unix_mode)
Mar 5 15:40:31 nasomv3 smbd[28096]: unix_mode(.) inherit mode 42770
Mar 5 15:40:32 nasomv3 smbd[29917]: [2021/03/05 15:40:32.605368, 2] ../source3/param/loadparm.c:2803(lp_do_section)
Mar 5 15:40:32 nasomv3 smbd[29917]: Processing section "[DATABCK]"
Mar 5 15:40:32 nasomv3 smbd[29917]: [2021/03/05 15:40:32.605828, 2] ../source3/param/loadparm.c:2803(lp_do_section)
Mar 5 15:40:32 nasomv3 smbd[29917]: Processing section "[DATARAW]"
Mar 5 15:40:32 nasomv3 smbd[29917]: [2021/03/05 15:40:32.643035, 2] ../source3/auth/auth.c:316(auth_check_ntlm_password)
Mar 5 15:40:32 nasomv3 smbd[29917]: check_ntlm_password: authentication for user [freenasiscsiuser] -> [freenasiscsiuser] -> [freenasiscsiuser] succeeded
Mar 5 15:40:32 nasomv3 smbd[29917]: [2021/03/05 15:40:32.793451, 2] ../source3/smbd/service.c:849(make_connection_snum)
Mar 5 15:40:32 nasomv3 smbd[29917]: pve09 (ipv4:192.168.190.62:47160) connect to service DATARAW initially as user freenasiscsiuser (uid=1004, gid=100) (pid 29917)
Mar 5 15:40:32 nasomv3 smbd[29917]: [2021/03/05 15:40:32.794079, 2] ../source3/smbd/service.c:1129(close_cnum)
Mar 5 15:40:32 nasomv3 smbd[29917]: pve09 (ipv4:192.168.190.62:47160) closed connection to service DATARAW
Mar 5 15:40:32 nasomv3 smbd[28097]: [2021/03/05 15:40:32.796570, 2] ../source3/smbd/dosmode.c:136(unix_mode)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!