[SOLVED] Proxmox and pfSense

dpearceFL

Member
Jun 1, 2020
70
3
13
64
I've spent almost an entire day with no progress so I thought I would try here.

I have a VM in Proxmox VE 7.3-4 running pfSense 2.6.-RELEASE. That VM has two Linux Bridges assigned to it with the "WAN" being my regular network (192.168.1.0/24) and the LAN being a different bridge (10.10.10.0/24). I created a different VM with Ubuntu Desktop (DHCP) cleverly called "Workstation". This VM can reach the internet to update itself and browse the internet. I installed nginx on the workstation and tested it.

I have created two rules in Firewall / Rules / WAN for ICMP and HTTP. From the WAN network, no traffic gets through to the LAN (internal).

SOLUTION! On Interfaces / WAN, at the bottom of the page, uncheck "Block private networks...". Checked (blocked) is the default and what you would normally want for a real firewall configuration.

1673038297597.png
 
Last edited:
  • Like
Reactions: UdoB

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!