Proxmox: adding Synology iSCSI host freeze, then has duplicate serial number.

ty628659

New Member
Mar 9, 2022
4
0
1
42
Hi Community!

Proxmox VE: add a LVM storage on top of iSCSI

Error: create storage failed: device ‘dev/disk/by-id/scsi.....’ is already used by volume group ‘[unknown]’ (500)

it happen Add iSCSI... it has time out error (see picture 1), then I reboot the host server. it shows add iSCSI completed!!

Then, When I try to Add LVM for the new "Synology-ProxmoxLUN", is has duplicate serial number (see pictures 2,3)

does anyone can help me, it must be one config file has hard drive information.

Thanks!!!
Thomas
 

Attachments

  • Image 101.png
    Image 101.png
    61.3 KB · Views: 8
  • Image 102.png
    Image 102.png
    30.3 KB · Views: 8
  • Image 103.png
    Image 103.png
    38.9 KB · Views: 8

bbgeek17

Renowned Member
Nov 20, 2020
1,095
208
68
Blockbridge
www.blockbridge.com
You appear to have, possibly, accidentally setup a multipath access to your LUN, hence two devices with the same serial number.
You can run iscsiadm -m session ;iscsiadm -m target to get more info.
You should setup multipath and then place LVM on top of it: https://pve.proxmox.com/wiki/ISCSI_Multipath


Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox
 
  • Like
Reactions: menk

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!