Proxmox 8 kept dying with error 'UBSAN: array-index-out-of-bounds'

brok88

New Member
Jul 21, 2023
1
0
1
I bought a new Beelink SER6 Mini PC, AMD Ryzen 7 7735HS (8C/16T,up to 4.75GHz) with 16GB ram and had installed Proxmox 8 recently. It was working fine until 3 weeks ago when I realised I am not able to PING to the host or the VM. There is only 1 Windows 10 VM by the way.

I switched off the Beelink and powered it on again, I was able to login to the Proxmox console. However within 5 minutes, it crashed again. When I looked at the monitor, it is showing lines of errors involving UBSAN. When it crashed, I am unable to ping to the host.

I had worked for 20 years involving the Windows and VMWare infrastructures and 1st time trying out Proxmox after hearing how great it was. I tried googled online for the cause and solution but couldn't find anything that is useful for me. This crashing had been going on for a few weeks now and I am beginning to think if Proxmox is really suitable in a Production environment. :rolleyes:

If any gurus here can help me look at the errors and point me to the right direction, it will be very helpful for me :)

Image_2_50.jpg
 
Last edited:
I have UBSAN messages only on bootup but this is more megaraid
Code:
UBSAN: array-index-out-of-bounds in drivers/scsi/megaraid/megaraid_sas_fp.c:103:32
index 1 is out of range for type 'MR_LD_SPAN_MAP [1]'

https://forum.proxmox.com/threads/proxmox-ve-7-2-megaraid-issues.110587/
The messages are just warnings of a sanitizer - and should not impact the functioning of the system (please correct me if I'm wrong)


about Your issue ... I am not sure but You can try :
- check problems with /etc/default/grub options with 'amd_iommu'
Code:
GRUB_CMDLINE_LINUX_DEFAULT="amd_iommu=on iommu=pt quiet"
- check also SMT (HT on amd) and if turned off You must black list ACPI_PAD
Code:
##cat /etc/modprobe.d/blacklist.conf
blacklist acpi_pad
- cpuidle_state... check cpu mode :
CSS:
cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

good luck
 
ofc after editing grub... run :
update-grub

about cpu idle states ... I am using linux-cpupower and set performance during bootup
Code:
/usr/bin/cpupower -c all frequency-set -g performance


or add
/lib/systemd/system/x86_energy_perf_policy.service
Code:
[Unit]
Description=Run x86_energy_perf_policy at boot
After=network-online.target

[Service]
Type=oneshot
ExecStart=/usr/bin/cpupower -c all frequency-set -g performance

[Install]
WantedBy=multi-user.target

and
systemctl enable x86_energy_perf_policy.service
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!