[SOLVED] Problems with moving disk VM


New Member
Oct 3, 2022
Hi, I'm getting this error every time I want to move a disk of the VM to another disk. I state that I have all NAS (physical, Synology) in NFS

TASK ERROR: storage migration failed: target storage is known to cause issues with aio=io_uring (used by current drive)

can someone help me? Sorry for the English but I'm translating with Google
Change the disk to not use Async IO =io_uring (in the advanced section)
Select it in the GUi and click edit
Hi all,

This kind of error is annoying...

A default option generating errors is not an acceptable option, at least for us.

Can we hope someone will solve the problem?

If not, I will change on our clusters from io_uring to native.
Don't know performance gain / loss but with our workloads, lose some % is acceptable, an error : not really.

Thank you,

There is no shoe that fits all, so unless you change from NFS to something better, you need to change the I/O setting.
Yes, it is my understanding.

In my case it's a move disk from a Ceph storage to an iSCSI one.

Best solution for me : chose an async_io : threads, which seems to live together with any cache policy and any storage type.


One option to work around this problem could be to set the aio=native parameter directly in the configuration file /etc/pve/qemu-server/vmid.conf, then migrate the disk and remove the aio=native parameter, in this case the machine does not need to be rebooted, tested on versions Proxmox VE 8.1 and 7.4
It works!!. First use EDIT disk option on GUI and change "Async IO =io_uring" (in the advanced section) for "Async IO = native" and then move disk from local storage to a zfs over ISCSI lun.

Deeping on the issue, my problem was tried to move disk from local storage --> zfs over ISCSI LUN storage. It failed with message "TASK ERROR: storage migration failed: Could not open /dev/zpool0/vm-107-disk-0"
Diggin on the Proxmox shell CLI saw there is a problem on the path of symbolik link that "MOVE DISK" plugin assing to the moved disk.
root@pmxserver:~# ls -l /dev/zvol/zpool0/
total 0
lrwxrwxrwx 1 root root 11 Apr 18 12:54 vm-104-disk-0 -> ../../zd320
lrwxrwxrwx 1 root root 10 Dec 13 11:58 vm-106-disk-0 -> ../../zd64 <---- ok path
lrwxrwxrwx 1 root root 8 Apr 19 12:00 vm-107-disk-0 -> ../zd336 <----- not ok path due zfs disk is located on /dev directory

As you can see symbolik link for disk of vm-107 points to /dev/zvol while vm-107 disk (zd336) is located on /dev. The disk was created OK but moving process stops and fails because it can't find the disk.

Conlusion: One or some "MOVE disk" plugins assing an incorrect path to disks and the moving disk process fails because it can't find the file or vm's disk.
Perhaps using the Async advanced option, plugin assign a correct path for vm's disks.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!