Problems with loading in LXC and CPanel.

corianito

Member
Jul 20, 2019
43
0
11
37
Hello!

Sorry about the translation, I use a translator.

I have a problem, the CPanel servers show the load of the main server, i.e. the host, this is a problem because CPanel is detecting it as a high load and is not entering the emails in the servers, due to the high load error.

Is there any way to make LXC VPS show their actual load as KVM does and not the host's main load?

Greetings!
 
Yes, I already have it activated, but CPanel shows badly the load, they have answered me this, I do not know if you know what we can do:

cPSteven
  • 2 hours ago
Hello,
cPanel's WHMAPI call will perform a syscall to get the load averages.
sysinfo() << This function is not part of cPanel.
Querying this data LXC seems to pull information from the host machine. I found a bug report for LXC where they've have since repaired the issue but it does require that you perform a change on the host machine to prevent this from happening.
Are you using "-l" in the ExecStart for lxcfs?
This is NOT an issue that can be directly repaired in cPanel. This problem is reported by your system with syscall sysinfo.
Best Regards,
--
Steven V. Sublett
Technical Analyst III
Migration Specialist
cPanel, L.L.C.

Greetings!
 
sysinfo() can't be intercepted/isolated in LXC at the moment. so if cpanel uses this, we can't isolate it
 
Hello!

Sorry about the translation, I use a translator.

I have a problem, the CPanel servers show the load of the main server, i.e. the host, this is a problem because CPanel is detecting it as a high load and is not entering the emails in the servers, due to the high load error.

Is there any way to make LXC VPS show their actual load as KVM does and not the host's main load?

Greetings!

We had the same issue a few years back and I remember we fixed that by editing advanced exim editor and making a change for exims load trigger to a high value in the 100s. Count remember exactly where will post if I remember but maybe that will help you a bit
 
https://www.greennet.org.uk/support/exim-and-greylisting
deliver_queue_load_max = 20

should help

But I do think even though cpanel uses sysinfo its only for internally displaying in whm. I dont think its used for exim and the services as they use /proc/loadavg - correct me if I am wrong. cpanel is just an interface that makes it easy to use underlying free tools like exim for example. So the new fix for lxc -l you addded already should be working fine.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!