Problems Proxmox Firewall Configuration Ports

gsanz

New Member
Apr 5, 2020
6
0
1
38
Hello I am working with Proxmox and want to block some ports of them . I have used ProxMox GUI and followed these steps:


1-I enable firewall on the network machine

2- I put in the firewall the input policy options: ACCEPT and OUTPUT policy ACCEPT
3. In the Hardware section of the network machine, the firewall is enabled
4- Now I add the port with the following options. For example, for port 27017 these options would be set:
DIRECTION: IN
ACTION: DROP
PROTOCOL: TCP
DEST.PORT: 27017
After doing these steps I make a request to the port and it is still active. I do the following:

curl -XGET http://37.153.93.72:27017
It looks like you are trying to access MongoDB over HTTP on the native driver port.

Any ideas about something that is wrong or may be missing?
Thanks a lot.
Cheers
Gorka
 

Attachments

  • ded-une2804-report-Thu-19-November-2020-17-32.txt
    29.1 KB · Views: 0
  • image1.png
    image1.png
    32.6 KB · Views: 2
  • image2.png
    image2.png
    58 KB · Views: 2
  • image3.png
    image3.png
    187.8 KB · Views: 2

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
1,341
156
63
Did you enable the firewall on a datacenter level? Datacenter -> Firewall -> Options.

Without that enabled, it will not be enabled on a node or guest level.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!