[SOLVED] pmg-smtp-filter[19469]: WARNING: Use of uninitialized value $spages

emanuelserpa

New Member
Apr 28, 2020
8
1
3
23
I keep receiving this error in my syslog:


pmg-smtp-filter[19469]: WARNING: Use of uninitialized value $spages in int at /usr/share/perl5/PVE/ProcFSTools.pm line 253.

What is/are the reason/reasons for this error? How to fix it?

Thanks for the help.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,009
730
133
Please add your detailed version - if you have not current, update:

> pmgversion -v
 

emanuelserpa

New Member
Apr 28, 2020
8
1
3
23
Oh, I'm sorry, I forgot.

Here's the output:

Code:
root@gateway:~# pmgversion -v
Use of uninitialized value $spages in int at /usr/share/perl5/PVE/ProcFSTools.pm line 253.
Use of uninitialized value $spages in int at /usr/share/perl5/PVE/ProcFSTools.pm line 253.
Use of uninitialized value $spages in int at /usr/share/perl5/PVE/ProcFSTools.pm line 253.
Use of uninitialized value $spages in int at /usr/share/perl5/PVE/ProcFSTools.pm line 253.
proxmox-mailgateway-container: 6.2-1 (API: 6.2-3/dd58a339, running kernel: 4.19.0-8-cloud-amd64)
pmg-api: 6.2-3
pmg-gui: 2.2-1
clamav-daemon: 0.102.2+dfsg-1~pmg1
libarchive-perl: 3.3.3-1
libjs-extjs: 6.0.1-10
libjs-framework7: 4.4.7-1
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.0-19
libpve-http-server-perl: 3.0-5
libxdgmime-perl: 0.01-5
lvm2: 2.03.02-3
pmg-docs: 6.2-1
pmg-log-tracker: 2.1.4-1
postgresql-11: 11.7-0+deb10u1
proxmox-mini-journalreader: 1.1-1
proxmox-spamassassin: 3.4.4-2
proxmox-widget-toolkit: 2.1-6
pve-xtermjs: 4.3.0-1
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,196
684
118
Where have you deployed the PMG? - the running kernel (4.19.0-8) does not look like either a debian stock kernel nor a proxmox provided kernel?

the code causing the warning message has been in our repositories since 2013 - so I guess something changed somewhere else (my guess on your host)

what's the output of:
`cat /sys/kernel/mm/ksm/pages_sharing`
?
 

emanuelserpa

New Member
Apr 28, 2020
8
1
3
23
It's not a debian stock kernel, I think.

I'm using a openstack based instance on OVH, but it's debian 10 -- the version seems correct, anyway.

The output:
Code:
debian@gateway:~$ cat /sys/kernel/mm/ksm/pages_sharing

cat: /sys/kernel/mm/ksm/pages_sharing: No such file or directory



PS: the kernel is avaliable on the official Debian repositories:

https://packages.debian.org/buster/linux-image-4.19.0-6-cloud-amd64
 
Last edited:

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,196
684
118

emanuelserpa

New Member
Apr 28, 2020
8
1
3
23
yeah, looks like KSM is disabled

Code:
root@gateway:/home/debian# zgrep -i ksm /proc/config.gz
gzip: /proc/config.gz: No such file or directory

root@gateway:/home/debian# grep -i ksm /boot/config
grep: /boot/config: No such file or directory

root@gateway:/home/debian# grep -i ksm /boot/config-$(uname -r)
# CONFIG_KSM is not set

PS.: Found a relevant bug
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=955366

Thanks!
 
Last edited:

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,196
684
118
thanks for verifying this - I'll send a patch for discussion shortly.

come to think about it - is the openstack instance a KVM base virtual machine or a container?
i.e. could you install a kernel of your choice?
in that case you could install the proxmox-mailgateway metapackage, which pulls in the pve-kernel (where KSM is enabled)
(this is more out of curiosity)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!