[SOLVED] Plex port forwarding to LXC container?


New Member
May 30, 2019
Full disclosure -- I'm just a hobbyist and not an IT professional, so struggling a bit here.

I have Plex running on a Proxmox 5.4-3 Ubuntu LXC container with hardware acceleration enabled and am beyond thrilled with the results. For the life of me though, I can't figure out how to port forward to enable external access.

Brief details on my (basic home) network setup:

external ip address [123.456.789.012] > router [] > proxmox host [] > plex lxc container []

I need to forward custom port 32401 (external ip, i.e. 123.456.789.012:32401) to the plex host at ( -- standard plex port). I'm using 32401 as a custom port for plex because I don't want to blow up my existing plex setup at :32400 until I get this working. If there's a better port suggestion other than 32400 I'm all for it.

I have setup port forwarding on my router to both the proxmos host ( and the LXC Plex container ( through a bunch of different setting variations without success, but am confident with the general workflow on this step just need direction on the correct IP to point it to.

I've made my container privileged, disabled the firewall, and have been using the standard network settings on the container that allow container > internet connections. name: eth0, mac address: auto, bridge: vmbr0, no VLAN, no firewall, IPv4: DHCP, IPv6: DHCP

I have messed around with iptable settings on the host-side based on other forum posts in /etc/network/interfaces, but end up screwing up my proxmox host every time in the process.

Is there a simple, repeatable way to pull this off? Totally at a loss from where to go from here...
Last edited:
Hi! I don´t think you need to do anything extra ordinary. I´ve successfully setup plex with external access in a Ubuntu container using default network configuration.

In the "server settings part" of the Plex UI, have you specified manual port forwarding and your port of choice? I know from experience the plex web app for no apparent reason may claim that external access doesn´t work and at the refresh of the UI, the UI all of a sudden claims it works.
Thanks gechu, that's encouraging to hear, although something about my system blocks this from just working for some reason. Both Proxmox settings and general network setup are pretty vanilla, so not sure what the issue is.

Oddly on the manual port screen for Plex, it sometimes confirms that the connection is available externally (turns green) but then reverts back to not available ~3 seconds later. External website open port checking tools also see the port as closed as well.
What does your firewall port-forwarding look like? And what does your home network look like (devices, networks etc..)?

Here´s mine:

IPv4-tcp, udp
From any host in wan
Via any router IP at port 32400
The best way I know to share my network setup is like this:
external ip address [123.456.789.012] > router, ASUS TM-AC1900 [] > proxmox host [] > plex lxc container []

When you say Firewall, do you mean on the router, host or container? I currently have the firewall disabled on the container so maybe that's the issue? It's also not clear where I would replicate those values (i.e. via a config file or the UI).

For WAN port forwarding on the router, I have port range: 32401 assigned to local IP (plex container) for TCP & UDP.
Checked my container network settings again - and the firewall box is not checked.

I believe your network and internet facing router (the Asus TM-AC1900) all seems OK.

Some ISP:s use some sort of carrier grade NAT which may prevent you from accessing your services externally. Can you expose other services?
@gechu -- thanks so much for your help!

So I decided to go nuclear and do a complete reinstall of proxmox on my machine to start from scratch (I had done enough fiddling on the host side that things were getting weird).

For anyone else that stumbles across this thread, I spun up a new container, privileged, no firewall with standard networking options (DHCP in my case). Port forwarded the traditional plex 32400 from my router to the IP of the LXC container as opposed to the custom one I was trying to use, and it worked like it was supposed to.

Huge exhale, finally.
Have you used this guide? http(s)://forums.plex.tv/t/pms-installation-guide-when-using-a-proxmox-5-1-lxc-container/219728



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!