PCIe NIC detected only when booting from one SMP MP-table (every second boot)


Feb 26, 2020
Hi, I have PCIe network interface card: NC375T PCI Express Quad Port Gigabit Server Adapter. It uses netxen_nic module. The problem is that it's detected every second boot. I noticed that the module and firmware are loaded correctly when it boots using certain SMP MP-table. When I see in journal:

found SMP MP-table at [mem 0x000fcdc0-0x000fcdcf

then everything works perfectly, but when i see:

found SMP MP-table at [mem 0x000fcd50-0x000fcd5f

the NIC is not detected, loading modules manually with

modprobe netxen_nic

doesn't bring it up.

Do you have any clue how can I force the system to boot from the working SM-table? I even don't know what these tables are. I tried every option for acpi boot parameter and a lot of related with acpi, apic, pci, pcie like:
  • acpi_force_table_verification
  • acpi_no_auto_serialize
  • acpi_apic_instance=
  • acpi_no_static_ssdt
None worked for me.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!