[SOLVED] PBS no longer working after upgrading host to PVE 7

lukyjay

Member
Aug 18, 2020
15
3
8
Hi

I have Proxmox Virtual Environment (PVE) installed and upgraded to the PVE 7 BETA. I had Proxmox Backup Server (PBS) installed on the host but after the BETA upgrade it has stopped working.

It's still installed.

I think the service file is: /lib/systemd/system/proxmox-backup.service
which fails to run. I ran the command manually as root on the host:
Bash:
root@pve1:~# /usr/lib/x86_64-linux-gnu/proxmox-backup/proxmox-backup-api

/usr/lib/x86_64-linux-gnu/proxmox-backup/proxmox-backup-api: error while loading shared libraries: libsgutils2.so.2: cannot open shared object file: No such file or directory

Note that libsgutils2-2 is already the newest version (1.45-1).

I'm going to guess PBS is not compatible with Debian Bullseye, which is what PVE7 uses. Is there any workaround?

Thanks
Jayden
 

grefabu

Active Member
May 23, 2018
209
10
38
48
To setup a new test machine?

I've upgrade an PVE/PBS test enviroment too and 've the same incidence.
Think we've to wait until the PBS is altough build for bullsey?

I hope it is only a test machine for you?
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,659
973
173
If you install additional packages, you should check if these still works after you dist-upgrade - we mention this in our upgrade docs.

=> See https://pve.proxmox.com/wiki/Upgrade_from_6.x_to_7.0#Introduction

For now, you cannot run Proxmox Backup Server on Bullseye - in a few days we will release first public packages and then it start working again.
 

lukyjay

Member
Aug 18, 2020
15
3
8
To setup a new test machine?

I've upgrade an PVE/PBS test enviroment too and 've the same incidence.
Think we've to wait until the PBS is altough build for bullsey?

I hope it is only a test machine for you?
Not a test machine, but I'm a home user so happy to go a while without new backups

If you install additional packages, you should check if these still works after you dist-upgrade - we mention this in our upgrade docs.

=> See https://pve.proxmox.com/wiki/Upgrade_from_6.x_to_7.0#Introduction

For now, you cannot run Proxmox Backup Server on Bullseye - in a few days we will release first public packages and then it start working again.
Awesome thank you. I'll wait for the next release!
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,659
973
173
@tom might there be some beta version ready to be tested?
For now, you cannot run Proxmox Backup Server on Bullseye - in a few days we will release first public packages and then it start working again.
 
  • Like
Reactions: showiproute

bofh

Active Member
Nov 7, 2017
126
11
38
43
Code:
Directory /usr/lib/x86_64-linux-gnu
hardlink libsgutils2-1.45.so.2.0.0 to libsgutils2.so.2

pbs boots after that and seems to work, can some dev confirm this as solution workaround for now?
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,559
1,832
174
South Tyrol/Italy
shop.proxmox.com
Code:
Directory /usr/lib/x86_64-linux-gnu
hardlink libsgutils2-1.45.so.2.0.0 to libsgutils2.so.2

pbs boots after that and seems to work, can some dev confirm this as solution ?
While it may seem to work it's rather unsupported and may break at will if you're a bit unlucky, library symbol-versioning and ABI bumps are done for a reason. Please wait the few days until official PBS packages are released for Bullseye instead, thanks!
 
  • Like
Reactions: showiproute

bofh

Active Member
Nov 7, 2017
126
11
38
43
While it may seem to work it's rather unsupported and may break at will if you're a bit unlucky, library symbol-versioning and ABI bumps are done for a reason. Please wait the few days until official PBS packages are released for Bullseye instead, thanks!
waiting is not an option.
rather risk having broken backups than having no backups aka certainly no backups

backups runs trough, no errors so far, verify is ok too
 

bofh

Active Member
Nov 7, 2017
126
11
38
43
I agree to @t.lamprecht -> it's usually not always the best idead to play around with library linking
never said its a good idea, but main version is still the same and hasnt change since 2018. and having a defunct pbs is even worse as having a halfway broken one:
question is what PBS does with the scsi tools. if its just to initialize storage or read out diskinfo then it should not affect operations.

 

bofh

Active Member
Nov 7, 2017
126
11
38
43
haha and waiting to install a full new release after letting others test it or reading all the release notes wasn't an option either. PBS incompatibility with PVE 7 has been known since the launch of the beta. Anyone coming here shocked and upset didn't do their own due diligence prior to upgrading.
never claimed im shocked, i expected this before the upgrade and noone here is complaining, just looking for solutions.
there where other reasons behind the decision todo things the way they have been done, none of which i have to or will explain here.

but yea be condescending and blame people in this way, despite you know nothing about the why, how and who.
well done and very topic oriented, hope you feel proud of yourself now. now go back to your homelab and let grownups talk
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,559
1,832
174
South Tyrol/Italy
shop.proxmox.com
Let's stop it here with off-topic talk now please, that does not help anybody.

FYI: The sgutils library is mainly for use with tape backup, so if you do not use tape drives/libraries you should be quite safe, but just for the record, that's still no encouragement to anybody else for upgrading if you have Proxmox VE and Proxmox Backup Server Co-installed directly on the same host (if PBS runs in a VM or CT that can be done just fine though).
 

lukyjay

Member
Aug 18, 2020
15
3
8
Thank you tom and t.lamprecht, I have marked the thread as resolved.

Resolution: Issue is known and will be fixed in an upcoming update.

It's also worth noting that no one should update to beta releases if they can't afford downtime of some (or all) functions. While I did read through the wiki page for PVE7 and didn't see any notes on this, I might have missed it and like I said above, backups are not critical for me as a home user so I'm happy to wait :)
 

bofh

Active Member
Nov 7, 2017
126
11
38
43
Let's stop it here with off-topic talk now please, that does not help anybody.

FYI: The sgutils library is mainly for use with tape backup, so if you do not use tape drives/libraries you should be quite safe, but just for the record, that's still no encouragement to anybody else for upgrading if you have Proxmox VE and Proxmox Backup Server Co-installed directly on the same host (if PBS runs in a VM or CT that can be done just fine though).
thanks lamprecht, thats what i wanted to know
 

luk085

Member
Sep 21, 2017
1
0
6
37
Hello,
I've used https://pbs.proxmox.com/wiki/index.php/Upgrade_from_1.1_to_2.x to upgrade to 2.x and have the same problem with libsgutils2.so.2
Has the problem been resolved or need to wait for update?

Edit:
I found the solution. I added:
Code:
deb http://download.proxmox.com/debian/pbs bullseye pbs-no-subscription
to sources.list
No subscription sources.list is not mentioned in manual.
 
Last edited:

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,559
1,832
174
South Tyrol/Italy
shop.proxmox.com
Yeah, without any PBS repository setup the update really cannot work.

No subscription sources.list is not mentioned in manual.
That's because they are not meant for production services, and we mention the enterprise repository clearly.
Also, as valid PBS package repositories are required to update the system to latest 1.1 anyway, the "replace buster with bullseye" command normally also provides one with a new valid Proxmox Backup Server repository even if one has no subscription.

Note, mostly for future readers, this thread was a result of Proxmox VE 7.0 being released earlier that Proxmox Backup Server 2.0; as that is now not the case any more, it's highly probably the wrong thread to reply. So please just open a new one.
 
  • Like
Reactions: luk085

LongDono

New Member
Jan 24, 2021
1
0
1
50
Halifax, Nova Scotia, Canada
Hello,
I've used https://pbs.proxmox.com/wiki/index.php/Upgrade_from_1.1_to_2.x to upgrade to 2.x and have the same problem with libsgutils2.so.2
Has the problem been resolved or need to wait for update?

Edit:
I found the solution. I added:
Code:
deb http://download.proxmox.com/debian/pbs bullseye pbs-no-subscription
to sources.list
No subscription sources.list is not mentioned in manual.

Thank you. I upgraded today and the PBS GUI was no longer responding after restarting. After adding the missing source and installing the newly found updates, the issue was resolved. The upgrade document we followed should be updated to reflect this.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!