OVMF (UEFI) Windows 10 Boot Option won't stick

b1ackplague

New Member
May 12, 2016
1
0
1
30
Proxmox 4.2
  • After it restarts it acts as if there is no virtual disk.
  • Enter BIOS configuration > Boot Maintenance Manager > Boot Options > Add Boot Option > select the disk, browse to efi > boot > select bootx64.efi.
  • Change Boot order
  • Save all changes.
  • Boots fine.
The problem is I have to add the disk and change boot order every time I restart or power off the VM.

How I setup the VM
  • Set up VM.
    • Select Windows 10
    • Add a new vDisk using Virtio Bus (iothread + Write back Cache) as Virtio0
    • add Qemu agent -> yes
    • Add windows 10 Iso as First DVD on Sata0
    • Add Virtio-win-0.1.117 as secondary DVD on Sata1
    • Select Virtio Controller via Options Tab (afaik best practice is to use SCSI ontop of Virtio controller for Windows on SSDs)
    • Verify your boot Orders. —> Disk then CD-Rom
  • Install windows 10
    • Start Windows VM
    • Boot from Windows ISO (press any key to start from DVD/CD . . .)
    • select “Install Now”
    • select windows 10 pro x64
    • custom install
      • “load Driver” option
        • Select Virtio-DVD > Viostor > w8.1 > amd64
        • Install Red Hat VirtIO SCSI controller (driver for your virtio0)
      • “load Driver” option
        • Select Virtio-DVD > VioSCSI > w8.1 > amd64
        • uncheck the checkbox
        • Install Red Hat VirtIO SCSI pass-through controller (in case you need it later)
      • “load Driver” option
        • Select Virtio-DVD > netKVM > w8.1 > amd64
        • uncheck the checkbox
        • Install Red Hat VirtIO Ethernet Adapter (you will need this later)
    • Install windows regularly (like you'd normally do)
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
4,887
328
83
Hi,

You have to set the boot order on the Option tab in the GUI.
 

fxdaemon

New Member
Mar 8, 2016
24
2
3
28
I have same issue and VM config looks like following. Boot order from GUI already set to virtio disk the first choice:

bios: ovmf
boot: cdn
bootdisk: virtio0
cores: 6
hostpci0: 03:00,pcie=1,x-vga=on
ide2: cdrom,media=cdrom
machine: q35
memory: 8192
name: WinTen
net0: e1000=66:37:38:62:63:62,bridge=vmbr0
numa: 1
ostype: win8
smbios1: uuid=e79f8bad-b023-448f-97b0-aaa1c3d26b29
sockets: 1
usb0: host=1-4
virtio0: local:103/vm-103-disk-1.raw,cache=writethrough,size=32G
virtio1: local:103/vm-103-disk-2.raw,cache=writethrough,size=100G
 

fxdaemon

New Member
Mar 8, 2016
24
2
3
28
Thanks. Is there a way to change the existing disk type without starting from scratch and build a new VM?
 

davlaw

Member
Apr 4, 2012
128
1
16
Proxmox 4.2
  • After it restarts it acts as if there is no virtual disk.
  • Enter BIOS configuration > Boot Maintenance Manager > Boot Options > Add Boot Option > select the disk, browse to efi > boot > select bootx64.efi.
  • Change Boot order
  • Save all changes.
  • Boots fine.
The problem is I have to add the disk and change boot order every time I restart or power off the VM.


This was brought up in another post on here somewhere that the bios settings were not working, they are saved in /tmp I think. Messed with it for a day or so, guess you could copy the bios file to a known location and modify the conf for the VM to load it. Having not done this, I'm not sure specifics.
 

fxdaemon

New Member
Mar 8, 2016
24
2
3
28
yes, sure.
remove the disk (it'll not be deleted, just put in "unused")
then edit the unused disk, and set it to scsi.

(and in vm options, choose virtio-scsi controller)
HI Spirit,
Is there instruction on how this can be done for both disk and controller?
I was able to remove the disk, edit and change its disk type to scsi.
However, I think I am missing the part about virtio.
With only the disk type changed to scsi and re-added to VM when I start up VM, UEFI can't find the disk at all.

Rgds,
FXD
 

spirit

Well-Known Member
Apr 2, 2010
3,507
155
63
www.odiso.com
HI Spirit,
Is there instruction on how this can be done for both disk and controller?
I was able to remove the disk, edit and change its disk type to scsi.
However, I think I am missing the part about virtio.
With only the disk type changed to scsi and re-added to VM when I start up VM, UEFI can't find the disk at all.

Rgds,
FXD
scsihw: virtio-scsi-pci

(in gui : vm option tab -> scsi controller type ->virtio)
 

fxdaemon

New Member
Mar 8, 2016
24
2
3
28
scsihw: virtio-scsi-pci

(in gui : vm option tab -> scsi controller type ->virtio)
Ok thanks found it. However, I am starting to get BSOD on boot up now. Not sure if this is just Win10 specific or what.
I may have to try my luck with installing from scratch now and see how goes it.

BTW, with the disk changed to SCSI & controller as virtio, UEFI still fails to remember the boot device
order change in persistant manner across reboot.

Cheers,
FXD
 

Roobre

New Member
Aug 28, 2016
1
1
1
26
Sorry if I'm reviving a dead thread, but I experienced the very same issue with livbirt, and wanted to leave a solution here for the record.
Leave ONLY the virtio disk as a boot option. It seems that OVMF picks literally anything else before virtio, and changes made on the UEFI cannot be saved in any way.

Also, it was pure virtio, not scsi+virtio.
 
  • Like
Reactions: ;piod

talos

Member
Aug 9, 2015
44
3
8
Hi,

afaik this is a known issues with ovmf and virtio. We really need a solution for this. I dont know if this is a proxmox or a general uefi firmware issue.

Second issues with omvf, you can't power down a vm in the gui (force poweroff), only way is to kill the qemu process.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,683
434
83
Hi,

afaik this is a known issues with ovmf and virtio. We really need a solution for this. I dont know if this is a proxmox or a general uefi firmware issue.

Second issues with omvf, you can't power down a vm in the gui (force poweroff), only way is to kill the qemu process.
works for me.

pls test again with latest version (pvetest).
 

talos

Member
Aug 9, 2015
44
3
8
works for me.

pls test again with latest version (pvetest).
Updated packages 1 hour ago, tried it, doesnt work.. searching for netboot und jumped right into uefi shell. Switched boot order to only use disk.. now it works, yay!

Ps. i like the new bios splash screen + proxmox logo.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!