Nvidia GTX 980 Passthrough - Error Code 43

vaporchipmunk

New Member
Mar 11, 2022
1
0
1
I am trying to passthrough my GTX 980 since a few days. I've tried a lot of different solutions and so far, none of them gets me over this cursed error code 43.

I'm running Proxmox VE v7.1-7 on the following machine:
  • CPU: Intel Core i3 8100 (Coffee Lake)
  • Motherboard: Gigabyte z730n
  • GPU: MSI GeForce GTX980 4G
The VM is loaded with the latest Windows 10 Pro version downloaded from Microsoft's servers.

Here is my current VM configuration (I tried several other configurations - none of them worked):

Code:
bios: ovmf
boot: order=sata0;ide2;net0
cores: 4
args: -cpu 'host,+kvm_pv_unhalt,+kvm_pv_eoi,hv_vendor_id=proxmox,hv_spinlocks=0x1fff,hv_vapic,hv_time,hv_reset,hv_vpindex,hv_runtime,hv_relaxed,hv_synic,hv_stimer,hv_tlbflush,hv_ipi,kvm=off'
cpu: host,hidden=1,flags=+pcid
efidisk0: LM-GamingPC:100/vm-100-disk-1.qcow2,efitype=4m,pre-enrolled-keys=1,size=528K
hostpci0: 01:00,pcie=1,romfile=nvidia-gtx980.rom,x-vga=1
machine: pc-q35-3.1
memory: 12000
meta: creation-qemu=6.1.0,ctime=1647018824
name: LM-GamingPC
numa: 0
ostype: win10
sata0: LM-GamingPC:100/vm-100-disk-0.qcow2,size=80G
scsihw: virtio-scsi-pci
sockets: 1

Here my Grub configuration

Code:
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on iommu=pt video=vesafb:off video=efifb:off"
GRUB_CMDLINE_LINUX=""

I went through several recreations of the windows VM and a couple of re-installation of the Proxmox VE, so far and I followed instructions and guidelines from:
  1. here: https://pve.proxmox.com/wiki/Pci_passthrough
  2. and/or here: https://bbs.archlinux.org/viewtopic.php?id=162768
  3. and/or here: https://www.reddit.com/r/homelab/comments/b5xpua/the_ultimate_beginners_guide_to_gpu_passthrough/
I also followed various video tutorials on YouTube and on other resources from the web from people who managed to get over this error, all more or less around the approaches described in the previously mentioned lists.

Lastly, I checked on this forum and I tried to follow the ROM patching approach described in the post:
https://forum.proxmox.com/threads/nvidia-gtx-1050ti-error-43-code-43.75553/#post-457290

Even though this approach is claimed to work only on 1xxx series and not on 9xx series, I tried in any case by patching one of the rom files at this address: https://www.techpowerup.com/vgabios...rface=PCI-E&memType=GDDR5&memSize=4096&since=

None of the approaches I tried has worked and I honestly don't know what else I can try...I have no clue of what is wrong with my hardware or with what I do.
This post is my last chance.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!