NoVNC on Android: Special characters become numbers (e.g. $ -> 4)


New Member
Oct 19, 2021
I stumbled across the same problem as discussed in this Thread here. As the Thread is closed for almost 3 years, I hope i t is okay to start a new one.

I can't type any special characters like `%` or `$` using NoVNC in the Proxmox WebUI on my Android phone (using Firefox). The special characters will end up as the numbers that would be on the same keys on a normal QWERTZ/Y keyboard.

Like suggested in the thread, I tried changing the setting for `privacy.resistFingerprinting` in `about:config`, but it was already set to `false` (disabled?)

I also checked with the e/OS native browser (i think it is `bromite` which is a `chromium` fork) and the behaviour is the same.

I also tried another Keyboard from F-Droid, but no luck.

Has anyone had this recently and solved it?
  • Like
Reactions: Carlos34
Same problem here. It still presist. I think its noVNC issue not handling keys correctly from virtual keyboard. Virtual keyboard doesnt have key events like physical keyboard has. So noVnc is guessing those keypress events before handling it to qemu. But seems this guessing is somehow broken with shift key.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!