NoVNC Mouse Lag

masterdaweb

Member
Apr 17, 2017
83
3
13
27
Hello friends.


Since Proxmox 5.1 I'm facing a mouse lag with NoVNC.

Is there any configuration which I could edit to try to solve this ?

On Proxmox earlier versions it doesn't happens.

Here it is a recording, on Proxmox 5.1, showing Mouse sliding with Lag:

mouse lag.gif


And here it is another Recording, with Proxmox 5.0.x, showing Mouse sliding smoothly:

mouse working good.gif
 
Last edited:
Jul 6, 2016
218
6
23
36
Hi @ all,

we are facing a similar error on 5.2-3 :
The mouse on noVNC also laggs but it is caught by the system cursor. So we only see one cursor that is lagging.

Any idea why this problem occours on proxmox 5.2-3, because on 5.2.1 everything is fine?
 

TomTomGo

Active Member
Mar 30, 2012
47
0
26
France
Keyboard ALT+GR issue with French keyboard layout and mouse lag issue seems to be fixed for us since last novnc-pve upgrade today :

Code:
Start-Date: 2018-07-31  11:44:52
Commandline: apt-get dist-upgrade
Upgrade: fuse:amd64 (2.9.7-1, 2.9.7-1+deb9u1), pve-docs:amd64 (5.2-4, 5.2-5), pve-cluster:amd64 (5.0-28, 5.0-29), pve-manager:amd64 (5.2-5, 5.2-6), libfuse2:amd64 (2.9.7-1, 2.9.7-1+deb9u1), novnc-pve:amd64 (1.0.0-1, 1.0.0-2), libpve-common-perl:amd64 (5.0-35, 5.0-37), qemu-server:amd64 (5.0-29, 5.0-30), pve-kernel-4.15.18-1-pve:amd64 (4.15.18-15, 4.15.18-16)
End-Date: 2018-07-31  11:46:43
root@svprx1:~#
Thanks to the Proxmox team !

Regards,
 

masterdaweb

Member
Apr 17, 2017
83
3
13
27
For me mouse still lags:

Code:
proxmox-ve: 5.2-2 (running kernel: 4.15.18-1-pve)
pve-manager: 5.2-6 (running version: 5.2-6/bcd5f008)
pve-kernel-4.15: 5.2-4
pve-kernel-4.15.18-1-pve: 4.15.18-16
corosync: 2.4.2-pve5
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.0-8
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-37
libpve-guest-common-perl: 2.0-17
libpve-http-server-perl: 2.0-9
libpve-storage-perl: 5.0-24
libqb0: 1.0.1-1
lvm2: 2.02.168-pve6
lxc-pve: 3.0.0-3
lxcfs: 3.0.0-1
novnc-pve: 1.0.0-2
proxmox-widget-toolkit: 1.0-19
pve-cluster: 5.0-29
pve-container: 2.0-24
pve-docs: 5.2-5
pve-firewall: 3.0-13
pve-firmware: 2.0-5
pve-ha-manager: 2.0-5
pve-i18n: 1.0-6
pve-libspice-server1: 0.12.8-3
pve-qemu-kvm: 2.11.2-1
pve-xtermjs: 1.0-5
qemu-server: 5.0-30
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.9-pve1~bpo9
 

TomTomGo

Active Member
Mar 30, 2012
47
0
26
France
Do you have the "VMware Pointer Device" installed in your Windows guests ?

upload_2018-7-31_13-20-11.png

Drivers are available from VMware Tools ...
There's also some new options in the NoVNC menu : try to tick / untick Local Cursor (it's ticked on my side ...)

upload_2018-7-31_13-21-30.png

Regards,
 

Brandon Holland

New Member
Nov 8, 2018
1
0
1
36
I think i have two issues the first one the smoothness issue as well as i dont have a local cursor on one of my installs... and do have it on another and dont have the options in the menu to turn it on. The lag to me not a big deal if i have a local cursor... if not idk where i'm going to click and its sickening... Any way to figure out how to get the local cursor back on this? the install WITH a cursor is on 521 the one without is 522, that wouldnt matter would it?
 
Last edited:

masterdaweb

Member
Apr 17, 2017
83
3
13
27
Does anyone could figure it out ?

Because even after several Proxmox updates, since Proxmox 5.1 novnc mouse still lags.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!