Node shutdown takes 10Minutes because of stalled VM (timeout set to 80s)

Discussion in 'Proxmox VE: Installation and configuration' started by bfwdd, Nov 8, 2018.

Tags:
  1. bfwdd

    bfwdd New Member
    Proxmox Subscriber

    Joined:
    Mar 29, 2016
    Messages:
    3
    Likes Received:
    1
    To ensure a proper shutdown of the proxmox/ceph cluster in case of power
    failure I experimented with setting a Timeout for quitting VMs.

    I've used 80s, but if the VM hangs, it will be killed after 10minutes instead of 80s.
    Where do this timeout of 10Minutes come from?

    Any help appreciated!
    With regards
    Konrad

    details with systemd-log:
    https://bugzilla.proxmox.com/show_bug.cgi?id=1983

    root@fidel:~# pveversion -v
    proxmox-ve: 5.2-2 (running kernel: 4.15.18-7-pve)
    pve-manager: 5.2-10 (running version: 5.2-10/6f892b40)
    pve-kernel-4.15: 5.2-10
    pve-kernel-4.15.18-7-pve: 4.15.18-27
    pve-kernel-4.15.18-5-pve: 4.15.18-24
    ceph: 12.2.8-pve1
    corosync: 2.4.2-pve5
    criu: 2.11.1-1~bpo90
    glusterfs-client: 3.8.8-1
    ksm-control-daemon: 1.2-2
    libjs-extjs: 6.0.1-2
    libpve-access-control: 5.0-8
    libpve-apiclient-perl: 2.0-5
    libpve-common-perl: 5.0-40
    libpve-guest-common-perl: 2.0-18
    libpve-http-server-perl: 2.0-11
    libpve-storage-perl: 5.0-30
    libqb0: 1.0.1-1
    lvm2: 2.02.168-pve6
    lxc-pve: 3.0.2+pve1-3
    lxcfs: 3.0.2-2
    novnc-pve: 1.0.0-2
    openvswitch-switch: 2.7.0-3
    proxmox-widget-toolkit: 1.0-20
    pve-cluster: 5.0-30
    pve-container: 2.0-29
    pve-docs: 5.2-8
    pve-firewall: 3.0-14
    pve-firmware: 2.0-5
    pve-ha-manager: 2.0-5
    pve-i18n: 1.0-6
    pve-libspice-server1: 0.14.1-1
    pve-qemu-kvm: 2.12.1-1
    pve-xtermjs: 1.0-5
    qemu-server: 5.0-38
    smartmontools: 6.5+svn4324-1
    spiceterm: 3.0-5
    vncterm: 1.5-3
    zfsutils-linux: 0.7.11-pve1~bpo1
     
    sumsum likes this.
  2. Alwin

    Alwin Proxmox Staff Member
    Staff Member

    Joined:
    Aug 1, 2017
    Messages:
    2,345
    Likes Received:
    212
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. bfwdd

    bfwdd New Member
    Proxmox Subscriber

    Joined:
    Mar 29, 2016
    Messages:
    3
    Likes Received:
    1
    Thanks for your response,
    Yes, agent was missing in VM, but activated in options.
    If I disable agent in options, the VM properly shutdown, so I guess it uses ACPI-power signal ONLY with disabled agent.
    Didn't know that.

    For the record: KVM processes became unresponsive, had to be killed with -9
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice