No View of IP Addresses in VE 8?

bearhntr

Member
Sep 9, 2022
150
9
18
Atlanta, GA USA
I took the plunge this weekend - wanted to replace the SSD with an NVME in my ProxMox home lab server. I backed up my 4 VMs (just in case) - and installed a new NVME 1TB drive - performed a fresh clean install from USB of VE 8. So far so good. I had to re-do the IOMMU stuff and some other things (notes from previous install -- hee hee).

I have a DHCP reservation for the MAC Address in the server, but still set it statically. I have not put any VMs back yet, as I am just exploring things. First thing I noticed is that my IP information (I have IPV4 and IPV6 (track-interface) from my pfSense machine (it is not a VM - standalone Thin Client machine) is not shown here:

1699888293020.png

It used to show the IPv4 and IPv6 address in the PVE Host WebPage when looking at the summary for the host (pve01). I cannot find it anywhere. If I open the SHELL - I can run the 'ip addr' command and see that it is not even pulling an IPv6 from pfSense. The other 4-port NIC card - with one cable plugged in as a test, is pulling BOTH IPv4 and IPv6 from pfSense.

1699888679342.png

Here is my /etc/network/interfaces

# network interface settings; autogenerated
# Please do NOT modify this file directly, unless you know what
# you're doing.
#
# If you want to manage parts of the network configuration manually,
# please utilize the 'source' or 'source-directory' directives to do
# so.
# PVE will preserve these directives, but will NOT read its network
# configuration from sourced files, so do not attempt to move any of
# the PVE managed interfaces into external files!

auto lo
iface lo inet loopback

iface lo inet6 loopback

iface eno1 inet manual

iface eno1 inet6 manual

iface ens4f0 inet manual

iface ens4f0 inet6 manual

iface ens4f1 inet manual

iface ens4f2 inet manual

iface ens4f3 inet manual

auto vmbr0
iface vmbr0 inet static
address 10.9.28.240/24
gateway 10.9.28.254
bridge-ports eno1
bridge-stp off
bridge-fd 0
#On-Board NIC (for HOST)

inet vmbr0 inet6 dhcp

auto vmbr40
iface vmbr40 inet dhcp
bridge-ports ens4f0
bridge-stp off
bridge-fd 0
#Intel i350-T4 (port 0)

iface vmbr40 inet6 dhcp

1) How to I get the SUMMARY on the web page to show the Host IP information?

2) How do I get it to pull an IPv6 address?
 
It used to show the IPv4 and IPv6 address in the PVE Host WebPage when looking at the summary for the host (pve01). I cannot find it anywhere
I have never seen that. Maybe you modified your PVE to show this like some people do to show the CPU temperature on the Host summary?
 
1) There was never was a IP address summary, you can check your network settings for your host in the (Host->Settings->Network)
2) Maybe that I am mistaken, but it seems to me, that your interfaces got the ipv6 addresses or not ?
Eg. For vmbr40 it is: 2601:c4:c501:8bf0::e8rc/64
 
Last edited:
1) There was never was a IP address summary, you can check your network settings for your host in the (Host->Settings->Network)
2) Maybe that I am mistaken, but it seems to me, that your interfaces got the ipv6 addresses or not ?
Eg. For vmbr40 it is: 2601:c4:c501:8bf0::e8rc/64
vmbr40 - is port 0 (on the 4-port card). The HOST (how I access the VE webpage is using the on-board NIC -- vmbr0) I name the ports on the 4-port add-on card 40, 41, 41 and 42.
 
vmbr40 - is port 0 (on the 4-port card). The HOST (how I access the VE webpage is using the on-board NIC -- vmbr0) I name the ports on the 4-port add-on card 40, 41, 41 and 42.
Ah there seems to be a typo:
Change from
inet vmbr0 inet6 dhcp
to
iface vmbr0 inet6 dhcp
 
you're welcome :)
 
Do I have to make a change here to enable IPv6?

/etc/sysctl.conf
No this should not be the case and also i can't see some other mistakes.
Have you double checked your MAC-address settings ?
 
No this should not be the case and also i can't see some other mistakes.
Have you double checked your MAC-address settings ?
yes... MAC address is good. It appears that DEBIAN (which is driving the 'host' port the one which allows me to web in - does not like DHCPv6 with a STATIC IPv4.

I am going to leave it alone for now, albeit I wish I could get it working.
 
Hello,

You can see the IPs of a VM from the Summary tab if you enable the "QEMU Guest Agent" in the VM's Options and if you install the `qemu-guest-agent` inside of the guest. Is this what you wanted?
 
So configuring vmbr0 with DHCPv6 and without a static IPv4 ist working properly ?
I am not sure what you are asking.

I have a DHCP reservation on my pfSense for the IPv4 for this NIC - and that works. I know this as during the installation, when I am prompted to enter IP Address for the network, it is pre-filled with the IP and GW address. I just choose NEXT on the install. When it completed installation and I got the screen - it had the https://10.9.28.240:8006 on the screen.

In order to make an IPv6 reservation, I have to have a DUID and I cannot find that anywhere in the SHELL of proxmox. Since it is not grabbing an IPv6 address in the first place - pfSense does not show it either.

Here is what I am seeing in proxmox with 'ip addr'

Linux pve01 6.2.16-19-pve #1 SMP PREEMPT_DYNAMIC PMX 6.2.16-19 (2023-10-24T12:07Z) x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Tue Nov 14 14:29:14 EST 2023 on pts/0
root@pve01:~# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host noprefixroute
valid_lft forever preferred_lft forever
2: ens4f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master vmbr40 state UP group default qlen 1000
link/ether 00:e0:c0:4f:48:7f brd ff:ff:ff:ff:ff:ff
altname enp2s0f0
3: ens4f1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master vmbr41 state DOWN group default qlen 1000
link/ether 00:e0:c0:4f:48:80 brd ff:ff:ff:ff:ff:ff
altname enp2s0f1
4: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master vmbr0 state UP group default qlen 1000
link/ether c8:d3:ff:b6:cb:29 brd ff:ff:ff:ff:ff:ff
altname enp0s31f6
5: ens4f2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 00:e0:c0:4f:48:81 brd ff:ff:ff:ff:ff:ff
altname enp2s0f2
6: ens4f3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 00:e0:c0:4f:48:82 brd ff:ff:ff:ff:ff:ff
altname enp2s0f3
8: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether c8:d3:ff:b6:cb:29 brd ff:ff:ff:ff:ff:ff
inet 10.9.28.240/24 scope global vmbr0
valid_lft forever preferred_lft forever
inet6 fe80::cad3:ffff:feb6:cb29/64 scope link
valid_lft forever preferred_lft forever
9: vmbr40: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 00:e0:c0:4f:48:7f brd ff:ff:ff:ff:ff:ff
inet6 2601:c4:c501:8bf0:2e0:c0ff:fe4f:487f/64 scope global dynamic mngtmpaddr
valid_lft 86073sec preferred_lft 14073sec
inet6 fe80::2e0:c0ff:fe4f:487f/64 scope link
valid_lft forever preferred_lft forever
10: vmbr41: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
link/ether 00:e0:c0:4f:48:80 brd ff:ff:ff:ff:ff:ff
12: vmbr0v999: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether a2:3b:ad:4d:90:05 brd ff:ff:ff:ff:ff:ff
13: eno1.999@eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master vmbr0v999 state UP group default qlen 1000
link/ether c8:d3:ff:b6:cb:29 brd ff:ff:ff:ff:ff:ff


I see that someplace there are VLANs created - but I cannot find them. I tried to do an install of OpenWRT and the script got all the way to the end, and did not look right - so I deleted the entire VM, but those '999' VLANS are still called/setup someplace. :oops:
 
Hello,

You can see the IPs of a VM from the Summary tab if you enable the "QEMU Guest Agent" in the VM's Options and if you install the `qemu-guest-agent` inside of the guest. Is this what you wanted?
Yes, I know this is how to see them. I currently have no VMs - I am trying to get the eno1 (the port used for the HOST access) to pull an IPv6 address.
 
I am not sure what you are asking.
if you get a ipv6 address assigned when you only configure ipv6 like:

auto vmbr0
iface vmbr0 inet6 dhcp
 
if you get a ipv6 address assigned when you only configure ipv6 like:

auto vmbr0
iface vmbr0 inet6 dhcp

I have added that in the past - and I still do not get an IPv6 Address on the Host Port - I just added it back, and rebooted. Here is what I am seeing now:

root@pve01:/etc/network# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host noprefixroute
valid_lft forever preferred_lft forever
2: ens4f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master vmbr40 state UP group default qlen 1000
link/ether 00:e0:c0:4f:48:7f brd ff:ff:ff:ff:ff:ff
altname enp2s0f0
3: ens4f1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master vmbr41 state DOWN group default qlen 1000
link/ether 00:e0:c0:4f:48:80 brd ff:ff:ff:ff:ff:ff
altname enp2s0f1
4: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master vmbr0 state UP group default qlen 1000
link/ether c8:d3:ff:b6:cb:29 brd ff:ff:ff:ff:ff:ff
altname enp0s31f6
5: ens4f2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 00:e0:c0:4f:48:81 brd ff:ff:ff:ff:ff:ff
altname enp2s0f2
6: ens4f3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 00:e0:c0:4f:48:82 brd ff:ff:ff:ff:ff:ff
altname enp2s0f3
12: vmbr0v999: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether a2:3b:ad:4d:90:05 brd ff:ff:ff:ff:ff:ff
13: eno1.999@eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master vmbr0v999 state UP group default qlen 1000

link/ether c8:d3:ff:b6:cb:29 brd ff:ff:ff:ff:ff:ff
15: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000

link/ether c8:d3:ff:b6:cb:29 brd ff:ff:ff:ff:ff:ff
inet 10.9.28.240/24 scope global vmbr0
valid_lft forever preferred_lft forever
inet6 fe80::cad3:ffff:feb6:cb29/64 scope link

valid_lft forever preferred_lft forever
16: vmbr40: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 00:e0:c0:4f:48:7f brd ff:ff:ff:ff:ff:ff
inet6 2601:c4:c501:8bf0:2e0:c0ff:fe4f:487f/64 scope global dynamic mngtmpaddr
valid_lft 86393sec preferred_lft 14393sec
inet6 fe80::2e0:c0ff:fe4f:487f/64 scope link
valid_lft forever preferred_lft forever
17: vmbr41: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
link/ether 00:e0:c0:4f:48:80 brd ff:ff:ff:ff:ff:ff


How do I get rid of the ones in GREEN?

Here is my /etc/network/interfaces file:

auto lo
iface lo inet loopback

iface eno1 inet manual

iface ens4f0 inet manual

iface ens4f1 inet manual

iface ens4f2 inet manual

iface ens4f3 inet manual

auto vmbr0
iface vmbr0 inet static
address 10.9.28.240/24
gateway 10.9.28.254
bridge-ports eno1
bridge-stp off
bridge-fd 0

iface vmbr0 inet6 dhcp

auto vmbr40
iface vmbr40 inet manual
bridge-ports ens4f0
bridge-stp off
bridge-fd 0
#OpenWRT WAN

auto vmbr41
iface vmbr41 inet manual
bridge-ports ens4f1
bridge-stp off
bridge-fd 0

#OpenWRT LAN
 
to remove the green stuff go into Datacenter-> Network -> vmbr0 -> tick "VLAN aware"

and also you can run ifreload -v -d -a 2>&1 to debug if there is an ipv6 address assignment for vmbr0
 
and also you can run ifreload -v -d -a 2>&1 to debug if there is an ipv6 address assignment for vmbr0

I ran this - and a whole bunch of stuff scrolled on the screen... nothing jumped out about vmbr0, but I then checked again 'ip addr' and there is still no IPv6 for vmbr0:

1700066798740.png
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!