No Network Adapter in fresh Windows Server after Upgrade to Proxmox 7

jj22072020

New Member
Apr 24, 2022
2
0
1
Hello, I switched to 6.0 unfortunately without success. The server does not recognize a network adapter

EDIT:
I just installed the English version and it now works without any problems.

i'll just leave it like that
 
Last edited:
Mar 30, 2020
108
12
23
42
Hy

Looks like the trick with q35 and v6.0 or 5.x does not work anymore with PVE 7.1.10

This is my current solution


Code:
System: Windows Server 2019 German
Machine: Default (i440fx) 6.1
Driver: VirtIO 0.1.217
Nic: virtIO

Disk Driver Virtio (2k19)
Disk SCSI
Installed by loading the driver via Windows Installation

After first Login
* Open Devicemanager
** Install Driver for "Ethernet-Controller"
***  Driver: D:\NetKVM\2k19
**** Installation hang with Code 56
** Kill Process "drvinst.exe"
** In Device Manager the Nic is now listet as "Unbekanntes Gerät"
** Install Driver for "Unbekanntes Gerät"
***  Driver: D:\NetKVM\2k19

Nic is now working




Question to Proxmox: Is the change "deault setting windows guest" from i440fx to q35 related to this bug?

Also interessting is that the RedHat Certificates from the driver is outdatet (26.1.2022) => I saw this in mmc -> certificate


kr
Roland
 

jonas.dongowski

New Member
May 13, 2022
1
0
1
I installed Windows Server 2019 Standard (German edition) on PVE 7.2-3 inside of a i440fx-6.2 virtual machine and got a nic working.

During the Windows Server setup procedure there was no nic present.

After setup I mounted the virtio-win drivers (version 0.1.215) and installed virtio-win-gt-x64.msi to make sure I got most of the drivers.
I then shut down the vm to add a virtio nic to it and booted it up again.
The nic was present in the device manager but faulty (yellow icon, you know the drill).
Here another reboot was required. Took a little while longer but don't worry, it'll be fine.
I selected the nic in the device manager and updated the driver by manually setting it to "[my iso mount point]\NetKVM\2k19\amd64".
Windows tried to tell me it was already using the best driver for this device so I selected it again and "uninstalled the device".
After scanning for new hardware (magnifier on monitor icon inside the device manager's navbar) the nic showed up again without any problems.
From that point on even after unmounting the drivers iso and multiple reboots, the nic keeps working.

I also tried that whole process using version 0.1.217 of the virtio-win drivers but it didn't work. Not even virtio-win-gt-x64.msi ran without problems.
 
Last edited:

dkbits

New Member
Jan 5, 2022
2
0
1
44
So nobody how solves this win 2019 or 2022. It's really annoying to install all in english and switch then to german with the language pack. So unnecessary this work. Why nobody can fix this?
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,511
1,760
164
South Tyrol/Italy
shop.proxmox.com
So nobody how solves this win 2019 or 2022
Windows is proprietary, nobody outside of Microsoft can look at the source for that reason, short of reverse engineering their binaries or hacking around, which may not even be legal and surely not a route we'll take.
Why nobody can fix this?
Ask microsoft why the messed up just by using a specific language..
 
Last edited:

KMJ

New Member
Jul 10, 2021
20
1
3
60
I run into the same: Windows 2016 RDS Server migrated from VMWare to Proxmox 7.2.5 / virtio-0.1.217. Tried nearly everything from this thread, incl. some other, reimported 120gb x-times, sitting for 8 hours without Nic now. Looks like i need to go back to VMWare with this one. Not good.........
 

KMJ

New Member
Jul 10, 2021
20
1
3
60
SOLVED:
- reimport disk
- ide hdu
- set to q35 6.0, no network card to see it comes up -> YES
- gerätemanager show absent devices -> delete old e1000
- uninstall vmware tools
- install virtio full 215
- shutdown
- add virtio network card
- boot and found network

pffffffffffffffffffffffffffffff
 
  • Like
Reactions: _gabriel

DasMoritz

Member
Jun 6, 2022
45
4
8
Hi,

yes, that works @reschm!
I've done the following steps:

1.) Install Windows 10
2.) Switch off the fresh installed VM
3.) Mount the virtio win 01.208.1 iso from the above called link
4.) Install the VirtIo drivers (I got an error the first time, I think because I've used the x86 Installer and not the x64 Installer)
5.) Restart, everything is fine.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!