[SOLVED] nfs mount error

Jan 31, 2019

I have setup a folder on my Synology NAS to backup my ProxMox server. Everything worked perfect until I had to change the location of my NAS.
I got a new IP Address and an error:

mount error: mount.nfs: access denied by server while mounting (500)

I changed the IP address at /etc/pve/storage.cfg

cat /etc/pve/storage.cfg
dir: local
path /var/lib/vz
content vztmpl,iso,backup

lvmthin: local-lvm
thinpool data
vgname pve
content images,rootdir

nfs: Backup
export /volume1/Ordination
path /mnt/pve/Backup
content backup
maxfiles 5

zfspool: ZFS-MCW-Pool
pool myPool/MCW
content rootdir,images
sparse 0

pveversion -v
proxmox-ve: 6.0-2 (running kernel: 5.0.21-1-pve)
pve-manager: 6.0-6 (running version: 6.0-6/c71f879f)
pve-kernel-5.0: 6.0-7
pve-kernel-helper: 6.0-7
pve-kernel-4.15: 5.4-8
pve-kernel-5.0.21-1-pve: 5.0.21-2
pve-kernel-4.15.18-20-pve: 4.15.18-46
pve-kernel-4.15.18-9-pve: 4.15.18-30
ceph-fuse: 12.2.12-pve1
corosync: 3.0.2-pve2
criu: 3.11-3
glusterfs-client: 5.5-3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.11-pve1
libpve-access-control: 6.0-2
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-4
libpve-guest-common-perl: 3.0-1
libpve-http-server-perl: 3.0-2
libpve-storage-perl: 6.0-7
libqb0: 1.0.5-1
lvm2: 2.03.02-pve3
lxc-pve: 3.1.0-64
lxcfs: 3.0.3-pve60
novnc-pve: 1.0.0-60
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.0-7
pve-cluster: 6.0-7
pve-container: 3.0-5
pve-docs: 6.0-4
pve-edk2-firmware: 2.20190614-1
pve-firewall: 4.0-7
pve-firmware: 3.0-2
pve-ha-manager: 3.0-2
pve-i18n: 2.0-2
pve-qemu-kvm: 4.0.0-5
pve-xtermjs: 3.13.2-1
qemu-server: 6.0-7
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.1-pve2

But the error still appears.

Obviously, I am doing something wrong. Is there another place where I have to change the ip address? Any help would be appreciated.

Where else you might need to specify an IP is at the NAS, as it may be restricting access to clients.

You have shell access to the NAS? Looks like Synology is running Linux. If so, show whats in /etc/exports on the NAS.

Run # pvesm nfsscan
Hi, thank you for your help! I am sorry for my late reply (I have no remote access).

root@proxmoxserver:~# pvesm nfsscan


I changed the entry in /etc/exports to:

pvesm nfsscan shows now

But still no success:
mount error: mount.nfs: access denied by server while mounting (500)

The IP to your PVE node is ?
I am assuming your last modification restricted the export to your NFS server only (may as well have been localhost) if it is
Try opening the export to your entire network to troubleshoot:


This is my working export:
The IP of the PVE node is
The IP of the NFS is

The former IP of the NFS was

I made the changes but the error is still the same:
mount error: mount.nfs: access denied by server while mounting (500)

This are the synology settings:

sorry guys, I found the problem. It was a really stupid mistake. The IP address was blocked by the nfs server
Thank you for your help!!
I'm having the same issue. Would you mind sharing, how you solved it? I already added the Proxmox IP in the Synology firewall rules. This doesn't help?!

Solved: I had a space within the folder name on the Synology. That caused the problem.
Last edited:
  • Like
Reactions: JBredal
The solution is go to the Synology, edit folder NFS you share, go to tab NFS permision and add all IP Proxmox Host Server.
The solution is go to the Synology, edit folder NFS you share, go to tab NFS permision and add all IP Proxmox Host Server.
bless you!!! wasted a good deal of time trying to figure out why I was getting the error smh lol
I am still having the issue...Proxmox will not mount it but Synology is setup with the IP of the PVE, privilege is r/w, squash is no mapping, and security is sys. I also have enable async and allow users to access mounted subfolders enabled.
Proxmox is doing a regular NFS mount as a Linux client. SSH into your Proxmox and try to mount your nfs server directly:
mkdir /tmp/test
mount nfs_ip:/path /tmp/test

If that doesn't work, then PVE wont be able to mount either. You can run a few commands to help you :
showmount -a [nfs_ip]
rpcinfo [nfs_ip]
/usr/sbin/rpcinfo -T tcp [nfs ip] nfs 3
/usr/sbin/rpcinfo -T tcp [nfs ip] nfs 4

If none (or some) of this not working, come back and provide actual data. Or, you can ask on synology forum for assistance with NFS mounting. They may be more aware of logs/messages that can assist.

good luck

Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!