Netplan dying on VM

GP123

New Member
Dec 20, 2021
2
0
1
32
I am running PVE v7.7-1 with a VM running ubuntu 18.04.4.

I encountered weird errors regarding my networking interface on the VM when I tried to restore from a snapshot. The networking configuration was working fine at the time of the snapshot, and before the restore. I am seeing weird errors in dmesg, and netplan decided to crap out immediately after I tried to restore from the backup. I am doing PCIE passthrough of the NIC card directly to the vm, never had an issues with it before.

So I have a question: I want to install NetworkManager to see if that will fix the weird networking issues, the issue is it's not installed already, and the VM has no internet access. Is there anyway I can mount a median with the .deb file on it and use that to install NM?

dmesg | grep -e ixgbe -e enp
[ 1.247113] ixgbe 0000:00:10.0 ens16: renamed from eth0 [ 8.398511] ixgbe 0000:00:10.0: registered PHC device on ens16 [ 166.209337] ixgbe 0000:00:10.0: removed PHC on ens16 [ 946.736109] ixgbe 0000:00:10.0: registered PHC device on ens16 [ 955.648170] ixgbe 0000:00:10.0: removed PHC on ens16

ip a
2: ens16: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_IP> mtu 1500 qdisc mq state DOWN group default qlen 1000 link/ether 02:42:d3:c5:60:3c brd ff:ff:ff:ff:ff:ff
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!