[SOLVED] Nach Update starten keine VM`s mehr. QEMU exited with code 1

sven-w

New Member
May 6, 2020
2
0
1
44
nearby Berlin
Hallo zusammen,

nach dem ich Proxmox via GUI mit einem Update versorgt habe starten nun keine VM`s mehr. In der GUI wird nur ein Fehler ausgeworfen "QEMU exited with code 1". Wenn ich eine VM per CLI starten möchte kommt folgender Output:

root@pve:~# qm start 111
Object "bridge" is unknown, try "bridge help".
failed to remove default vlan tags of tap111i0 - command '/sbin/bridge bridge vlan del dev tap111i0 vid 1-4094' failed: exit code 255

kvm: network script /var/lib/qemu-server/pve-bridge failed with status 65280
start failed: QEMU exited with code 1

Wenn ich nun die Network Config aus der entsprechenden VM entferne kann ich die VM auch starten. Füge ich sie wieder hinzu kommt die gleiche Fehlermeldung.

Hat jemand ggf. eine Idee woran das liegen kann?

root@pve:~# pveversion -v
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
proxmox-ve: 6.1-2 (running kernel: 5.3.18-3-pve)
pve-manager: 6.1-11 (running version: 6.1-11/f2f18736)
pve-kernel-helper: 6.1-9
pve-kernel-5.3: 6.1-6
pve-kernel-5.0: 6.0-11
pve-kernel-5.3.18-3-pve: 5.3.18-3
pve-kernel-5.3.18-2-pve: 5.3.18-2
pve-kernel-5.0.21-5-pve: 5.0.21-10
pve-kernel-5.0.15-1-pve: 5.0.15-1
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.3-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: residual config
ifupdown2: 2.0.1-1+pve8
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.15-pve1
libproxmox-acme-perl: 1.0.2
libpve-access-control: 6.0-7
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.0-20
libpve-guest-common-perl: 3.0-10
libpve-http-server-perl: 3.0-5
libpve-storage-perl: 6.1-7
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.2-1
lxcfs: 4.0.3-pve2
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.1-6
pve-cluster: 6.1-8
pve-container: 3.1-4
pve-docs: 6.1-6
pve-edk2-firmware: 2.20200229-1
pve-firewall: 4.1-1
pve-firmware: 3.0-7
pve-ha-manager: 3.0-9
pve-i18n: 2.1-1
pve-qemu-kvm: 4.1.1-4
pve-xtermjs: 4.3.0-1
qemu-server: 6.1-19
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.3-pve1
root@pve:~#
 

loomes

Member
May 22, 2018
74
15
13
40
Ich habe auch Probleme nachdem ich heute morgen geupdatet habe:
Code:
Use of uninitialized value $data in split at /usr/share/perl5/PVE/JSONSchema.pm line 751.
no efidisk configured! Using temporary efivars disk.
kvm: -device hda-micro,id=audiodev0-codec0,bus=audiodev0.0,cad=0,audiodev=spice-backend0: Property '.audiodev' not found
TASK ERROR: start failed: QEMU exited with code 1

Entferne ich das Audio Device von den Maschinen starten sie wieder.
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
4,652
735
133
Hallo zusammen,

nach dem ich Proxmox via GUI mit einem Update versorgt habe starten nun keine VM`s mehr. In der GUI wird nur ein Fehler ausgeworfen "QEMU exited with code 1". Wenn ich eine VM per CLI starten möchte kommt folgender Output:

root@pve:~# qm start 111
Object "bridge" is unknown, try "bridge help".
failed to remove default vlan tags of tap111i0 - command '/sbin/bridge bridge vlan del dev tap111i0 vid 1-4094' failed: exit code 255

kvm: network script /var/lib/qemu-server/pve-bridge failed with status 65280
start failed: QEMU exited with code 1

Wenn ich nun die Network Config aus der entsprechenden VM entferne kann ich die VM auch starten. Füge ich sie wieder hinzu kommt die gleiche Fehlermeldung.

Hat jemand ggf. eine Idee woran das liegen kann?

root@pve:~# pveversion -v
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
proxmox-ve: 6.1-2 (running kernel: 5.3.18-3-pve)
pve-manager: 6.1-11 (running version: 6.1-11/f2f18736)
pve-kernel-helper: 6.1-9
pve-kernel-5.3: 6.1-6
pve-kernel-5.0: 6.0-11
pve-kernel-5.3.18-3-pve: 5.3.18-3
pve-kernel-5.3.18-2-pve: 5.3.18-2
pve-kernel-5.0.21-5-pve: 5.0.21-10
pve-kernel-5.0.15-1-pve: 5.0.15-1
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.3-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: residual config
ifupdown2: 2.0.1-1+pve8
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.15-pve1
libproxmox-acme-perl: 1.0.2
libpve-access-control: 6.0-7
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.0-20
libpve-guest-common-perl: 3.0-10
libpve-http-server-perl: 3.0-5
libpve-storage-perl: 6.1-7
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.2-1
lxcfs: 4.0.3-pve2
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.1-6
pve-cluster: 6.1-8
pve-container: 3.1-4
pve-docs: 6.1-6
pve-edk2-firmware: 2.20200229-1
pve-firewall: 4.1-1
pve-firmware: 3.0-7
pve-ha-manager: 3.0-9
pve-i18n: 2.1-1
pve-qemu-kvm: 4.1.1-4
pve-xtermjs: 4.3.0-1
qemu-server: 6.1-19
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.3-pve1
root@pve:~#

wird in kürze mit libpve-common-perl 6.0-21 behoben sein
 

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
1,249
140
63
@loomes
Bitte einen neuen Thread aufmachen damit wir hier nicht parallel zwei Dinge diskutieren. Kannst du bitte auch gleich den output von pveversion -v dann dazu geben?
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
4,652
735
133
Ich habe auch Probleme nachdem ich heute morgen geupdatet habe:
Code:
Use of uninitialized value $data in split at /usr/share/perl5/PVE/JSONSchema.pm line 751.
no efidisk configured! Using temporary efivars disk.
kvm: -device hda-micro,id=audiodev0-codec0,bus=audiodev0.0,cad=0,audiodev=spice-backend0: Property '.audiodev' not found
TASK ERROR: start failed: QEMU exited with code 1

Entferne ich das Audio Device von den Maschinen starten sie wieder.

das scheint ein anderes problem zu sein -> bitte bugzilla.proxmox.com oder ein neuer thread!
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
4,652
735
133
wird in kürze mit libpve-common-perl 6.0-21 behoben sein

libpve-common-perl 6.1-1 ist auf pve-no-subscription verfügbar und behebt das problem!
 
  • Like
Reactions: sven-w

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!