Nach Klick auf [>_ Upgrade] bootet Proxmox nicht mehr

matt69

Member
Nov 12, 2023
65
11
8
Hallo,

ich habe in der Web-GUI unter
pve > Updates
den Button [Aktualisieren] angeklickt.
Danach den Button [>_ Upgrade].

In der Shell kam am Ende der Hinweis, dass Aufgrund eines Kernel-Updates ein Reboot notwendig ist.
Den habe ich in der Web-GUI ausgeführt.

Jetzt bootet Proxmox nicht mehr.
Es hängt bei der Meldung:
"Loading Linux 6.5.11-4-pve ..."

Wie kann man das Problem reparieren?

Den Thread habe ich gelesen.
https://forum.proxmox.com/threads/s...update-auf-neuesten-kernel-nicht-mehr.136977/
Hilft mir aber leider nicht weiter.

VG
matt69
 
da Proxmox selbst kein vernünftiges Backup von PVEs hat, setzen viele veeam ein - ist leider so und wird mit SDNs, Benachrichtigungssystem etc. noch schlimmer
Proxmox sollte den Aktualisierungsprozess auf das Vorhandensein von veeam prüfen und ggf. abbrechen bzw. verständlich auf eine Deinstallation hinweisen
 
Hallo,

ich habe in der Web-GUI unter
pve > Updates
den Button [Aktualisieren] angeklickt.
Danach den Button [>_ Upgrade].

In der Shell kam am Ende der Hinweis, dass Aufgrund eines Kernel-Updates ein Reboot notwendig ist.
Den habe ich in der Web-GUI ausgeführt.

Jetzt bootet Proxmox nicht mehr.
Es hängt bei der Meldung:
"Loading Linux 6.5.11-4-pve ..."

Wie kann man das Problem reparieren?

Den Thread habe ich gelesen.
https://forum.proxmox.com/threads/s...update-auf-neuesten-kernel-nicht-mehr.136977/
Hilft mir aber leider nicht weiter.

VG
matt69

Hast du meine Schritte probiert bzw Veeam im Einsatz?

Was du machen kannst ist beim Hochfahren auf Advanced Options gehen und dort den vorhergehenden Kernel auswählen. Mit dem ging damals bei mir das Hochfahren. Den Kernel kannst du dann pinnen damit der Host immer damit hochfährt, solange bis Veeam den Client updated. Dann kannst du den gepinnten Kernel wieder rausgeben.
 
  • Like
Reactions: matt69
Danke für die Info.
Aber ich nutze Veeam gar nicht.

Es läuft nur Proxmox mit LXC-Container.
 
Was du machen kannst ist beim Hochfahren auf Advanced Options gehen und dort den vorhergehenden Kernel auswählen.
Ich habe in Advanced Options 6.5.11-4-pve ausgewählt.
Proxmox bootet wieder.

Merkt sich Proxmox die letzte Kernel-Auswahl?

Wie bekomme ich den neuen Kernel bootfähig?
 
  • Like
Reactions: harry1983
Ich habe in Advanced Options 6.5.11-4-pve ausgewählt.
Proxmox bootet wieder.

Merkt sich Proxmox die letzte Kernel-Auswahl?

Wie bekomme ich den neuen Kernel bootfähig?

Du kannst den jetztigen Kernel pinnen in den Grub Einstellungen

In deinem Fall proxmox-boot-tool kernel pin "kernelname zb 5.15.35-2-pve"

Für den neuen Kernel müsstest jetzt auf Fehlersuche gehen warum er bei dir nicht geht.
 
  • Like
Reactions: matt69
Mir fällt ein, dass ich den Realtek Netzwerk-Treiber r8169 durch r8168 ersetzt habe.
Muss ich das rückgänig machen?

Hier meine Doku dazu:
Code:
# Treiber prüfen
lspci -v
lspci -k

# Kernel Module für Netzwerk-Treiber "r8168" installieren
#
# Adjust sources
nano /etc/apt/sources.list
#
# Datei-Inhalt:
#----------
# englisch
#deb http://ftp.debian.org/debian bookworm main contrib non-free non-free-firmware
#deb http://ftp.debian.org/debian bookworm-updates main contrib non-free non-free-firmware

# deutsch
deb http://ftp.de.debian.org/debian bookworm main contrib non-free non-free-firmware
deb http://ftp.de.debian.org/debian bookworm-updates main contrib non-free non-free-firmware
#----------

# Update (gucken ob es Fehler bei den Listen gibt, die Enterprise Listen sind egal)
apt update

# PVE-Headers installieren (gucken ob es Fehler gibt)
apt install pve-headers

# Netzwerk-Treiber r8168 installieren
apt install -y r8168-dkms

# Sicherstellen, dass der Netzwerk-Treiber r8168 beim Booten geladen wird
cat /etc/modules
echo "# Netzwerk-Treiber r8168 beim Booten laden" | sudo tee -a /etc/modules
echo "r8168" | sudo tee -a /etc/modules

# Netzwerk-Treiber r8169 auf Blacklist setzen
echo "# Netzwerk-Treiber r8169 auf Blacklist setzen" | sudo tee -a /etc/modprobe.d/blacklist.conf
echo "blacklist r8169" | sudo tee -a /etc/modprobe.d/blacklist.conf
cat /etc/modprobe.d/blacklist.conf

# Neustart Proxmox

# Treiber prüfen
# Es muss jetzt Netzwerk-Treiber "r8168" verwendet werden
lspci -v
lspci -k
 
Mir fällt ein, dass ich den Realtek Netzwerk-Treiber r8169 durch r8168 ersetzt habe.
Muss ich das rückgänig machen?

Hier meine Doku dazu:
Code:
# Treiber prüfen
lspci -v
lspci -k

# Kernel Module für Netzwerk-Treiber "r8168" installieren
#
# Adjust sources
nano /etc/apt/sources.list
#
# Datei-Inhalt:
#----------
# englisch
#deb http://ftp.debian.org/debian bookworm main contrib non-free non-free-firmware
#deb http://ftp.debian.org/debian bookworm-updates main contrib non-free non-free-firmware

# deutsch
deb http://ftp.de.debian.org/debian bookworm main contrib non-free non-free-firmware
deb http://ftp.de.debian.org/debian bookworm-updates main contrib non-free non-free-firmware
#----------

# Update (gucken ob es Fehler bei den Listen gibt, die Enterprise Listen sind egal)
apt update

# PVE-Headers installieren (gucken ob es Fehler gibt)
apt install pve-headers

# Netzwerk-Treiber r8168 installieren
apt install -y r8168-dkms

# Sicherstellen, dass der Netzwerk-Treiber r8168 beim Booten geladen wird
cat /etc/modules
echo "# Netzwerk-Treiber r8168 beim Booten laden" | sudo tee -a /etc/modules
echo "r8168" | sudo tee -a /etc/modules

# Netzwerk-Treiber r8169 auf Blacklist setzen
echo "# Netzwerk-Treiber r8169 auf Blacklist setzen" | sudo tee -a /etc/modprobe.d/blacklist.conf
echo "blacklist r8169" | sudo tee -a /etc/modprobe.d/blacklist.conf
cat /etc/modprobe.d/blacklist.conf

# Neustart Proxmox

# Treiber prüfen
# Es muss jetzt Netzwerk-Treiber "r8168" verwendet werden
lspci -v
lspci -k

ja probier es mal
 
Ich habe versucht, den alten Netzwerk-Treiber r8168 wieder durch den neuen r8169 zu tauschen.
Leider klappt das nicht.
Es ist immer noch der alte r8168 aktiv.

Code:
$ lspci -k
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
        Subsystem: Dell RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
        Kernel driver in use: r8168
        Kernel modules: r8168

Wie kann ich den neuen r8169 aktivieren?

Folgendes habe ich gemacht:
Code:
# Rückgängig machen - Netzwerk-Treiber "r8168"

# Blacklist löschen
cat /etc/modprobe.d/blacklist.conf
rm /etc/modprobe.d/blacklist.conf
ls -lh /etc/modprobe.d

# Eintrag für Netzwerk-Treiber r8168 aus Datei löschen
nano /etc/modules
#
# Zeilen aus Datei löschen:
#----------
echo "# Netzwerk-Treiber r8168 beim Booten laden" | sudo tee -a /etc/modules
echo "r8168" | sudo tee -a /etc/modules
#----------

# Quellen wieder auf Standard setzen
nano /etc/apt/sources.list
#
# Zeilen aus Datei löschen:
#----------
# Für Netzwerk-Treiber "r8168"
# englisch
#deb http://ftp.debian.org/debian bookworm main contrib non-free non-free-firmware
#deb http://ftp.debian.org/debian bookworm-updates main contrib non-free non-free-firmware
#
# Für Netzwerk-Treiber "r8168"
# deutsch
deb http://ftp.de.debian.org/debian bookworm main contrib non-free non-free-firmware
deb http://ftp.de.debian.org/debian bookworm-updates main contrib non-free non-free-firmware
#----------
#
# Original nach Installation wieder auskommentieren:
#----------
# Original nach Installation
deb http://ftp.de.debian.org/debian bookworm main contrib
deb http://ftp.de.debian.org/debian bookworm-updates main contrib
#----------

# Netzwerk-Treiber r8168 löschen
apt remove -y r8168-dkms

# Neustart Proxmox

P.S. Werde mich vermutlich erst morgen wieder melden können.
 
Proxmox läuft jetzt wieder mit Kernel 6.5.11-4-pve und Netzwerktreiber r8169. :)
Code:
$ lspci -k
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
        Subsystem: Dell RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
        Kernel driver in use: r8169
        Kernel modules: r8169

Tausend Dank an @rkollman
Hier steht die Lösung:
https://forum.proxmox.com/threads/a...-5-11-4-pve-does-not-boot.137071/#post-609594

Es wurde automatisch eine 2. Blacklist erstellt.
Darin wird der Treiber r8169 blockiert.
Das habe ich nicht gesehen.
Ich hatte nach Anleitung eine eigene Blacklist erstellt und hatte somit zwei Blacklists für den Treiber r8169.
Code:
cat /etc/modprobe.d/r8168-dkms.conf
#
nano /etc/modprobe.d/r8168-dkms.conf
#
# Alle Zeilen kommentieren:
#----------
# settings for r8168-dkms

# map the specific PCI IDs instead of blacklisting the whole r8169 module
#alias  pci:v00001186d00004300sv00001186sd00004B10bc*sc*i*      r8168
#alias  pci:v000010ECd00008168sv*sd*bc*sc*i*                    r8168

# if the aliases above do not work, uncomment the following line
# to blacklist the whole r8169 module
#blacklist r8169
#----------


Hier nochmal als Zusammenfassung, was ich alles gemacht habe, damit Proxmox mit Kernel 6.5.11-4-pve und Netzwerktreiber r8169 bootet.
Code:
# *** Realtek Netzwerk-Treiber "r8168" rückgängig machen, wieder "r8169" aktivieren ***

# https://forum.proxmox.com/threads/after-upgrading-kernel-6-5-11-4-pve-does-not-boot.137071/#post-609435
# https://forum.proxmox.com/threads/after-upgrading-kernel-6-5-11-4-pve-does-not-boot.137071/#post-609594

# Kernel 6.2.16-19-pve pinnen
proxmox-boot-tool kernel pin 6.2.16-19-pve
# Proxmox bootet ab jetzt mit dem gepinnten, alten Kernel

# Blacklist löschen
cat /etc/modprobe.d/blacklist.conf
rm /etc/modprobe.d/blacklist.conf
ls -lh /etc/modprobe.d

# Eintrag für Netzwerk-Treiber r8168 aus Datei löschen
nano /etc/modules
#
# Zeilen aus Datei löschen:
#----------
# Netzwerk-Treiber r8168 beim Booten laden
r8168
#----------

# Quellen wieder auf Standard setzen
nano /etc/apt/sources.list
#
# Zeilen aus Datei löschen:
#----------
# Für Netzwerk-Treiber "r8168"
# englisch
#deb http://ftp.debian.org/debian bookworm main contrib non-free non-free-firmware
#deb http://ftp.debian.org/debian bookworm-updates main contrib non-free non-free-firmware
#
# Für Netzwerk-Treiber "r8168"
# deutsch
deb http://ftp.de.debian.org/debian bookworm main contrib non-free non-free-firmware
deb http://ftp.de.debian.org/debian bookworm-updates main contrib non-free non-free-firmware
#----------
#
# Original nach Installation wieder auskommentieren:
#----------
# Original nach Installation
deb http://ftp.de.debian.org/debian bookworm main contrib
deb http://ftp.de.debian.org/debian bookworm-updates main contrib
#----------

# 2. Blacklist auskommentieren oder löschen
# Es wurde automatisch eine 2. Blacklist erstellt
cat /etc/modprobe.d/r8168-dkms.conf
#
nano /etc/modprobe.d/r8168-dkms.conf
#
# Alle Zeilen kommentieren:
#----------
# settings for r8168-dkms

# map the specific PCI IDs instead of blacklisting the whole r8169 module
#alias  pci:v00001186d00004300sv00001186sd00004B10bc*sc*i*      r8168
#alias  pci:v000010ECd00008168sv*sd*bc*sc*i*                    r8168

# if the aliases above do not work, uncomment the following line
# to blacklist the whole r8169 module
#blacklist r8169
#----------
#
# Oder Blacklist löschen
cat /etc/modprobe.d/r8168-dkms.conf
rm /etc/modprobe.d/r8168-dkms.conf
ls -lh /etc/modprobe.d

# Fehlendes Package installieren
cat /var/log/apt/term.log | grep grub-efi-amd64
cat /var/log/apt/term.log | grep "not installed"
apt install grub-efi-amd64

# Netzwerk-Treiber r8168 löschen
apt remove -y r8168-dkms

# Kernel 6.2.16-19-pve unpinnen
proxmox-boot-tool kernel unpin

# Neustart Proxmox

# Treiber prüfen
# Es muss jetzt Netzwerk-Treiber "r8169" verwendet werden
lspci -k
lspci -v
 
Last edited:
Hallo, ich glaube ich stehe vor einem ähnlichen Problem (https://forum.proxmox.com/threads/proxmox-8-1-installation-issues.140378/) und komme irgendwie gar nicht mehr voran. Unterschied zu den Beiträgen oben, ich habe kein Upgrade gemacht sondern direkt 8.1 installiert. Entsprechend kann ich nicht zum alten Kernel retour und der Recovery Mode den man am Anfang in Grub auswählen kann, bleibt genauso "stecken".
Wie kann ich das mit den oben beschriebenen Treibern in meinem Fall ausführen?
 
Hallo, ich glaube ich stehe vor einem ähnlichen Problem (https://forum.proxmox.com/threads/proxmox-8-1-installation-issues.140378/) und komme irgendwie gar nicht mehr voran. Unterschied zu den Beiträgen oben, ich habe kein Upgrade gemacht sondern direkt 8.1 installiert. Entsprechend kann ich nicht zum alten Kernel retour und der Recovery Mode den man am Anfang in Grub auswählen kann, bleibt genauso "stecken".
Wie kann ich das mit den oben beschriebenen Treibern in meinem Fall ausführen?
Was für eine Hardware verwendest du ? Kannst du die mal auflisten?
 
Hallo, ich versuch Proxmox auf einem Lenovo ST50 v2 server mit Xeon E-2324G Prozessor, 16 GB RAM auf einer SSD zu installieren
 
Hallo, ich versuch Proxmox auf einem Lenovo ST50 v2 server mit Xeon E-2324G Prozessor, 16 GB RAM auf einer SSD zu installieren

Welche SSD und auf welche Anschluss hängt diese? Welches Dateisystem hast du ausgewählt für die OS Partition? Welche Komponenten / Disken sind noch im System?
 
Es sind die zwei Original SSDs von Lenovo Think System 960GB SSD SATA (Model: MTFDDAK960TGA-1BC16ABLA (scheint eigentlich von Micron zu sein, ist aber mit Lenovo gelabelt)) verbaut. Die hängen an einem SATA Anschluss (SATA1 und SATA3) so wie original beim Lenovo ST50. Hab an dem System nichts verändert.
Installiert habe ich Proxmox auf die sda Festplatte mit ext4 Dateisystem (Standardeinstellung die das Proxmox Setup vorgeschlagen hat).
Ev. wichtig zu erwähnen. Die Installation hat nur mit dem "Netzwerkkabelreset" den ich hier beschrieben habe https://forum.proxmox.com/threads/proxmox-8-1-installation-issues.140378/ funktioniert. Nach dem "Netzwerkkabelreset sieht man einige Promt ausgaben, da ist aber nichts auffälliges dabei.
 
Ich habe schon einige schlechte Micron Serien in Clients gesehen. Für höhere Last mit mehreren VMs sind die nicht geeignet.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!