Hello, I have been struggling for a while to getting this configuration to work, Searched forums and compared multiple times with existing configs without luck
2 x Cisco switches with an ether-channel trunk for HSRP
Proxmox hosts connected to port 5 on each switch eth0 to sw1 and eth1 to sw2 respectively
VLAN:2 (management)
VLAN 3
VLAN 4
VLAN 5
My goal:
1- Must-Have redundancy in case of switch failure for VLANs 2,3,4
2- CSR1000 need to be only on one interface eth1 with access to the 3 VLANs 2,3,5
Here are my current configurations:
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet manual
auto eth1
iface eth1 inet manual
auto eth1.2
iface eth1.2 inet manual
auto eth1.3
iface eth1.3 inet manual
auto eth1.5
iface eth1.5 inet manual
auto bond0
iface bond0 inet manual
bond-slaves eth0 eth1
bond-miimon 100
bond-mode active-backup
bond_downdelay 200
bond_updelay 200
iface bond0.2 inet manual
iface bond0.3 inet manual
iface bond0.4 inet manual
auto vmbr1
iface vmbr1 inet static
address 192.168.100.7/24
gateway 192.168.100.3
bridge-ports bond0.2
bridge-stp off
bridge-fd 0
auto vmbr0
iface vmbr0 inet manual
bridge-ports bond0.3
bridge-stp off
bridge-fd 0
auto vmbr2
iface vmbr2 inet manual
bridge-ports bond0.4
bridge-stp off
bridge-fd 0
#CSR bridges
auto vmbr4
iface vmbr4 inet manual
bridge-ports eth1.2
bridge-stp off
bridge-fd 0
auto vmbr5
iface vmbr5 inet manual
bridge-ports eth1.5
bridge-stp off
bridge-fd 0
auto vmbr6
iface vmbr6 inet manual
bridge-ports eth1.3
bridge-stp off
bridge-fd 0
SW1 and SW2 port configurations
interface GigabitEthernet1/0/5
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,4,5,6
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
==================================
When I restart networking on PX i get this error on the console :
bond0: option mode : unable to set cause the bond device is up
1340.215262 bond0: (slave eth1): Invalid new link 3 on slave
==================================
This setup is accepted however CSR is not getting traffic passed properly - is the proper recommended setup? Any advice would be appreciated.
Thanks
2 x Cisco switches with an ether-channel trunk for HSRP
Proxmox hosts connected to port 5 on each switch eth0 to sw1 and eth1 to sw2 respectively
VLAN:2 (management)
VLAN 3
VLAN 4
VLAN 5
My goal:
1- Must-Have redundancy in case of switch failure for VLANs 2,3,4
2- CSR1000 need to be only on one interface eth1 with access to the 3 VLANs 2,3,5
Here are my current configurations:
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet manual
auto eth1
iface eth1 inet manual
auto eth1.2
iface eth1.2 inet manual
auto eth1.3
iface eth1.3 inet manual
auto eth1.5
iface eth1.5 inet manual
auto bond0
iface bond0 inet manual
bond-slaves eth0 eth1
bond-miimon 100
bond-mode active-backup
bond_downdelay 200
bond_updelay 200
iface bond0.2 inet manual
iface bond0.3 inet manual
iface bond0.4 inet manual
auto vmbr1
iface vmbr1 inet static
address 192.168.100.7/24
gateway 192.168.100.3
bridge-ports bond0.2
bridge-stp off
bridge-fd 0
auto vmbr0
iface vmbr0 inet manual
bridge-ports bond0.3
bridge-stp off
bridge-fd 0
auto vmbr2
iface vmbr2 inet manual
bridge-ports bond0.4
bridge-stp off
bridge-fd 0
#CSR bridges
auto vmbr4
iface vmbr4 inet manual
bridge-ports eth1.2
bridge-stp off
bridge-fd 0
auto vmbr5
iface vmbr5 inet manual
bridge-ports eth1.5
bridge-stp off
bridge-fd 0
auto vmbr6
iface vmbr6 inet manual
bridge-ports eth1.3
bridge-stp off
bridge-fd 0
SW1 and SW2 port configurations
interface GigabitEthernet1/0/5
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,4,5,6
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
==================================
When I restart networking on PX i get this error on the console :
bond0: option mode : unable to set cause the bond device is up
1340.215262 bond0: (slave eth1): Invalid new link 3 on slave
==================================
This setup is accepted however CSR is not getting traffic passed properly - is the proper recommended setup? Any advice would be appreciated.
Thanks
Last edited: