[SOLVED] mounting 'drive-scsiXX.img.fidx/part/1' failed: all mounts failed or no supported file system (400)

MisterDeeds

Active Member
Nov 11, 2021
128
25
33
34
Dear all

I have a PVE system in use together with a Proxmox backup server. Now when I want to perform the "file restore" from the PVE, the following message appears:

Code:
mounting 'drive-scsiXX.img.fidx/part/1' failed: all mounts failed or no supported file system (400)

I use a normal GPT partition. However, I am not sure if it is because of the 128MB Reserved partition:

1690263835849.png

Does anyone know the problem? Thank you and best regards
 
I have now changed the partition to have only one and run a new backup. Unfortunately, the same message still appears. Can anyone help me?
1690345710001.png
 
Dear all

In consultation with Proxmox support, it turns out that the restore via web gui mounts the disk into a temporary virtual machine with the "ntfs-3g" command. This shows in the logfile of the PVE host under:
Code:
/var/log/proxmox-backup/file-restore/
an error.

There it was apparent that the file system had an error. Windows seems to have no problem with it, but the ntfs-3g command does.
A simple

Code:
CHKDSK D: /F /R /X

fixed the problem.

Thanks again to the great proxmox support!

Best regards
 
Hello, i have the same problem with an NTFS disk backup.
If I try to do a "file restore" from GUI, i get the message:

mounting 'drive-scsiXX.img.fidx/part/1' failed: all mounts failed or no supported file system (400)

The file-restore log (/var/log/proxmox-backup/file-restore/qemu.log) show this information about ntfs:

ntfs: (device vda1): read_ntfs_boot_sector(): Primary boot sector is invalid. ntfs: (device vda1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover. ntfs: (device vda1): ntfs_fill_super(): Not an NTFS volume.

If i map the backup with "proxmox-backup-client map" and then mount the mapping i can access all the files without problem. Seems like "file-restore" and "map" works different. Is there a way to configure "file-restore" so i can force the mount an NTFS dirty-flagged partition?

Thanx in advance
 
how are you mounting the mapped snapshot? please give the exact command line/options used!
 
how are you mounting the mapped snapshot? please give the exact command line/options used!

Using this commands:

proxmox-backup-client map vm/101/2024-01-10T07:15:12Z drive-virtio1.img --repository root@pam@192.168.1.2:8007:bk1 --ns jls ls -lah /dev/loop0* mkdir /mnt/test mount -r /dev/loop0p1 /mnt/test ls /mnt/test/
 
what does "mount" say about the /mnt/test mountpoint afterwards?
 
what does "mount" say about the /mnt/test mountpoint afterwards?

/dev/loop0p1 on /mnt/test type fuseblk (ro,relatime,user_id=0,group_id=0,allow_other,blksize=4096)

Mounts ok using that commands, I can acces all the files.
The problem is when I try to do a "file restore" from GUI
 
yeah, that seems to use a very different driver (ntfs-3g?) than the file-restore VM (which uses the in-tree kernel "ntfs" one)..
 
no, that's hard-coded at the moment..
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!