MG 6.0 relay domain not working.

akong

Well-Known Member
Oct 15, 2018
87
1
48
45
Hello,
I installed MG 6.0 and I set relay domain like attachment. But it's will show relay access denied. It's can work on MG 5 version.
And I edit relay domain and enable MX and click OK. It's always show "No". What's this problem?
 

Attachments

  • relay_domain.png
    relay_domain.png
    29.4 KB · Views: 35
  • relay_domain_edit.png
    relay_domain_edit.png
    21.2 KB · Views: 35
Hello, Is this a MG 6 bug?

No, a configuration issue on your side, I assume you have a wrong SMTP port setup.

Based on what you posted here, its unable to see the issue.
 
Sep 5 17:00:11 pmg postfix/smtpd[23723]: NOQUEUE: reject: RCPT from tw.linguitronics.com[220.130.148.52]: 554 5.7.1 <akong@eshtech.com.tw>: Relay access denied; from=<akong@linguitronics.com> to=<akong@eshtech.com.tw> proto=ESMTP helo=<pmg.linguitronics.com>
Sep 5 17:11:58 pmg postfix/smtpd[23825]: NOQUEUE: reject: RCPT from tw.linguitronics.com[220.130.148.52]: 554 5.7.1 <akong@eshtech.com.tw>: Relay access denied; from=<akong@linguitronics.com> to=<akong@eshtech.com.tw> proto=ESMTP helo=<pmg.linguitronics.com>
I use proxmox mail gateway to filter eshtech.com.tw incoming mail.
Transport:
domain: eshtech.com.tw
host: eshtech.com.tw ip address
MX: NO
Could any another question?
 
please post the redacted content of:
* '/etc/pmg/domains'
* '/etc/pmg/transport'
and the output of:
* `pmgconfig dump`
 
root@pmg:~# cat /etc/pmg/domains
aspa.idv.tw 1
root@pmg:~# cat /etc/pmg/transport
eshtech.com.tw smtp:[122.116.33.171]:25
mouse-team.com.tw smtp:[122.116.33.171]:25
pmgconfig dump
root@pmg:~# pmgconfig dump
could not change directory to "/root": Permission denied
composed.wl_bounce_relays = pmg.aspa.idv.tw
dns.domain = aspa.idv.tw
dns.hostname = pmg
ipconfig.int_ip = 192.168.2.230
pmg.admin.advfilter = 1
pmg.admin.avast = 0
pmg.admin.clamav = 1
pmg.admin.custom_check = 0
pmg.admin.custom_check_path = /usr/local/bin/pmg-custom-check
pmg.admin.dailyreport = 1
pmg.admin.demo = 0
pmg.admin.email = akong@aspa.idv.tw
pmg.admin.http_proxy =
pmg.admin.statlifetime = 7
pmg.clamav.archiveblockencrypted = 0
pmg.clamav.archivemaxfiles = 1000
pmg.clamav.archivemaxrec = 5
pmg.clamav.archivemaxsize = 25000000
pmg.clamav.dbmirror = database.clamav.net
pmg.clamav.maxcccount = 0
pmg.clamav.maxscansize = 100000000
pmg.clamav.safebrowsing = 1
pmg.mail.banner = ESMTP Proxmox
pmg.mail.conn_count_limit = 50
pmg.mail.conn_rate_limit = 0
pmg.mail.dnsbl_sites = zen.spamhaus.org
pmg.mail.dnsbl_threshold = 1
pmg.mail.dwarning = 4
pmg.mail.ext_port = 25
pmg.mail.greylist = 0
pmg.mail.helotests = 1
pmg.mail.hide_received = 0
pmg.mail.int_port = 26
pmg.mail.max_filters = 15
pmg.mail.max_policy = 5
pmg.mail.max_smtpd_in = 98
pmg.mail.max_smtpd_out = 98
pmg.mail.maxsize = 10485760
pmg.mail.message_rate_limit = 0
pmg.mail.rejectunknown = 0
pmg.mail.rejectunknownsender = 0
pmg.mail.relay = 192.168.2.240
pmg.mail.relaynomx = 1
pmg.mail.relayport = 25
pmg.mail.smarthost =
pmg.mail.smarthostport = 25
pmg.mail.spf = 1
pmg.mail.tls = 0
pmg.mail.tlsheader = 0
pmg.mail.tlslog = 0
pmg.mail.verifyreceivers = 550
pmg.spam.bounce_score = 0
pmg.spam.clamav_heuristic_score = 3
pmg.spam.languages = all
pmg.spam.maxspamsize = 262144
pmg.spam.rbl_checks = 1
pmg.spam.use_awl = 1
pmg.spam.use_bayes = 1
pmg.spam.use_razor = 1
pmg.spam.wl_bounce_relays =
pmg.spamquar.allowhrefs = 1
pmg.spamquar.authmode = ticket
pmg.spamquar.hostname =
pmg.spamquar.lifetime = 7
pmg.spamquar.mailfrom =
pmg.spamquar.port = 8006
pmg.spamquar.protocol = https
pmg.spamquar.reportstyle = none
pmg.spamquar.viewimages = 1
pmg.virusquar.allowhrefs = 1
pmg.virusquar.lifetime = 7
pmg.virusquar.viewimages = 1
postfix.dnsbl_sites = zen.spamhaus.org
postfix.dnsbl_threshold = 1
postfix.int_ip = 192.168.2.230
postfix.mynetworks = 127.0.0.0/8 [::1]/128 192.168.2.0/24 122.116.33.171/32 122.116.33.171/32 192.168.2.240/32
postfix.transportnets = 122.116.33.171/32 122.116.33.171/32
postfix.usepolicy = 1
postgres.version = 11
Please tell me if I miss another output. Thanks a lot.
 
as @chebedewel said in the first reply - you need to add all domains, for which you wish to relay mail to the 'Relay Domains' tab (under 'Configuration' -> 'Mail Proxy')

I hope this helps!
 
Hello,
It's solved it. But I don't know the same setting at version 5 is all ok. At version 6 can't use it.
 
This is odd, since nothing changed in that respect between version 5.2 and 6.0 - How did you perform the upgrade?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!