Looking for rootfs.tar.xz

Hello Oguz,
Thanks for doing this.

Well, I have tested dozens of roofs.tar and this one as well, but it still gives the same error message:

Formatting '/var/lib/vz/images/100/vm-100-disk-0.raw', fmt=raw size=4294967296 preallocation=off
Creating filesystem with 1048576 4k blocks and 262144 inodes
Filesystem UUID: 8a0be867-c145-4a6e-b667-4fad5ef7e10a
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736
extracting archive '/var/lib/vz/template/cache/rootfs.tar.xz'
Total bytes read: 343091200 (328MiB, 26MiB/s)
Detected container architecture: arm64
unable to open file '/etc/network/interfaces.tmp.142890' - No such file or directory
TASK ERROR: unable to create CT 100 - error in setup task PVE::LXC::Setup::post_create_hook

From my searches, this one works :
But cannot find it anywhere.

Best wishes,
can't tell you why this doesn't work, you should talk with the "pimox" developers (only the official PVE is supported here)
Hi there!

Same problem on my Proxmox VE 7.2-4 (with all updates installed for 20.05.2022).

For image https://uk.lxd.images.canonical.com...ye/amd64/default/20220520_05:25/rootfs.tar.xz



Formatting '/var/lib/vz/images/313/vm-313-disk-0.raw', fmt=raw size=10737418240 preallocation=off
Creating filesystem with 2621440 4k blocks and 655360 inodes
Filesystem UUID: 0f5e6eb0-ecd8-4e30-957a-ebf8dd66c92c
Superblock backups stored on blocks:
    32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632
extracting archive '/mnt/pve/Qnap/template/cache/Debian_bullseye_11.3_rootfs.tar.xz'
Total bytes read: 350996480 (335MiB, 51MiB/s)
Detected container architecture: amd64
unable to open file '/etc/network/interfaces.tmp.20033' - No such file or directory
TASK ERROR: unable to create CT 313 - error in setup task PVE::LXC::Setup::post_create_hook

With old one distro https://uk.lxd.images.canonical.com/images/debian/buster/amd64/default/20220520_05:25/rootfs.tar.xz Buster everything works fine.

So, I guess problem caused by some changes made by Debian bullseye network settings moved to /etc/systemd/network/eth0.network

UPD: This problem doesn't show on Proxmox or Pimox if you download a cloud branch of LXD.

Successfully tested with https://uk.lxd.images.canonical.com/images/debian/bookworm/arm64/cloud/20220520_05:25/rootfs.tar.xz with my Pimox on Raspberry Pi 4
Last edited:
I know it's an old thread, but it was never solved and I had the same issue. Found this page and wanted to help anyone else who finds it.

I've just figured out how to get the latest Cloud image of Debian 12 Bullseye working on PiMox 7:

When configuring the CT, leave IP = Static. Do not enter any IP addresses anywhere.

Boot the CT, enter the CTs console.

Install Nano
apt install nano

Edit the network configuration file
nano /etc/systemd/network/eth0.network


Restart Systemd Networkd
systemctl restart systemd-networkd

Check the static IP is set (you'll probably also see the DHCP IP is still there)
ip -c a

reboot now

You've now got the static IP set up
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!