Live migration does not work when SPICE console/client is open.

casparsmit

Active Member
Feb 24, 2015
38
1
28
I noticed in PVE 3.4 when i live migrate a VM it fails when there is a SPICE client (In my case Remote Viewer on Ubuntu) running for the VM.

Live migration works if the console is closed or when using the NoVNC console, only not with SPICE console open.

Here's the log including the error message:

Feb 27 16:55:56 starting migration of VM 103 to node 'pve-ceph-sn02' (192.168.0.13)
Feb 27 16:55:56 copying disk images
Feb 27 16:55:56 starting VM 103 on remote node 'pve-ceph-sn02'
Feb 27 16:55:57 starting ssh migration tunnel
Feb 27 16:55:58 starting online/live migration on localhost:60000
Feb 27 16:55:58 migrate_set_speed: 8589934592
Feb 27 16:55:58 migrate_set_downtime: 0.1
Feb 27 16:55:58 spice client_migrate_info
Feb 27 16:56:00 migration status: active (transferred 101428317, remaining 2358349824), total 4429852672)
Feb 27 16:56:02 migration status: active (transferred 209611197, remaining 2157207552), total 4429852672)
Feb 27 16:56:04 migration status: active (transferred 311697595, remaining 2015055872), total 4429852672)
Feb 27 16:56:06 migration status: active (transferred 413662539, remaining 1860911104), total 4429852672)
Feb 27 16:56:08 migration status: active (transferred 520977037, remaining 1716162560), total 4429852672)
Feb 27 16:56:10 migration status: active (transferred 623924528, remaining 159703040), total 4429852672)
Feb 27 16:56:12 migration status: active (transferred 729685545, remaining 126803968), total 4429852672)
Feb 27 16:56:14 migration status: active (transferred 837580363, remaining 17285120), total 4429852672)
Feb 27 16:56:14 migration status: active (transferred 856487611, remaining 52432896), total 4429852672)
Feb 27 16:56:15 migration status: active (transferred 872844316, remaining 33968128), total 4429852672)
Feb 27 16:56:15 migration status: active (transferred 891318061, remaining 16019456), total 4429852672)
Feb 27 16:56:15 migration status: active (transferred 906470294, remaining 10915840), total 4429852672)
Feb 27 16:56:16 migration speed: 227.56 MB/s - downtime 142 ms
Feb 27 16:56:16 migration status: completed
Feb 27 16:56:16 ERROR: VM 103 not running
Feb 27 16:56:16 ERROR: command '/usr/bin/ssh -o 'BatchMode=yes' root@192.168.0.13 qm resume 103 --skiplock' failed: exit code 2
Feb 27 16:56:16 Waiting for spice server migration
Feb 27 16:56:19 ERROR: migration finished with problems (duration 00:00:24)
TASK ERROR: migration problems
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,405
852
163
known issue with SPICE. as long as spice is configured, live migration is not working (most times).
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!