KVM: 2 network interface on same bridge = not supported ?

softlion

Active Member
Dec 10, 2009
63
0
26
Hi,
as soon as i add a new virtual network card to the same bridge, the vm (Win2K8) can't see the outside world / even the host. No improvement if this new card is disabled in the vm.

If i remove the virtual card all works correctly.
If i add a new virtual network card to another bridge it works ok.

Is this a known limitation ?
Is there a network option to activate on the host ?

Non working conf:
#brctl show
bridge name bridge id STP enabled interfaces
vmbr0 8000.002590115dc2 no eth0
tap220i0d0
tap220i0d1
tap225i0d0
vmbr10 8000.002590115dc2 no eth0.4000
tap200i10d0
tap205i10d0
tap220i10d0
tap225i10d0

vm 220 .conf:
# cat /etc/qemu-server/220.conf
name: back100
ide2: local:iso/nnn.iso,media=cdrom
bootdisk: virtio0
ostype: w2k8
memory: 2048
sockets: 1
virtio0: nas1:220/vm-220-disk-1.raw
boot: cad
freeze: 0
cpuunits: 1000
acpi: 1
kvm: 1
onboot: 1
cores: 1
vlan10: virtio=CC:CC:CC:CC:CC:08
vlan0: virtio=DD:00:00:DD:DD:DD,virtio=EE:EE:EE:EE:EE:EE
args: -no-hpet -no-kvm-pit-reinjection
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!