Kernel Ugrade

mhbosch

Member
Dec 22, 2020
23
0
6
50
Hello,

i have three Server with proxmox. With a new lxc i have the Problem, i cant start it on a Clusterpartner.
I read something here but have no soluton found.
But i found a difference in the Kernel.

The System who i can start the lxc have:
Code:
proxmox-ve: 6.3-1 (running kernel: 5.4.103-1-pve)
pve-manager: 6.3-6 (running version: 6.3-6/2184247e)

The other two, i cant start have:
Code:
proxmox-ve: 6.3-1 (running kernel: 5.4.73-1-pve)
pve-manager: 6.3-2 (running version: 6.3-2/22f57405)


and

proxmox-ve: 6.3-1 (running kernel: 5.4.73-1-pve)
pve-manager: 6.3-2 (running version: 6.3-2/22f57405)

Maybe it is a Kernelproblem?
Bit i dont find a way to update the Kernel.
apt-get dist-upgrade its no solution.

How can i upgrade the Kernel?
 
Hi,

without any information about why the container doesn't start this will be hard to debug. Please post the task log at least, alternatively run pct start <Container-ID> --debug and post the output here, ideally between [CODE][/CODE] tags.

Bit i dont find a way to update the Kernel.
apt-get dist-upgrade its no solution.
You may need to run apt-get update first and then apt-get dist-upgrade. If that doesn't work, please post the output of these commands here, ideally between [CODE][/CODE] tags.

Finally, please upgrade your Cluster. PVE 6 is not supported any longer. Upgrade to PVE 7 [1] and after that maybe all the way to PVE 8 [2].

[1]: https://pve.proxmox.com/wiki/Upgrade_from_6.x_to_7.0
[2]: https://pve.proxmox.com/wiki/Upgrade_from_7_to_8
 
Last edited:
Hello Stefan,

thanks for the reply. In this Thread i want to understand, to upgrade the Kernel.
I have twice the proxmox-ve: 6.3-1 (running kernel: 5.4.73-1-pve). The Runnig Kernel is 5.4.73-1-pve.
Once i have proxmox-ve: 6.3-1 (running kernel: 5.4.103-1-pve).

I dont understand, the differnce between 5.4.73 and 5.4.103.

With dist-upgrade there is no change to 5.4.103.

I will show from a system with 5.4.73:

Code:
apt-get update && apt-get -y upgrade && apt-get -y dist-upgrade && apt-get -y autoremove && apt-get -y autoclean
Get:1 http://security.debian.org buster/updates InRelease [34.8 kB]
Hit:2 http://ftp.de.debian.org/debian buster InRelease
Hit:3 http://ftp.de.debian.org/debian buster-updates InRelease
Get:4 http://security.debian.org buster/updates/main amd64 Packages [551 kB]
Fetched 586 kB in 1s (1,053 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done

A upgrade to V7 or 8 i will shift to a later time. Or can i make a system enviroment with different Version?
I don´t want to upgrade all three system at the same time,

My wish is first to set the version of running pve kernel to 5.4.103.

When you wish to held to debug the start, here my log.

lxc-start -n 452 -F -lDEBUG -o lxc-452.log
Code:
lxc-start 452 20230913122240.841 ERROR    conf - conf.c:run_buffer:323 - Script exited with status 25
lxc-start 452 20230913122240.841 ERROR    start - start.c:lxc_init:797 - Failed to run lxc.hook.pre-start for container "452"
lxc-start 452 20230913122240.841 ERROR    start - start.c:__lxc_start:1896 - Failed to initialize container "452"
lxc-start 452 20230913122240.841 INFO     conf - conf.c:run_script_argv:340 - Executing script "/usr/share/lxcfs/lxc.reboot.hook" for container "452", config section "lxc"
lxc-start 452 20230913122241.344 INFO     conf - conf.c:run_script_argv:340 - Executing script "/usr/share/lxc/hooks/lxc-pve-poststop-hook" for container "452", config section "lxc"
lxc-start 452 20230913122242.112 ERROR    lxc_start - tools/lxc_start.c:main:308 - The container failed to start
lxc-start 452 20230913122242.112 ERROR    lxc_start - tools/lxc_start.c:main:314 - Additional information can be obtained by setting the --logfile and --logpriority options

Very less information.
The Information about PVE version:

Code:
proxmox-ve: 6.3-1 (running kernel: 5.4.73-1-pve)
pve-manager: 6.3-2 (running version: 6.3-2/22f57405)
pve-kernel-5.4: 6.3-1
pve-kernel-helper: 6.3-1
pve-kernel-5.4.73-1-pve: 5.4.73-1
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.4-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.16-pve1
libproxmox-acme-perl: 1.0.5
libproxmox-backup-qemu0: 1.0.2-1
libpve-access-control: 6.1-3
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.2-6
libpve-guest-common-perl: 3.1-3
libpve-http-server-perl: 3.0-6
libpve-storage-perl: 6.3-1
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.3-1
lxcfs: 4.0.3-pve3
novnc-pve: 1.1.0-1
proxmox-backup-client: 1.0.5-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.4-3
pve-cluster: 6.2-1
pve-container: 3.3-1
pve-docs: 6.3-1
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-3
pve-firmware: 3.1-3
pve-ha-manager: 3.1-1
pve-i18n: 2.2-2
pve-qemu-kvm: 5.1.0-7
pve-xtermjs: 4.7.0-3
qemu-server: 6.3-1
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 0.8.5-pve1

The other system, where the lxc will start:
Code:
proxmox-ve: 6.3-1 (running kernel: 5.4.73-1-pve)
pve-manager: 6.3-2 (running version: 6.3-2/22f57405)
pve-kernel-5.4: 6.3-1
pve-kernel-helper: 6.3-1
pve-kernel-5.4.73-1-pve: 5.4.73-1
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.4-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.16-pve1
libproxmox-acme-perl: 1.0.5
libproxmox-backup-qemu0: 1.0.2-1
libpve-access-control: 6.1-3
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.2-6
libpve-guest-common-perl: 3.1-3
libpve-http-server-perl: 3.0-6
libpve-storage-perl: 6.3-1
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.3-1
lxcfs: 4.0.3-pve3
novnc-pve: 1.1.0-1
proxmox-backup-client: 1.0.5-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.4-3
pve-cluster: 6.2-1
pve-container: 3.3-1
pve-docs: 6.3-1
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-3
pve-firmware: 3.1-3
pve-ha-manager: 3.1-1
pve-i18n: 2.2-2
pve-qemu-kvm: 5.1.0-7
pve-xtermjs: 4.7.0-3
qemu-server: 6.3-1
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 0.8.5-pve1

I use ZFS for Container. The Container i can mount. Do you need more Information?


With regards,

Michael
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!